Announcement

Collapse
No announcement yet.

RGBW Lights not displaying in IH?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • RGBW Lights not displaying in IH?

    I setup 3 Lightify RGBW strips about a month ago and finally getting around to creating the dashboard for them.

    As you can see in the screenshot, they are in (for over a month) Homeseer's IH plugin config... but they never show in IH even thought the 'Colors' group shows ... there are 0 devices?

    Any ideas how to fix?

    thx!
    Attached Files
    Last edited by Ltek; January 26th, 2018, 11:07 AM.

  • #2
    Have you hit reload in IH?
    Do you see the device in the trace logs?

    Comment


    • #3
      Originally posted by spud View Post
      Have you hit reload in IH?
      Do you see the device in the trace logs?
      100 times at least... its been a month.

      There is definitely a problem. Here's a new trace log...

      Dec-24 16:26:59 DEBUG Device 243 value changed from 432 to 433
      Dec-24 16:26:59 DEBUG Device 527 value changed from 8 to 9
      Dec-24 16:27:18 DEBUG Device 400 value changed from 0 to 255
      Dec-24 16:27:18 DEBUG ISSCache: Security Device Motion (id=13) added or updated
      Dec-24 16:27:19 DEBUG Device 331 value changed from 0 to 1
      Dec-24 16:27:19 DEBUG ISSCache: Security Device Motion (id=14) added or updated
      Dec-24 16:27:19 DEBUG Device 328 string changed to FAULT 02 MAIN ROOM MOTION
      Dec-24 16:27:19 DEBUG Device 187 value changed from 0 to 1
      Dec-24 16:27:19 DEBUG ISSCache: Sensor All Motion Sensors (id=29) added or updated
      Dec-24 16:27:19 DEBUG Device 187 string changed to Dining Room Motion<br>
      Dec-24 16:27:19 DEBUG ISSCache: Sensor All Motion Sensors (id=29) added or updated
      Dec-24 16:27:19 DEBUG Device 161 value changed from 0 to 8
      Dec-24 16:27:19 DEBUG Device 165 value changed from 0 to 255
      Dec-24 16:27:19 DEBUG ISSCache: Security Device Motion (id=6) added or updated
      Dec-24 16:27:19 DEBUG Device 187 value changed from 1 to 0
      Dec-24 16:27:19 DEBUG ISSCache: Sensor All Motion Sensors (id=29) added or updated
      Dec-24 16:27:19 DEBUG Device 187 string changed to No Motion
      Dec-24 16:27:19 DEBUG ISSCache: Sensor All Motion Sensors (id=29) added or updated
      Dec-24 16:27:19 DEBUG Device 187 value changed from 0 to 1
      Dec-24 16:27:19 DEBUG ISSCache: Sensor All Motion Sensors (id=29) added or updated
      Dec-24 16:27:19 DEBUG Device 187 string changed to Living Room Motion<br>
      Dec-24 16:27:19 DEBUG ISSCache: Sensor All Motion Sensors (id=29) added or updated
      Dec-24 16:27:19 DEBUG Device 187 string changed to Living Room Motion<br>Dining Room Motion<br>
      Dec-24 16:27:19 DEBUG ISSCache: Sensor All Motion Sensors (id=29) added or updated
      Dec-24 16:27:20 DEBUG Device 161 changed
      Dec-24 16:27:23 DEBUG Device 328 string changed to FAULT 04 BASEMENT DOOR
      Dec-24 16:27:23 DEBUG Device 328 string changed to FAULT 02 MAIN ROOM MOTION
      Dec-24 16:27:24 DEBUG Device 400 value changed from 255 to 0
      Dec-24 16:27:24 DEBUG ISSCache: Security Device Motion (id=13) added or updated
      Dec-24 16:27:27 DEBUG Device 328 string changed to FAULT 04 BASEMENT DOOR
      Dec-24 16:27:29 DEBUG Device 400 value changed from 0 to 255
      Dec-24 16:27:29 DEBUG ISSCache: Security Device Motion (id=13) added or updated
      Dec-24 16:27:31 DEBUG Device 328 string changed to FAULT 02 MAIN ROOM MOTION
      Dec-24 16:27:34 DEBUG Device 328 string changed to FAULT 04 BASEMENT DOOR
      Dec-24 16:27:36 DEBUG Device 400 value changed from 255 to 0
      Dec-24 16:27:36 DEBUG ISSCache: Security Device Motion (id=13) added or updated
      Dec-24 16:27:37 DEBUG Device 116 value changed from 265.339 to 265.342
      Dec-24 16:27:37 DEBUG Device 117 value changed from 2.188 to 1514.389
      Dec-24 16:27:48 DEBUG Device 331 value changed from 1 to 0
      Dec-24 16:27:48 DEBUG ISSCache: Security Device Motion (id=14) added or updated
      Dec-24 16:27:48 DEBUG Device 187 value changed from 1 to 0
      Dec-24 16:27:48 DEBUG ISSCache: Sensor All Motion Sensors (id=29) added or updated
      Dec-24 16:27:48 DEBUG Device 187 string changed to No Motion
      Dec-24 16:27:48 DEBUG ISSCache: Sensor All Motion Sensors (id=29) added or updated
      Dec-24 16:27:48 DEBUG Device 187 value changed from 0 to 1
      Dec-24 16:27:48 DEBUG ISSCache: Sensor All Motion Sensors (id=29) added or updated
      Dec-24 16:27:48 DEBUG Device 187 string changed to Living Room Motion<br>
      Dec-24 16:27:48 DEBUG ISSCache: Sensor All Motion Sensors (id=29) added or updated
      Dec-24 16:27:53 DEBUG Start building cache
      Dec-24 16:27:53 ERROR System.NullReferenceException: Object reference not set to an instance of an object.
      at HSPI_ImperiHome.ISSDeviceRGBLight.GetRGBValuesFromDevices(RG BLight rgb)
      at HSPI_ImperiHome.ISSDeviceRGBLight.FromRGBLight(RGBLight rgb)
      Dec-24 16:27:53 ERROR System.NullReferenceException: Object reference not set to an instance of an object.
      at HSPI_ImperiHome.ISSDeviceRGBLight.GetRGBValuesFromDevices(RG BLight rgb)
      at HSPI_ImperiHome.ISSDeviceRGBLight.FromRGBLight(RGBLight rgb)
      Dec-24 16:27:53 ERROR System.NullReferenceException: Object reference not set to an instance of an object.
      at HSPI_ImperiHome.ISSDeviceRGBLight.GetRGBValuesFromDevices(RG BLight rgb)
      at HSPI_ImperiHome.ISSDeviceRGBLight.FromRGBLight(RGBLight rgb)
      Dec-24 16:27:53 DEBUG End building cache
      Dec-24 16:27:59 DEBUG Device 243 value changed from 433 to 434
      Dec-24 16:27:59 DEBUG Device 527 value changed from 9 to 10
      Dec-24 16:28:00 DEBUG Device 161 value changed from 8 to 0
      Dec-24 16:28:00 DEBUG Device 165 value changed from 255 to 0
      Dec-24 16:28:00 DEBUG ISSCache: Security Device Motion (id=6) added or updated
      Dec-24 16:28:00 DEBUG Device 187 value changed from 1 to 0
      Dec-24 16:28:00 DEBUG ISSCache: Sensor All Motion Sensors (id=29) added or updated
      Dec-24 16:28:00 DEBUG Device 187 string changed to No Motion
      Dec-24 16:28:00 DEBUG ISSCache: Sensor All Motion Sensors (id=29) added or updated
      Dec-24 16:28:02 DEBUG Device 161 changed
      Dec-24 16:28:07 DEBUG Device 117 value changed from 1514.389 to 2.171
      Dec-24 16:28:13 DEBUG Device 707 value changed from 1 to 0
      Dec-24 16:28:13 DEBUG Device 707 string changed to Disconnected
      Dec-24 16:28:22 DEBUG Device 607 value changed from 4 to 1
      Dec-24 16:28:37 DEBUG Device 116 value changed from 265.342 to 265.345
      Dec-24 16:28:59 DEBUG Device 243 value changed from 434 to 435
      Dec-24 16:28:59 DEBUG Device 527 value changed from 10 to 11

      Comment


      • #4
        Spud
        How can we troubleshoot this problem? The problem is persistent across many IH updates and changes to Homeseer

        Thx

        Sent from my SM-G950U using Tapatalk

        Comment


        • #5
          How those "Zigbee Cameras Colors..." devices are defined, do they have a range defined as a control?

          Comment


          • #6
            Originally posted by spud View Post
            How those "Zigbee Cameras Colors..." devices are defined, do they have a range defined as a control?
            Attached is the correct screenshot showing both the plugi config, and Homeseer admin console for them. I can properly control the lights from Homeseer and Homeseer properly shows the status when controlling from the Lightify app. The only thing that has never worked is they dont show in the IH Plugin.
            Attached Files

            Comment


            • #7
              the IH plugin expect the 3 different RGB devices with 3 control ranges, so this kind of configuratio with a color picker control is not supported yet. I will add it soon.

              Comment


              • #8
                Originally posted by spud View Post
                the IH plugin expect the 3 different RGB devices with 3 control ranges, so this kind of configuratio with a color picker control is not supported yet. I will add it soon.
                Ah, cool thanks for continuing to improve your plugin,!

                Sent from my SM-G950U using Tapatalk

                Comment


                • #9
                  Done in version 3.0.0.27 available in the Beta section of the updater.

                  In the RGB Lights tab select ColorPicker as the Color Model, then select your color picker device.

                  Comment


                  • #10
                    Originally posted by spud View Post
                    Done in version 3.0.0.27 available in the Beta section of the updater.

                    In the RGB Lights tab select ColorPicker as the Color Model, then select your color picker device.

                    here's what I get spud; I have a fibaro rgbw Version: 3.52 (ZDK 4.54.2) Firmware: 25.25

                    Feb-05 4:38:17 PM ImperiHome ERROR System.NullReferenceException: Object reference not set to an instance of an object. at HSPI_ImperiHome.ISSDeviceRGBLight.FromRGBLight(RGBLight rgb)

                    Comment


                    • #11
                      Originally posted by wadesready View Post
                      here's what I get spud; I have a fibaro rgbw Version: 3.52 (ZDK 4.54.2) Firmware: 25.25

                      Feb-05 4:38:17 PM ImperiHome ERROR System.NullReferenceException: Object reference not set to an instance of an object. at HSPI_ImperiHome.ISSDeviceRGBLight.FromRGBLight(RGBLight rgb)
                      I don't have fibaro RGBW lights to test with, so I would need a little more information.

                      How have you configured them in the IH plugin config page?
                      How do they look like in homeseer? Is there a device with a color picker?
                      Could you post some screenshots, and a full Trace log.

                      Comment


                      • #12
                        Originally posted by spud View Post
                        I don't have fibaro RGBW lights to test with, so I would need a little more information.

                        How have you configured them in the IH plugin config page?
                        How do they look like in homeseer? Is there a device with a color picker?
                        Could you post some screenshots, and a full Trace log.
                        yes there is a color picker. I will get you a trace log. but here is a screen shot for you to start with.
                        Attached Files

                        Comment


                        • #13
                          fibaro rgbw

                          this is all the trace log shows spud for the color picker. I will change it back to individual switches and get more info for you.

                          Feb-05 5:09:18 PM ImperiHome ERROR System.NullReferenceException: Object reference not set to an instance of an object. at HSPI_ImperiHome.ISSDeviceRGBLight.FromRGBLight(RGBLight rgb) Feb-05 5:09:18 PM ImperiHome ERROR Color string {0} is not a valid hex color

                          Comment


                          • #14
                            trace log for individual switches from fibaro.

                            "room":"LLivingroom","type":"DevSwitch","params":[{"key":"pulseable","value":"0"},{"key":"Status","value":" 0"}]},{"id":"D248","name":"Switch Multilevel 1","room":"LLivingroom","type":"DevDimmer","params":[{"key":"Level","value":"0"},{"key":"Status","value":"0"}]},{"id":"D249","name":"Switch 2 Green","room":"LLivingroom","type":"DevDimmer","params":[{"key":"Level","value":"0"},{"key":"Status","value":"0"}]},{"id":"D250","name":"Switch 3 Red","room":"LLivingroom","type":"DevDimmer","params":[{"key":"Level","value":"0"},{"key":"Status","value":"0"}]},{"id":"D251","name":"Switch 4 Blue","room":"LLivingroom","type":"DevDimmer","params":[{"key":"Level","value":"0"},{"key":"Status","value":"0"}]},{"id":"D252","name":"Switch 5 White","room":"LLivingroom","type":"DevDimmer","params":[{"key":"Level","value":"0"}

                            Comment


                            • #15
                              Originally posted by wadesready View Post
                              this is all the trace log shows spud for the color picker. I will change it back to individual switches and get more info for you.

                              Feb-05 5:09:18 PM ImperiHome ERROR System.NullReferenceException: Object reference not set to an instance of an object. at HSPI_ImperiHome.ISSDeviceRGBLight.FromRGBLight(RGBLight rgb) Feb-05 5:09:18 PM ImperiHome ERROR Color string {0} is not a valid hex color
                              I have fixed this error in version 3.0.0.28
                              But note that your current configuration will not work both ways because the device with the color picker does not report the current color in its status. So you may be able to select the color using the IH app, but the app will not show the correct current color.

                              Instead of color model = color picker, you should try color model = RGB, and then select your 3 "Color Control Red/Green/Blue Channel" devices.
                              Last edited by spud; February 5th, 2018, 05:30 PM.

                              Comment

                              Working...
                              X