Announcement

Collapse
No announcement yet.

Thermostat heat and cool set points

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Thermostat heat and cool set points

    I read in another thread that the plugin (or maybe Imperihome) decides which set point to display based on the one that is closest to the actual temperature. This is causing me all kinds of problems. I have heating-only systems in a vacation home and when the house is vacant we turn the heat set point down to 45. Because they are heating-only I can't even get to the cool set point to change it. If the house happens to be 60 and the cool set point is 70 then it looks like our house is set to warm up to 70. Very misleading.

    Is there any way to have a setting on the thermostat screen that specifies whether the thermostat is heating-only, heat/cool, cool-only, and then show the relevant set point? In a heat/cool system I think the logic makes some sense. Unfortunately in a heating-only system it can be very misleading.

    Thanks for any help you can provide.

  • #2
    Originally posted by beerguy View Post
    I read in another thread that the plugin (or maybe Imperihome) decides which set point to display based on the one that is closest to the actual temperature. This is causing me all kinds of problems. I have heating-only systems in a vacation home and when the house is vacant we turn the heat set point down to 45. Because they are heating-only I can't even get to the cool set point to change it. If the house happens to be 60 and the cool set point is 70 then it looks like our house is set to warm up to 70. Very misleading.

    Is there any way to have a setting on the thermostat screen that specifies whether the thermostat is heating-only, heat/cool, cool-only, and then show the relevant set point? In a heat/cool system I think the logic makes some sense. Unfortunately in a heating-only system it can be very misleading.

    Thanks for any help you can provide.
    Maybe I am missing something. But I think there is a widget that does what you are looking for. On your screen in edit mode, select a blank spot, click "data", find your thermostat, choose "Thermostat Widget".

    Here is a picture of mine. The top # is current temp, Middle is mode (Hoeat or Cool), the bottom is the setpoint with -/+ controls to change it.

    Hope this helps.
    Jim
    Click image for larger version

Name:	20180603_151829.jpg
Views:	1
Size:	45.9 KB
ID:	1196996

    Comment


    • #3
      Hi Jim -
      Thanks for your reply. Unfortunately on IOS it looks quite different. Maybe I'm doing something wrong but I only have one choice in Device Widgets for thermostats. You will see from the attached picture what is going on. All my zones are heating-only. The device called 1555 Kitchen set point is set to 65.5 and the room temperature is 70 so it shows the heat set point. But on the 1555 Bunk Room, the heat set point is 50, the cool set point is 75, the actual temperature is 69.5, so Cool is closer than Heat so it shows the Cool set point, which is pointless because these are heating-only zones.

      Hopefully it's just user error but I can't see any other settings to solve this.

      Thanks again for the reply.

      Pat



      Originally posted by JMarias View Post
      Maybe I am missing something. But I think there is a widget that does what you are looking for. On your screen in edit mode, select a blank spot, click "data", find your thermostat, choose "Thermostat Widget".

      Here is a picture of mine. The top # is current temp, Middle is mode (Hoeat or Cool), the bottom is the setpoint with -/+ controls to change it.

      Hope this helps.
      Jim
      [ATTACH]69165[/ATTACH]
      Attached Files

      Comment


      • #4
        Originally posted by beerguy View Post
        Hi Jim -
        Thanks for your reply. Unfortunately on IOS it looks quite different. Maybe I'm doing something wrong but I only have one choice in Device Widgets for thermostats. You will see from the attached picture what is going on. All my zones are heating-only. The device called 1555 Kitchen set point is set to 65.5 and the room temperature is 70 so it shows the heat set point. But on the 1555 Bunk Room, the heat set point is 50, the cool set point is 75, the actual temperature is 69.5, so Cool is closer than Heat so it shows the Cool set point, which is pointless because these are heating-only zones.

        Hopefully it's just user error but I can't see any other settings to solve this.

        Thanks again for the reply.

        Pat
        Why do you have a cool setpoint if your zone is heating only?
        what kind of thermostat do you use?
        can't you either delete the cool setpoint device, or set it to a very high value?

        Comment


        • #5
          I've got an Ecobee and two CT-100s. Even though the thermostats themselves are set for Heating-only they all created Cool set point devices. I typically just hide the Cooling set point. I've had issues in the past deleting a child device and then needing it later and not being able to get it back without deleting the device and starting over which is a pain with Events. I'm open to any suggestions though. If deleting the device is the best approach I'll do that.

          Comment


          • #6
            Wouldn't it be easiest if it respected the "Hide device from Mobile Views" checkbox?

            Comment


            • #7
              Originally posted by beerguy View Post
              Wouldn't it be easiest if it respected the "Hide device from Mobile Views" checkbox?
              Unfortunately, I don't think the hidden attribute is available from the API.

              I may add an option to fix this problem in the next version.

              Comment

              Working...
              X