Announcement

Collapse
No announcement yet.

Temperature setpoint is taken from heating setpoint and not the actual mode

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Temperature setpoint is taken from heating setpoint and not the actual mode

    Hi
    When the thermostat is in energy save mode, then the imperihome app still show the setpoint from heating setpoint. (Or is this random which one it pics?)

    So in my case , it show energy setpoint in the app, and it show the room temperature correctly, but setpoint is wrong. It show 19 degrees, instead of 13 degrees which is the current energy save mode setpoint.
    Is it possible to fix this?

    Free online storage and sharing with Screencast.com. 2 GB of storage and 2 GB of bandwidth per month for free. We won't compress, alter or take ownership of your content.

  • #2
    The imperihome plug-in expect only 2 setpoint devices, one for heat and one for cool, and it display in the imperihome app the one the closest to the ambient temp.

    What kind of thermostat is it? If it is handled by a specific plugin, you may ask the developer to only create 2 setpoint devices (Heat/Cool) and update their value depending on the thermostat mode.

    Comment


    • #3
      It is a normal zwave floor thermostat, handled by zwave plugin
      Here you can see the complete device list for that thermostat
      Free online storage and sharing with Screencast.com. 2 GB of storage and 2 GB of bandwidth per month for free. We won't compress, alter or take ownership of your content.

      Comment


      • #4
        I have the same problem, I didn't know imperihome wrote some logic into that does not make sense to me. If my Thermostat is set to heat, it should show the heat values not the cold values. I have ecobee Thermostats. So the request should go to them? Sorry if I intrude in the conversation


        Sent from my SM-G935V using Tapatalk

        Comment


        • #5
          This has been this way in Imperihome for some time. The key is to not set you heat and A/C setpoints so close. So like right now for winter if your not running A/C turn that setpoint to something high like 80 degrees. Then your heat setpoint say 70 will always be closer to your actual temp and it will always only show heat setpoint.

          Comment


          • #6
            Originally posted by integlikewhoa View Post
            This has been this way in Imperihome for some time. The key is to not set you heat and A/C setpoints so close. So like right now for winter if your not running A/C turn that setpoint to something high like 80 degrees. Then your heat setpoint say 70 will always be closer to your actual temp and it will always only show heat setpoint.
            Ok, so basically if i set energy mode on, i also set the heatsetpoint high at the same time?
            Or another way to do it, is to only adjust heating setpoint, and forget the energy mode, maybe that is even better?

            Comment


            • #7
              I managed to fix the correct setpoint shown in imperihome, by setting the cool setpoint high.
              But i have a different problem with the actual temperature

              The Thermostat has 2 temperature devices.
              1. External sensor (Not connected, and showing 0 degrees)
              2. Floor sensor (This is used, and show example 19 degrees)

              In imperihome it show correct setpoint temperature, 21 degrees , but the temperature is shown as 0 degrees instead of 19 degrees.
              How can i fool imperihome to check the Floor sensor instead of the External sensor?
              As far as i can see, both devices are equally setup.

              https://www.screencast.com/t/lH32iUEZP8C

              Comment

              Working...
              X