Announcement

Collapse
No announcement yet.

ImperiHome Plug-in - Beta Testing

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Thanks! That worked. Why oh why did I not think of that.
    _______________________________________________

    HS3 : HSpro (3.0.0.460) on Win2012 (vm on ESXi)
    Plugins: HSTouch, UPBSpud, Kinect, Nest, IFTTT, DirecTV, EasyTrigger, Imperihome, Zwave, RFXcom, UltraMon3, UltraWeatherBug3, UltraGCIR3, UltraLog3, UltraPioneer, PHLocation, Pushover, Pushalot, MCSSPrinklers S, JowiHue
    Jon00 Plugins: Bluetooth Proximity, Performance Monitor, DB Chart, Links

    Comment


    • ImperiHome Plug-in - Beta Testing

      It looks like the latest iOS imperihome beta has Nest support. It seems to so far not display the correct temperature or unit. At least with the Nest plugin and adding the nest as a thermostat using the API it shows the temperature correctly with correct unit with latest released iOS app.
      Last edited by jlrichar; March 25th, 2016, 09:54 AM.
      _______________________________________________

      HS3 : HSpro (3.0.0.460) on Win2012 (vm on ESXi)
      Plugins: HSTouch, UPBSpud, Kinect, Nest, IFTTT, DirecTV, EasyTrigger, Imperihome, Zwave, RFXcom, UltraMon3, UltraWeatherBug3, UltraGCIR3, UltraLog3, UltraPioneer, PHLocation, Pushover, Pushalot, MCSSPrinklers S, JowiHue
      Jon00 Plugins: Bluetooth Proximity, Performance Monitor, DB Chart, Links

      Comment


      • Hi spud,

        I frequently get this message in the log when creating new HS devices (not related to the plugin):


        Apr-10 4:25:23 PM ImperiHome ERROR System.NullReferenceException: Object reference not set to an instance of an object. at HSPI_ImperiHome.ISSDeviceObject.FromDevice(DeviceClass dev) at HSPI_ImperiHome.ISSCache.UpdateDevice(Int32 dvRef)

        Thoughts?

        Thanks
        Al
        HS 3.0.0.548: 1970 Devices 1148 Events
        Z-Wave 3.0.1.262: 123 Nodes on one Z-Net

        Comment


        • Is there a trick to refresh devices / events in the Imperihome iOS app?

          Hi Spud

          I am in trial mode with the plugin and trying to get my devices updated. Initially it populated all my events (hundreds) and a few of the devices out of hundreds with the ControlUse settings set.

          I decided that the Events were causing a lot of noise, so I unchecked all the event groups in the PI config.

          I also created 5 security devices and 2 cameras.

          Whatever I do, I cannot get this to refresh in the app. I am still showing all the events and I cannot see the new security devices and cameras.

          I have restarted the iOS app, restarted the PI, restarted HS3 etc etc and I cannot get it to refresh.

          I am currently remote, but the router and firewall are not issues as I can control the devices that I can see.

          One thing that I have noticed in the app (and I doubt this is related), is that when I try and select devices for a multi-device switch, I cannot actually select anything.

          Any ideas what I might be doing wrong?

          I am on HS3 3.0.0.286 on Win 10 Home, running v3.0.0.8 of the plugin and 1.5.2 of the iOS Imperihome app

          Cheers
          James
          cheeryfool

          Comment


          • Originally posted by cheeryfool View Post
            Hi Spud

            I am in trial mode with the plugin and trying to get my devices updated. Initially it populated all my events (hundreds) and a few of the devices out of hundreds with the ControlUse settings set.

            I decided that the Events were causing a lot of noise, so I unchecked all the event groups in the PI config.

            I also created 5 security devices and 2 cameras.

            Whatever I do, I cannot get this to refresh in the app. I am still showing all the events and I cannot see the new security devices and cameras.

            I have restarted the iOS app, restarted the PI, restarted HS3 etc etc and I cannot get it to refresh.

            I am currently remote, but the router and firewall are not issues as I can control the devices that I can see.

            One thing that I have noticed in the app (and I doubt this is related), is that when I try and select devices for a multi-device switch, I cannot actually select anything.

            Any ideas what I might be doing wrong?

            I am on HS3 3.0.0.286 on Win 10 Home, running v3.0.0.8 of the plugin and 1.5.2 of the iOS Imperihome app

            Cheers
            James
            first to figure out if the problem is on the plugin side or on imperihome side, set the log level to Trace from the config page, then open the app on iOS.

            You should see the json data that is sent to the app in the logs, if you still see the events you have filtered out in this data, then the problem is on the plugin side, in this case a restart should have fixed it.
            If the problem is on the imperihome app, tap the gear icon on the right and then select Reload.

            Comment


            • Originally posted by spud View Post
              If the problem is on the imperihome app, tap the gear icon on the right and then select Reload.

              And there you have it! Not sure why I didn't see the Reload button, but that works a charm. Thanks much. Now to play with this.
              cheeryfool

              Comment


              • I just installed/bought the plug in, i really love how fast it is to setup.

                Thanks for a great plugin, hope development continues

                Comment


                • Originally posted by spud View Post
                  ... In the current Beta version the following object will automatically be exposed
                  • ...
                    ...
                  • Thermostats (any group of HS devices that implement the Thermostat API)
                    ...
                  I've just started playing around with your plugin and ImperiHome. Looks very promising! Thanks for your contribution.

                  I have a 2441TH thermostat. I have access to most of its functions from ImperiHome. But I don't seem to have access to the program capability of the unit; in other words, I can't set a defined program ('programs' tab on Nathan's plugin); that device has its Control-status set to 'both'. Am I missing something or is this simply beyond your plugin's scope?

                  Comment


                  • Originally posted by claude View Post
                    I've just started playing around with your plugin and ImperiHome. Looks very promising! Thanks for your contribution.

                    I have a 2441TH thermostat. I have access to most of its functions from ImperiHome. But I don't seem to have access to the program capability of the unit; in other words, I can't set a defined program ('programs' tab on Nathan's plugin); that device has its Control-status set to 'both'. Am I missing something or is this simply beyond your plugin's scope?

                    The imperihome thermostat widget can only have controls for Mode and Fan Mode. If "Program" is a different thing then you won't be able to control it from the thermostat widget, however you can create an independent mutiswitch device for this control.

                    Comment


                    • Got it, thanks.

                      Comment


                      • Originally posted by sparkman View Post
                        Hi spud, thanks for the update. For the events tab, would it be possible to have an option to deselect them all, or deselect all in an event group? Also, new events get enabled by default. I would prefer to have them disabled by default. Would it be possible to add an option to allow each user to select whether the default is enabled or disabled? I'm planning on 3 or 4 instances of the plugin and manually disabling most events will be a lot of work.
                        Hi spud, any possibility of this option being added? Also any ETA on the whitelist for devices?

                        Thanks
                        Al
                        HS 3.0.0.548: 1970 Devices 1148 Events
                        Z-Wave 3.0.1.262: 123 Nodes on one Z-Net

                        Comment


                        • Originally posted by sparkman View Post
                          Hi spud, any possibility of this option being added? Also any ETA on the whitelist for devices?

                          Thanks
                          Al
                          I will add an option for new events to be not selected by default in the next version, which will be released in the forum probably this week.

                          Regarding the whitelist of devices, no ETA yet, I have to finish adding support for RGB lights first

                          Comment


                          • Originally posted by spud View Post
                            I will add an option for new events to be not selected by default in the next version, which will be released in the forum probably this week.

                            Regarding the whitelist of devices, no ETA yet, I have to finish adding support for RGB lights first
                            Thanks!
                            HS 3.0.0.548: 1970 Devices 1148 Events
                            Z-Wave 3.0.1.262: 123 Nodes on one Z-Net

                            Comment


                            • in version 3.0.0.12 I have added a "Events enabled by default" checkbox in the Settings tab, if you untick it then all your events are disabled by default in the Events tab (i.e not sent to the ImperiHome app)

                              In the same version, I have added a "Cache Rebuild" button that let the plug-in rescan all your events and devices. This is useful for example if a configuration change on a device is not picked up by the plug-in, it avoids having to disable and enable the plug-in.

                              Comment


                              • Originally posted by spud View Post
                                in version 3.0.0.12 I have added a "Events enabled by default" checkbox in the Settings tab, if you untick it then all your events are disabled by default in the Events tab (i.e not sent to the ImperiHome app)

                                In the same version, I have added a "Cache Rebuild" button that let the plug-in rescan all your events and devices. This is useful for example if a configuration change on a device is not picked up by the plug-in, it avoids having to disable and enable the plug-in.
                                Great, thanks!
                                HS 3.0.0.548: 1970 Devices 1148 Events
                                Z-Wave 3.0.1.262: 123 Nodes on one Z-Net

                                Comment

                                Working...
                                X