Announcement

Collapse
No announcement yet.

ImperiHome Plug-in - Beta Testing

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    I figured some kind of authentication must be coming, but was looking for confirmation. That's excellent news.

    So far testing had been very good (particularly for an Alpha). You've clearly been hard at work for some time on this and done a ton of internal testing before opening this up to the unwashed masses.

    Definitely off to a very promising start.
    My home is smarter than your honor roll student.

    Comment


    • #32
      Made a new group event to day, did not show inn the app. Had to disable/enable the plugin within Homeseer.

      Keep up the good work

      Comment


      • #33
        Originally posted by spud View Post
        it means the plugin cannot access the web server created by the plugin on port 8072.
        From a browser on your ipad, enter http://XXX.YYY.ZZZ.WWW:8072/issapi/system

        where XXX.YYY.ZZZ.WWW is the local IP of your HS3 machine as it shows up in the ImperiHome config page. You should get the following json string in return:
        Code:
        {"id":"HS3","apiversion":1}
        if you don't maybe you have firewall or antivirus blocking port 8072 on your HS3 machine?
        I tried opening a browser and entering address with no luck. I turned off the firewall completely and still can't get thru. I event forwarded a port but no luck.
        Hector
        ____________________________________
        Win.2003 OS, HS3
        BLDSC,BLstat,BLRadar,BLRamdom,BLOccupied
        BLups,BLrain8,HSTouch,Ultrajones Weatherbug,
        MyTrigger,ACRF2,W800,Zwave
        AP800,Honeywell Stat

        Comment


        • #34
          Originally posted by Rotech View Post
          I tried opening a browser and entering address with no luck. I turned off the firewall completely and still can't get thru. I event forwarded a port but no luck.
          can you access http://XXX.YYY.ZZZ.WWW:8072/issapi/system from a browser running on your HS3 machine?

          set the log level to debug then restart the plugin, do you have any error in the logs?

          Comment


          • #35
            Spud, I shut down HS and restarted PC , then I turned off local firewall then it communicated. If I turn back on the firewall it doesn't work. What can I do?
            Hector
            ____________________________________
            Win.2003 OS, HS3
            BLDSC,BLstat,BLRadar,BLRamdom,BLOccupied
            BLups,BLrain8,HSTouch,Ultrajones Weatherbug,
            MyTrigger,ACRF2,W800,Zwave
            AP800,Honeywell Stat

            Comment


            • #36
              You could add an exception to the firewall for the application but out of curiosity why are you running a local firewall?

              Comment


              • #37
                Originally posted by kideon View Post
                You could add an exception to the firewall for the application but out of curiosity why are you running a local firewall?
                My pc came with it on, should I turn it off?
                Hector
                ____________________________________
                Win.2003 OS, HS3
                BLDSC,BLstat,BLRadar,BLRamdom,BLOccupied
                BLups,BLrain8,HSTouch,Ultrajones Weatherbug,
                MyTrigger,ACRF2,W800,Zwave
                AP800,Honeywell Stat

                Comment


                • #38
                  Definitely your router should handle all firewall duties. You may want to kill Windows defender as well and use a virus protector on your main file server.

                  Comment


                  • #39
                    Hi, for the people that have problem to get the API url to work.
                    Check that you not have multiple Newtonsoft.Json.dll with different versions in hs3 folders. Search for the file, take a backup and place them outside of hs3.
                    Download the latest json from https://github.com/JamesNK/Newtonsoft.Json/releases

                    Open the zipfile, copy the files in Bin/Net45 folder to Homeseer Bin folder.
                    Restart the plugin.
                    Hope it helps.
                    Please excuse any spelling and grammatical errors I may make.
                    --
                    Tasker Plugin / Speech Droid
                    Tonlof | Sweden

                    Comment


                    • #40
                      Originally posted by tonlof View Post
                      Hi, for the people that have problem to get the API url to work.
                      Check that you not have multiple Newtonsoft.Json.dll with different versions in hs3 folders. Search for the file, take a backup and place them outside of hs3.
                      Download the latest json from https://github.com/JamesNK/Newtonsoft.Json/releases

                      Open the zipfile, copy the files in Bin/Net45 folder to Homeseer Bin folder.
                      Restart the plugin.
                      Hope it helps.
                      If you have a version of Newtonsoft.Json.dll in the root Homeseer folder then yes you need to remove it from there. However I don't think copying one version of this dll to the bin folder is necessary or a good idea; that could cause problems with other plugins. Each plugin is supposed to have all its dependencies in bin/<plugin_name>, for example the ImperiHome plugin installs the Newtonsoft.Json.dll in bin/ImperiHome.

                      Comment


                      • #41
                        Spud, just installed this and this was a missing piece for me from Vera... Kuddos! Please take my money .

                        I am looking forward to seeing the rest of the devices to show up.

                        This won't replace HSTouch for me, except on my phone. It is still limited compared to what HSTouch can do (no fault to you of course), but it fits perfectly for my needs on my phone.

                        Thank you again for doing this.

                        Comment


                        • #42
                          in version 3.0.0.1 available on first post of this thread I have added
                          - support for sensors
                          - support for Locks
                          - optional username/password http authentication

                          A sensor is basically anything that has a numerical value. To add one go to the Sensors tab of the config page, select the type of sensor you want to add, then select the HS device value you to map it to (some sensors type like the "Temperature and Hygrometry combined sensor" can be mapped to 2 device values). Name and Group of the sensor are automatically populated one you select the first device, but they can be overridden as well as the default units.


                          Click image for larger version

Name:	sensors_config.png
Views:	1
Size:	46.4 KB
ID:	1183268

                          Click image for larger version

Name:	sensors.png
Views:	3
Size:	126.9 KB
ID:	1183269

                          Comment


                          • #43
                            Working perfect for me, great work.

                            Comment


                            • #44
                              Is there a way to use the sensors for Motion/Door?
                              Thanks,
                              Frank

                              Comment


                              • #45
                                Originally posted by sirmeili View Post
                                Is there a way to use the sensors for Motion/Door?
                                I'm going to implement Motion and Door sensors as part of another security devices category in the next version.
                                Right now you could use a generic sensor which would show 1 for open and 0 for close (not ideal, I agree)

                                Comment

                                Working...
                                X