Announcement

Collapse
No announcement yet.

ImperiHome Plug-in - Beta Testing

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    Great work Spud! I'm having trouble getting IP Cameras/Kinect to appear. Getting "unsupported URL". Could you show us what settings you're using for IP Cameras?

    Comment


    • #47
      Great Update..... stoked about id/password credentials. Will be giving it a thorough shakedown cruise this weekend. But so far, really liking this. Great find.
      My home is smarter than your honor roll student.

      Comment


      • #48
        Originally posted by frozendevl View Post
        Great work Spud! I'm having trouble getting IP Cameras/Kinect to appear. Getting "unsupported URL". Could you show us what settings you're using for IP Cameras?
        here is how I configure my Kinect camera in the ImperiHome plugin:

        Click image for larger version

Name:	cameras.png
Views:	1
Size:	27.6 KB
ID:	1183280

        192.168.1.xxx being the local IP of my HS3 machine
        xxx.xxx.xxx.xxx being my external IP

        If you are using a kinect of course you need to have the Kinect plugin running and configured as a NetCam. Also make sure you can access the snapshot url from a browser on your mobile device.

        In ImperiHome apps, you sometime have to force a reload before the camera can be accessed.

        Comment


        • #49
          Originally posted by spud View Post
          can you access http://XXX.YYY.ZZZ.WWW:8072/issapi/system from a browser running on your HS3 machine?

          set the log level to debug then restart the plugin, do you have any error in the logs?
          EDIT: SOLVED I am having same trouble Spud
          Can't access through Imperihome setup OR another Ipad
          Firewall is off. (Didn't realize my computer was set with 3 layers of firewalls)
          I get appropriate response from HS3 machine:
          {"id":"HS3","apiversion":1}

          This is HS# log with debug:

          Feb-13 3:15:38 PM Plug-In Finished initializing plug-in ImperiHome
          Feb-13 3:15:38 PM ImperiHome DEBUG ISS server started: http://*:8072/issapi/
          Feb-13 3:15:37 PM ImperiHome INFO ImperiHome version 3.0.0.1
          Feb-13 3:15:37 PM Info Plugin ImperiHome has connected. IP:127.0.0.1:49915
          Feb-13 3:15:37 PM Plug-In Interface ImperiHome is running as a trial, 30 days remaining.
          Feb-13 3:15:19 PM Info Plugin ImperiHome with instance: has disconnected
          Feb-13 3:15:19 PM ImperiHome DEBUG ISS server stopped
          Feb-13 3:15:19 PM Plug-In Shutting down Plug-In: ImperiHome
          Last edited by 519zwave; February 14th, 2016, 08:54 AM. Reason: Solved
          Jim
          ----
          Plugins:Z Wave 3.0.1.55, HS3 Pro 3.0.0.208, HS3Touch, HS3Touch IOS, Z-Net, SceneMaster, XBMC, Sonos, Media Controller, Envisalink (52 Virtual nodes), JowiHue, EasyTrigger, Liftmaster MyQ, BLBackup, BLLAN, BLRadar, Pushover

          Devices:Cooper RF9540, Cooper Scene, Yale Locks, Sonos, Phillips Hue and Lux, DSC, Somfy Blinds

          Comment


          • #50
            Originally posted by 519zwave View Post
            I am having same trouble Spud
            Can't access through Imperihome setup OR another Ipad
            Firewall is off.
            I get appropriate response from HS3 machine:
            {"id":"HS3","apiversion":1}

            This is HS# log with debug:

            Feb-13 3:15:38 PM Plug-In Finished initializing plug-in ImperiHome
            Feb-13 3:15:38 PM ImperiHome DEBUG ISS server started: http://*:8072/issapi/
            Feb-13 3:15:37 PM ImperiHome INFO ImperiHome version 3.0.0.1
            Feb-13 3:15:37 PM Info Plugin ImperiHome has connected. IP:127.0.0.1:49915
            Feb-13 3:15:37 PM Plug-In Interface ImperiHome is running as a trial, 30 days remaining.
            Feb-13 3:15:19 PM Info Plugin ImperiHome with instance: has disconnected
            Feb-13 3:15:19 PM ImperiHome DEBUG ISS server stopped
            Feb-13 3:15:19 PM Plug-In Shutting down Plug-In: ImperiHome
            can you access http://XXX.YYY.ZZZ.WWW:8072/issapi/system from a browser on the mobile device where ImperiHome app is installed?

            what is the error shown in ImperiHome when you set the url http://XXX.YYY.ZZZ.WWW:8072/issapi

            notice the difference between the 2 url
            http://XXX.YYY.ZZZ.WWW:8072/issapi is the one to set in the ImperiHome app
            http://XXX.YYY.ZZZ.WWW:8072/issapi/system is the one to test the plugin in a browser

            Comment


            • #51
              Originally posted by spud View Post
              here is how I configure my Kinect camera in the ImperiHome plugin:

              [ATTACH]52075[/ATTACH]

              192.168.1.xxx being the local IP of my HS3 machine
              xxx.xxx.xxx.xxx being my external IP

              If you are using a kinect of course you need to have the Kinect plugin running and configured as a NetCam. Also make sure you can access the snapshot url from a browser on your mobile device.

              In ImperiHome apps, you sometime have to force a reload before the camera can be accessed.
              Hi spud, trying the plugin for the first time today. Ran into a bug regarding the cameras. If I fill out the login or password field, it populates the remote mjpeg url field instead. Also, I have a few feature requests. Do you want me to make them in this thread, or will you have a separate thread for that?

              Thanks
              Al
              HS 3.0.0.532: 1963 Devices 1141 Events
              Z-Wave 3.0.1.261: 122 Nodes on one Z-Net

              Comment


              • #52
                Originally posted by sparkman View Post
                Hi spud, trying the plugin for the first time today. Ran into a bug regarding the cameras. If I fill out the login or password field, it populates the remote mjpeg url field instead. Also, I have a few feature requests. Do you want me to make them in this thread, or will you have a separate thread for that?

                Thanks
                Al
                nice catch, the bug will be fixed in the next version

                Please post features requests here:
                http://board.homeseer.com/showthread.php?t=179741

                Comment


                • #53
                  Originally posted by spud View Post
                  here is how I configure my Kinect camera in the ImperiHome plugin:

                  [ATTACH]52075[/ATTACH]

                  192.168.1.xxx being the local IP of my HS3 machine
                  xxx.xxx.xxx.xxx being my external IP

                  If you are using a kinect of course you need to have the Kinect plugin running and configured as a NetCam. Also make sure you can access the snapshot url from a browser on your mobile device.

                  In ImperiHome apps, you sometime have to force a reload before the camera can be accessed.
                  Thanks, this looks to be another iOS bug. It works fine on my Android tablet, but gives an unsupported URL on iOS.

                  Comment


                  • #54
                    Originally posted by frozendevl View Post
                    Thanks, this looks to be another iOS bug. It works fine on my Android tablet, but gives an unsupported URL on iOS.
                    it works for me on both iOS and Android
                    is it a Kinect or another kind of camera?

                    Comment


                    • #55
                      Originally posted by spud View Post
                      nice catch, the bug will be fixed in the next version

                      Please post features requests here:
                      http://board.homeseer.com/showthread.php?t=179741
                      Thanks, I also noticed that devices such as lights don't appear in the list of available devices until they have been operated at least once. The control use is set for all of these devices, but are not available in the list until after they have been used once and Imperihome is refreshed.

                      Cheers
                      Al
                      HS 3.0.0.532: 1963 Devices 1141 Events
                      Z-Wave 3.0.1.261: 122 Nodes on one Z-Net

                      Comment


                      • #56
                        I also tried a door lock and all appeared correct when adding it, but when I try to operate it, I get the following error in the log: ImperiHome ERROR can't find Off control for device 1028. The Door Unlock and Door Lock control use properties are set.

                        Cheers
                        Al
                        HS 3.0.0.532: 1963 Devices 1141 Events
                        Z-Wave 3.0.1.261: 122 Nodes on one Z-Net

                        Comment


                        • #57
                          Love the progress that is being made, cant wait for motion and door sensors. Also curious if they will have last tripped info displayed. I currently am switching over form VERA and use imperihome. Door and Window sensors currently display that info.

                          As far as cameras go..... ImperiHome already allows for IP cameras to be added directly and that's how my cameras were added before. I can either go direct to the camera or I use Blueiris and I can also get directly from there.

                          Is there any reason to pass the cameras threw this plugin vs. adding them in Imperihome as a IP camera?

                          Comment


                          • #58
                            Originally posted by sparkman View Post
                            I also tried a door lock and all appeared correct when adding it, but when I try to operate it, I get the following error in the log: ImperiHome ERROR can't find Off control for device 1028. The Door Unlock and Door Lock control use properties are set.

                            Cheers
                            Al
                            it's bug, sorry for that, it will be fixed in version 3.0.0.2

                            Comment


                            • #59
                              Originally posted by integlikewhoa View Post
                              Love the progress that is being made, cant wait for motion and door sensors. Also curious if they will have last tripped info displayed. I currently am switching over form VERA and use imperihome. Door and Window sensors currently display that info.

                              As far as cameras go..... ImperiHome already allows for IP cameras to be added directly and that's how my cameras were added before. I can either go direct to the camera or I use Blueiris and I can also get directly from there.

                              Is there any reason to pass the cameras threw this plugin vs. adding them in Imperihome as a IP camera?
                              No real benefit of adding the cameras through this plugin except for having everything configured from the same place.

                              Comment


                              • #60
                                Spud, great job, I love this plug in, sooooooo fast.
                                Thanks,
                                Aldo

                                Comment

                                Working...
                                X