Announcement

Collapse
No announcement yet.

Door locks don't appear in ImperiHome

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Door locks don't appear in ImperiHome

    Hi there, I have 2 Schlage Z-Wave door locks that work perfect in HS3. In ImperiHome however they don't appear as devices anywhere. I've gone through all floors, there's every device like lamps, thermostats etc but not the locks. Do I have to do something special to make them work?

    I have the free version while I try it out, not sure if that matters.

  • #2
    For the door locks to appear in ImperiHome, the HS devices need to have the Door Lock/Door Unlock "Control Use" set. Could you edit your devices and make sure they have the "Control Use" field set correctly?

    Comment


    • #3
      I saw that in the manual but couldn't find it, I see under the lock itself under status I can set Control Status to Door Unlocked or Door Locked so I did that, but ImperiHome doesn't show the devices. Restarted it, pressed Reload, do I have to do anything to have ImperiHome update the new devices?

      Comment


      • #4
        From the "device management" page, click on the name of your door lock device, then in the "Status Graphics" tab set the "Control Use" to "Door Lock"/ "Door Unlock" for the 2 controls that allow to lock/unlock the door.

        Then click on the "Cache Rebuild" button from the config page or restart the plug-in.

        For example, here is what the "Control Use" field look like for a dimmer:
        Click image for larger version

Name:	controluse.png
Views:	3
Size:	264.0 KB
ID:	1186708

        Comment


        • #5
          I'm also having the same problem. Set the Control Use fields but I don't see a "Cache Rebuild" button anywhere. Have tried disabling/re-enabling the plugin, reloading app, stopping/restarting app, re-starting my HomeTroller SEL. No change.

          Here's a screenshot of my config.
          Attached Files

          Comment


          • #6
            you need to set the Control Use field to "Door Unlock" / "Door Lock", not to On.

            the "Cache Rebuild" button is only in version 3.0.0.12 or later, but restarting should have the same effect.

            so, set the ControlUse fields correctly, then restart the ImperiHome plug-in, then do a Reload from the ImperiHome app.

            Comment


            • #7
              That did it. Thanks spud.

              Comment


              • #8
                I have this set and still not seeing Locks in the app even after a reload.

                Comment


                • #9
                  Originally posted by Sireone View Post
                  I have this set and still not seeing Locks in the app even after a reload.
                  After clicking "cache Rebuild" and then refreshing the page, do you see your door lock in the Door Locks tab of the config page?

                  Comment


                  • #10
                    Originally posted by spud View Post
                    After clicking "cache Rebuild" and then refreshing the page, do you see your door lock in the Door Locks tab of the config page?
                    I do see it on the config page, just not as a widget option in the app.

                    Sent from my Pixel using Tapatalk

                    Comment


                    • #11
                      Originally posted by Sireone View Post
                      I do see it on the config page, just not as a widget option in the app.

                      Sent from my Pixel using Tapatalk
                      Are you sure you tapped the reload button within the app? Restarting the app is not enough.
                      To make sure this is not specific to this door lock device, can you create a fake sensor in the config page, and see if this one appears in IH?

                      Comment


                      • #12
                        Originally posted by spud View Post
                        Are you sure you tapped the reload button within the app? Restarting the app is not enough.
                        To make sure this is not specific to this door lock device, can you create a fake sensor in the config page, and see if this one appears in IH?
                        Yep, hit the Reload link in the top right and showed reloading devices, still no Door Lock as a widget option. I'll try the test device.

                        Sent from my Pixel using Tapatalk
                        Last edited by Sireone; November 1st, 2017, 06:59 PM.

                        Comment


                        • #13
                          After creating a test sensor, it appears in the app, under the Room (location2) for that sensor. I then went back and noticed that the Door Lock was there as well, under the Living room location. I was expecting to see a a separate Door Lock location. Issue resolved!

                          Comment

                          Working...
                          X