Announcement

Collapse
No announcement yet.

Album art squeezebox on HS hard drive

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Album art squeezebox on HS hard drive

    Is there a way to show images from the hard drive (HS server) as a camera snapshot?

    I use the SqueezeBox plugin and this plugin generates for every squeezebox two images that I want to display in IH.
    The files are located in the html dir of HS, for my living room squeezebox like;

    C:\Program Files (x86)\HomeSeer HS3\html\SqueezeBox\AlbumArtwork_Squeezebox Woonkamer_1.current.jpg
    C:\Program Files (x86)\HomeSeer HS3\html\SqueezeBox\Squeezebox Woonkamer_1.current.jpg

    Any help is appreciated.

  • #2
    Yes, I do the same. Just use the URL to the file:

    Code:
    http://www.xxx.yyy.zzz/SqueezeBox/AlbumArtwork_SqueezeboxWoonkamer_1.current.jpg
    Change the www.xxxx.yyy.zzz to the ip address of your homeseer server.

    Cheers
    Al
    HS 3.0.0.548: 1965 Devices 1146 Events
    Z-Wave 3.0.1.262: 122 Nodes on one Z-Net

    Comment


    • #3
      Album art squeezebox on HS hard drive

      Hi Al,

      Thnx for your fast response.
      Unfortunately it shows only a camera picture in IH, so I am missing something.
      Any ideas?
      Attached Files

      Comment


      • #4
        Originally posted by Broes View Post
        Hi Al,

        Thnx for your fast response.
        Unfortunately it shows only a camera picture in IH, so I am missing something.
        Any ideas?
        What happens when you paste that URL in a browser? It should bring the image up as well.

        Cheers
        Al
        HS 3.0.0.548: 1965 Devices 1146 Events
        Z-Wave 3.0.1.262: 122 Nodes on one Z-Net

        Comment


        • #5
          Album art squeezebox on HS hard drive

          Then I get the message that the other side (www.xxxx.yyy.zzz) refused the connection.

          Comment


          • #6
            Originally posted by Broes View Post
            Then I get the message that the other side (www.xxxx.yyy.zzz) refused the connection.
            Do you run HomeSeer's web server on a non-standard port? Something other than port 80? If so, add :aa after the .zzz in the example so http://www.xxx.yyy.zzz:aa/ and change aa to the port number you are using.
            HS 3.0.0.548: 1965 Devices 1146 Events
            Z-Wave 3.0.1.262: 122 Nodes on one Z-Net

            Comment


            • #7
              Album art squeezebox on HS hard drive

              Originally posted by sparkman View Post
              Do you run HomeSeer's web server on a non-standard port? Something other than port 80? If so, add :aa after the .zzz in the example so http://www.xxx.yyy.zzz:aa/ and change aa to the port number you are using.
              Yes, port 86
              But no luck with adding this port number, I get a "404 bad request" back.

              Comment


              • #8
                If there are any spaces in the filename, replace those with %20

                Looking at your original post and my original reply, it looks like I might have dropped a space.
                HS 3.0.0.548: 1965 Devices 1146 Events
                Z-Wave 3.0.1.262: 122 Nodes on one Z-Net

                Comment


                • #9
                  Album art squeezebox on HS hard drive

                  Originally posted by sparkman View Post
                  If there are any spaces in the filename, replace those with %20

                  Looking at your original post and my original reply, it looks like I might have dropped a space.
                  Progress!
                  Indeed a missing space.
                  Both pictures show up in my browser
                  So I will play around with IH to see if I can get further from here.
                  I will let you know.

                  Edit: Working!
                  On my phone I've got the pictures, so I have to find out why I am not getting the "Live Camera Widget" option on my tablet.
                  Edit2: after restarting my tablet it is working too.
                  I am a happy man now, thanks very much!
                  Last edited by Broes; December 27th, 2016, 07:09 PM.

                  Comment

                  Working...
                  X