Announcement

Collapse
No announcement yet.

InControl For Windows Phone 7

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • InControl For Windows Phone 7

    All,

    I am please to announce the release of InControl for Windows Phone 7. InControl For Windows Phone 7 includes HomeSeer and Windows Phone 7 plugins that work together to provides a real-time, interactive interface between your Microsoft Windows Phone 7 and Homeseer. With InControl, you are provided with an easy to use, graphical interface in Windows Phone 7 to control and monitor any HomeSeer devices no matter where you are.



    The HomeSeer Plug-in is available through the HomeSeer Updater and the Windows Phone 7 App is available through the Windows Phone Marketplace.

    HomeSeer Plug-in
    Windows Phone 7 App (must have Zune installed)

    Complete details and instructions can be viewed here.

    Thanks!
    Last edited by lamanmi; November 12th, 2010, 05:39 PM.

  • #2
    Wow!

    If only somebody would make a WM7 ROM for my Touch Pro 2....
    HSPro 3.0.0.458, Z-NET with Z-wave plugin 3.0.1.190, RFXCOM + 2x RFXtrx433E, HSTouch, Squeezebox plugin, iTach IP/WF2IR & GC-100-6 with UltraGCIR, BLDenon, NetcamStudio, Jon00s Webpage builder, Harmony Hub plugin, SCSIP (with FreePBX), Arduino plugin, IFTTT, Pushalot plugin, Device History plugin.
    Running on Windows 10 (64) virtualized
    on ESXi (Fujitsu Primergy TX150 S8).
    WinSeer (for Win10) - TextSeer - FitbitSeer - HSPI_MoskusSample

    Are you Norwegian (or Scandinavian) and getting started with HomeSeer? Read the "HomeSeer School"!

    Comment


    • #3
      InControl for WP7 Timeout masking another error?

      I puchased the plug-in, and am testing this out. I am able to connect no problem via my home's internal WiFi network, but when I try to connect through my external connection (e.g., via the internet) I get the timeout screen.

      I have verified that my firewall is configured properly, and can access the homeseer site from a browser. I can also click on the "View" button in the setup screen, and it takes me to the HomeSeer page so that appears to be working.

      I have tried both my external hostname as well as my external IP address (from whatismyip.com) and they all fail. I am not using the standard port, so have to append ":xxx" after the IP address.

      The Timeout screen comes up fairly quickly, so I am not even sure if it timing out or encountering a different error. How can I troubleshoot? Can I change the timeout value any way?

      Arthur

      Comment


      • #4
        Artherya,

        Can you enable the logging -- go to the InControl Settings (http://<homeseer server>/InControl_WP7_config), enter 3 for the log level and then click Save.

        Then while on external connection, start the app and see if any log enteries are made in the homeseer log.

        Thanks!

        Comment


        • #5
          Log info

          I set logging to 3 and then tried to access thru the WP7 client via external IP address (http://12.34.56.78:8888). Nothing showed up in the log file, and I got the Timeout screen very quickly multiple times. Clicking "VIEW" without changing anything connects me to the HomeTroller server, but generates an ASP.NET error:

          11/13/2010 4:29:37 PM - InControl_WP7 - TRACE: Entering modMain_Row
          11/13/2010 4:29:37 PM - InControl_WP7 - TRACE: Entering modMain_Row
          11/13/2010 4:32:34 PM - Web Server - Web Server authorized login successful from: 1xx.190.72.73 User: wp7
          11/13/2010 4:32:36 PM - Error - Processing ASP.NET page: Index was outside the bounds of the array.

          Hope this helps,
          Arthur

          Comment


          • #6
            Authur,

            Thanks, yes this does help. I have isolated the problem and will have a fixed version out shortly.

            Originally posted by arthurya View Post
            I set logging to 3 and then tried to access thru the WP7 client via external IP address (http://12.34.56.78:8888). Nothing showed up in the log file, and I got the Timeout screen very quickly multiple times. Clicking "VIEW" without changing anything connects me to the HomeTroller server, but generates an ASP.NET error:

            11/13/2010 4:29:37 PM - InControl_WP7 - TRACE: Entering modMain_Row
            11/13/2010 4:29:37 PM - InControl_WP7 - TRACE: Entering modMain_Row
            11/13/2010 4:32:34 PM - Web Server - Web Server authorized login successful from: 1xx.190.72.73 User: wp7
            11/13/2010 4:32:36 PM - Error - Processing ASP.NET page: Index was outside the bounds of the array.

            Hope this helps,
            Arthur

            Comment


            • #7
              WP7 app now works externally

              Thanks for the fix. I installed the WP7 app update from the Marketplace, and I am now able to see - and control - my devices remotely using the app over the internet. I tested from the office (with my wife verifying the actions over the phone), and all is working.

              Comment


              • #8
                I just purchased the Samsung Focus and Incontrol was up in running in about 10 mins... Awesome! Question, I'm not sure how to set up a z-wave thermostat, is that possible and can it be control via the WP7 client? Additionally, I'm planning to re-install HS at my lake house which means I would need to control two homes. I'm assuming the only way to accomplish this is to install two clients on the phone (not even sure you can do that) and point each one to their respected URL's? (I realize I need to purchase two licenses)....

                -John

                Comment


                • #9
                  Originally posted by Moskus View Post
                  Wow!

                  If only somebody would make a WM7 ROM for my Touch Pro 2....
                  agreed.. i have the Sprint Mogul (Titan)

                  this thing looks sexy!!!!!
                  HW - i5 4570T @2.9ghz runs @11w | 8gb ram | 128gb ssd OS - Win10 x64

                  HS - HS3 Pro Edition 3.0.0.435

                  Plugins - BLRF 2.0.94.0 | Concord 4 3.1.13.10 | HSBuddy 3.9.605.5 | HSTouch Server 3.0.0.68 | RFXCOM 30.0.0.36 | X10 3.0.0.36 | Z-Wave 3.0.1.190

                  Hardware - EdgePort/4 DB9 Serial | RFXCOM 433MHz USB Transceiver | Superbus 2000 for Concord 4 | TI103 X-10 Interface | WGL Designs W800 RF | Z-Net Z-Wave Interface

                  Comment


                  • #10
                    Arthurya,

                    Great...thanks for the update!

                    Originally posted by arthurya View Post
                    Thanks for the fix. I installed the WP7 app update from the Marketplace, and I am now able to see - and control - my devices remotely using the app over the internet. I tested from the office (with my wife verifying the actions over the phone), and all is working.

                    Comment


                    • #11
                      John,

                      Thanks for the feedback.

                      For the Thermostat, it does not "yet" have access to control a Thermostat. That feature is, however, in the works.

                      On the multiple HomeSeer servers, that is interesting, I have not run into that before. You will not be able to install the App twice, Windows Phone will not allow it. Let me think on that one for a while, to see if I can build that into the App directly.

                      Originally posted by johnoc View Post
                      I just purchased the Samsung Focus and Incontrol was up in running in about 10 mins... Awesome! Question, I'm not sure how to set up a z-wave thermostat, is that possible and can it be control via the WP7 client? Additionally, I'm planning to re-install HS at my lake house which means I would need to control two homes. I'm assuming the only way to accomplish this is to install two clients on the phone (not even sure you can do that) and point each one to their respected URL's? (I realize I need to purchase two licenses)....

                      -John

                      Comment


                      • #12
                        Originally posted by Moskus View Post
                        Wow!

                        If only somebody would make a WM7 ROM for my Touch Pro 2....
                        Not gonna happen. We don't have enough resources.

                        I switch back and forth between Android for TP2 and WM6.1 (I didn't like how slow 6.5 "felt").

                        --Dan
                        Tasker, to a person who does Homeautomation...is like walking up to a Crack Treatment facility with a truck full of 3lb bags of crack. Then for each person that walks in and out smack them in the face with an open bag.

                        Comment


                        • #13
                          Does InControl for WP7 include security support?

                          Thanks for the note on the future support for Thermostats. I am just about to buy the 2GIG-ZSTAT.

                          But it also got me to thinking about integrating my DSC home security system. Does the InControl app support that?

                          A

                          Comment


                          • #14
                            This looks great. I added a couple of my devices and verified that everything worked for me but after I added the rest of my devices the app no longer runs. It gets to the "Loading..." screen and then closes after about 4 seconds.

                            I tried removing all of my thermostat-related devices since those don't seem to be fully supported yet, but I still have the same issue.

                            Sort of removing each device one by one do you have any other ideas?

                            Thanks.

                            Comment


                            • #15
                              Acheslow,

                              About how many devices?

                              Can you to the following:

                              - Go to the InControl configuration in HomeSeer (http://<homeseer>/InControl_Sage_config)
                              - Enter 3 in the Log Level
                              - Click Save
                              - On the Windows Phone click the Refresh icon on the bottom toolbar
                              - Review/post your log results.

                              They should look something like:

                              11/21/2010 7:10:50 AM Web Server Web Server authorized login successful from: 173.88.214.216 User: <username>
                              11/21/2010 7:10:50 AM InControl_WP7 TRACE: Entering ReturnDevices
                              11/21/2010 7:10:50 AM InControl_WP7 DEBUG: Adding Cable Modem
                              11/21/2010 7:10:50 AM InControl_WP7 DEBUG: Adding Chair Light
                              11/21/2010 7:10:50 AM InControl_WP7 DEBUG: Adding Computer Lights
                              11/21/2010 7:10:50 AM InControl_WP7 DEBUG: Adding Desk Lights
                              11/21/2010 7:10:50 AM InControl_WP7 DEBUG: Adding Game Table Light
                              11/21/2010 7:10:50 AM InControl_WP7 DEBUG: Adding Hallway Lights
                              11/21/2010 7:10:50 AM InControl_WP7 DEBUG: Adding Router
                              11/21/2010 7:10:50 AM InControl_WP7 DEBUG: Adding Holiday
                              11/21/2010 7:10:50 AM InControl_WP7 DEBUG: Adding Wireless Router
                              11/21/2010 7:10:50 AM InControl_WP7 DEBUG: Adding Holiday
                              11/21/2010 7:10:50 AM InControl_WP7 DEBUG: Adding Basement
                              11/21/2010 7:10:50 AM InControl_WP7 DEBUG: Adding Great Room
                              11/21/2010 7:10:50 AM InControl_WP7 DEBUG: Adding Sage Server
                              11/21/2010 7:10:50 AM InControl_WP7 DEBUG: Adding Fan
                              11/21/2010 7:10:50 AM InControl_WP7 DEBUG: Adding Light
                              11/21/2010 7:10:50 AM InControl_WP7 DEBUG: Adding Temperature
                              11/21/2010 7:10:50 AM InControl_WP7 TRACE: Exiting ReturnDevices

                              This will help me determine if a specific device is causing the problem or on the phone.



                              Originally posted by acheslow View Post
                              This looks great. I added a couple of my devices and verified that everything worked for me but after I added the rest of my devices the app no longer runs. It gets to the "Loading..." screen and then closes after about 4 seconds.

                              I tried removing all of my thermostat-related devices since those don't seem to be fully supported yet, but I still have the same issue.

                              Sort of removing each device one by one do you have any other ideas?

                              Thanks.

                              Comment

                              Working...
                              X