Announcement

Collapse
No announcement yet.

Plugin: InControl For Windows Phone 7/HomeSeer - Version 2.2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Plugin: InControl For Windows Phone 7/HomeSeer - Version 2.2

    Description:

    NOTE - We have just released the InControl 2.2 App to the Windows Phone Marketplace. You MUST first install the HomeSeer InControl 2.0.5 plug in to use this app. Also, the app may take up to 48 hours to appear in the market place.

    InControl 2.1 For Windows Phone 7.5 includes HomeSeer 2.0 and Windows Phone 7 plugins that work together to provides a real-time, interactive interface between your Microsoft Windows Phone 7 and Homeseer. With InControl, you are provided with an easy to use, graphical interface in Windows Phone 7 to control and monitor any HomeSeer devices no matter where you are. See attachments for some sample screenshots.

    How To Install
    • Backup your HomeSeer Directory
    • Use the HomeSeer Updater to update the InControl Plug-In to Version 2.0.5 (or higher) - NOTE, you must update HomeSeer before using the new version of the App on Windows Phone
    • When you receive an App Update notice from Windows Phone, follow the prompts to update your App (should be within the next 24-48 hours)
    • Search for and install the App directly from the Microsoft MarketPlace.

    Version 2.2 Features:
    Version 2.2 Fixes:
    • Thermostat screen not refreshing properly when changing the temperature set points.
    • Background agent timing out if only tiles or location selected to update.
    • Fixed issues with Location Virtual Devices when House Code/Device Code were changed.
    • Other minor bug fixes

    Version 2.1 Features:
    Version 2.1 Fixes:
    • Corrected issues with some devices containg images or HTML not being correctly sent to phone
    • Corrected Thermostat timeout logic to allow for more rapid changes in set points
    • Corrected HomeSeer interface issues when working with custom thermostats
    • Backgournd agent was not firing when only location was set to update and not tiles
    • Other minor bug fixes

    Version 2.0 Features:
    • Completely Re-designed Metro Interface and images
    • Windows Phone App can control/access multiple HomeSeer Servers running Plug In
    • Devices can be added as Live Tiles to Home Screen that can be updated in background
    • Ability to for app to send Geo Location to HomeSeer (creates virtual devices in HS)
    • Will be released to all countries available in the Windows Phone marketplace
    • Control and/or monitor any Thermostats in HomeSeer from Windows Phone 7
    • Control and/or monitor any device in HomeSeer from Windows Phone 7
    • Start any Event in HomeSeer from Windows Phone 7
    • Secure connection via HomeSeer user id and password
    • Custom graphic library included for Windows Phone 7

    Requirements:
    • Windows Phone 7.5 or higher
    • HomeSeer 2.0 or higher
    • InControl For App (2.0 or higher)
    • InControl For HomeSeer Plugin (2.0.3 or higher through HomeSeer store and updater)

    Current Version Information:
    • InControl Windows Phone App - 2.1
    • InControl HomeSeer 2.0 Plugin - 2.0.4

    Feedback:
    • Enhancement Requests - There are many other features I am planning to add to this plugin. However, please feel free to post any enhancement ideas and I will do my best to add the capability.
    • Defect Reports - Please post any bugs or issues to this thread or via PM message.

    Special Notes:
    • Incontrol HomeSeer Plug In (2.0.4) - This plug in is backward compatible with the current Windows Phone application. Therefore, you can install this new plug in on HomeSeer to both continue to use the current version while testing the new version. As usual, when downloading any new plug in, be sure to backup your HomeSeer directory before updating from the HomeSeer store.
    • The Windows Phone App has a background update process which (if selected) updates both the Live Tiles and/or sends your current Geo Location to HomeSeer. Windows Phone limits the frequency in which this background process to run and therefore will run somewhere between every 30-60 minutes based on numerous factors.
    Attached Files
    Last edited by lamanmi; February 17th, 2012, 08:10 PM.

  • #2
    Installed the update, works great and looks much better!

    Comment


    • #3
      Thanks for the feedback!

      Originally posted by Droezel View Post
      Installed the update, works great and looks much better!

      Comment


      • #4
        for some reason my homeseer server is allways slow to respond. Incontrol usually times out saying it cant connect but then does after a refresh (its allways done this), anyways, I noticed on the screen that says "error The HomeSeer server did not respond in a reasonable time to load the locations. Please be sure it is accessible through the internet. Click the refresh icon below to try again"

        There is no refresh button. Just settings and send error Details.

        Im running Mango by the way.
        If it ain't broke, don't fix it!

        Comment


        • #5
          Oh, and the temperature icon is missing.
          If it ain't broke, don't fix it!

          Comment


          • #6
            I have seen the same issue with the error message and no refresh button. I usually get this on my thermostat screens. Not sure if I have seen this in other "location" screens on InControl. Can't remember but might have.

            Also I have seen the missing icon issue on a device where I have customized the icon by selecting something other than the default in the HS setup screen. I have previously reported both of these so I believe Lamanmi is aware of both of these "behaviors".

            Comment


            • #7
              Happnatious1,

              Thanks. The error text will be fixed in the next version, however, when you see that, just click the back key on the phone, that will do the same as a refresh. Also, per your other post, the temperature icon will be included in the next update.

              Regarding your timeout issue, I made a change to the initial query that should help the issue in the upcoming release of version 2.1 to the Windows Phone App. After that version comes out, please give a try and see if that corrects the issue when the phone first tries to connect to your server.

              Thanks!

              Originally posted by happnatious1 View Post
              for some reason my homeseer server is allways slow to respond. Incontrol usually times out saying it cant connect but then does after a refresh (its allways done this), anyways, I noticed on the screen that says "error The HomeSeer server did not respond in a reasonable time to load the locations. Please be sure it is accessible through the internet. Click the refresh icon below to try again"

              There is no refresh button. Just settings and send error Details.

              Im running Mango by the way.

              Comment


              • #8
                Ive discovered that my time out issue only occurs when I'm connected to the Wi-Fi in my house. If I'm out and about I dont see the problem. Must have something to do with the fact that its pointed to my external DNS even though the server at that point is local.

                Also, I just recieved the HSM100 device, enabling it for InControl causes an error. Maybe I should join your mango beta program, It's a very cool pluggin and I'd be happy to help if I can. Still need beta testers?
                If it ain't broke, don't fix it!

                Comment


                • #9
                  happnatious1,

                  For your HSM100 device, go to the following http://board.homeseer.com/showthread.php?t=151687 link and follow the steps to export the device settings. I have not worked with this device, so this would help me understand how to adapt InControl to support it.

                  As of right now, the current version on the HomeSeer Updator and in the Windows Phone Marketplace is the current version. We do not have any active betas, however, if we start another beta, I will be sure to post it in the HomeSeer forum.


                  Originally posted by happnatious1 View Post
                  Ive discovered that my time out issue only occurs when I'm connected to the Wi-Fi in my house. If I'm out and about I dont see the problem. Must have something to do with the fact that its pointed to my external DNS even though the server at that point is local.

                  Also, I just recieved the HSM100 device, enabling it for InControl causes an error. Maybe I should join your mango beta program, It's a very cool pluggin and I'd be happy to help if I can. Still need beta testers?

                  Comment


                  • #10
                    New versions are no available

                    I have released a new version of the App (2.1) and the HomeSeer InControl Plug In (2.0.4). Please see the first post for more details. The main new feature is the ability to either show a toggle button for devices or use the icon itself as the toggle button (or both of you so choose) on the main pivot panel.

                    It also includes a number of bug fixes. Thanks for all the great feedback.

                    http://board.homeseer.com/showthread.php?t=152249

                    Comment


                    • #11
                      Thanks for update.

                      Whenever I pin a device to the home screen the tile never updates. In the log I get statements such as:

                      Til-315-home-DeviceFull
                      Starting loc/title for home
                      Agent timed out.


                      I can access and control my HS through the app without an issue. Although I seem to have hit the refresh when I first load the app to get a connection.

                      Can you help?

                      Thanks

                      Darren

                      Comment


                      • #12
                        Darren,

                        What is the seconds in the time between the first entry below and the agent time out?

                        Does this happen all the time or does it work some of the time?

                        Does your phone use WIFI most of the time? If so, try turning that off to make sure the phone is able to access your server over the internet.

                        Let me know.


                        Originally posted by darren-mc View Post
                        Thanks for update.

                        Whenever I pin a device to the home screen the tile never updates. In the log I get statements such as:

                        Til-315-home-DeviceFull
                        Starting loc/title for home
                        Agent timed out.


                        I can access and control my HS through the app without an issue. Although I seem to have hit the refresh when I first load the app to get a connection.

                        Can you help?

                        Thanks

                        Darren

                        Comment


                        • #13
                          Hi there,

                          Sorry for taking so long to respond. The difference is about 13 seconds between the "Starting loc/title for home" entry and the "Agent timed out" entry.

                          I have tried it on the internal wifi and 3g networks. I get the same result.

                          Cheers,

                          Darren

                          Comment


                          • #14
                            Does Incontrol WP7 support HTTPS? I have Z-wave locks, so dont want anything non-SSL

                            Comment


                            • #15
                              Darren,

                              I'm uploading a new version now that should address this issue.

                              Originally posted by darren-mc View Post
                              Hi there,

                              Sorry for taking so long to respond. The difference is about 13 seconds between the "Starting loc/title for home" entry and the "Agent timed out" entry.

                              I have tried it on the internal wifi and 3g networks. I get the same result.

                              Cheers,

                              Darren

                              Comment

                              Working...
                              X