Announcement

Collapse
No announcement yet.

Z-wave locks and toggle are not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Z-wave locks and toggle are not working

    The z-wave locks generally work very well with Incontrol. The only minor problem I'm having is that if I assign lock and unlock to the toggle when I flip the toggle nothing happens.

    All the other non lock toggles work perfectly

    This is what I see in the logs:

    Code:
     
    2/19/2012 2:51:14 PM  - InControl_WP7 - TRACE: Entering ReturnDevice
    2/19/2012 2:51:14 PM  - InControl_WP7 - Sending device information to external device (Locked;5137;)
    2/19/2012 2:51:14 PM  - InControl_WP7 - Mobile Device Credentials Validated
    2/19/2012 2:51:14 PM  - InControl_WP7 - Getting device settings for HomeSeer Device
    2/19/2012 2:51:14 PM  - InControl_WP7 - DEBUG: sData=REF=5137;ACTION=LOCKED;DIMVAL=;
    2/19/2012 2:51:14 PM  - InControl_WP7 - TRACE: Entering modMain_ProcessMessage_Exec
    2/19/2012 2:51:14 PM  - InControl_WP7 - DEBUG: Waiting for command to be performed
    2/19/2012 2:51:14 PM  - InControl_WP7 - TRACE: Entering modMain_ProcessMessage_InitDevice
    2/19/2012 2:51:14 PM  - InControl_WP7 - TRACE: Entering modMain_GetStatusString
    2/19/2012 2:51:14 PM  - InControl_WP7 - DEBUG: Building device information
    2/19/2012 2:51:14 PM  - InControl_WP7 - DEBUG: sCustomLoc=Living Room
    2/19/2012 2:51:14 PM  - InControl_WP7 - DEBUG: sCustomName=Door Lock
    2/19/2012 2:51:14 PM  - InControl_WP7 - DEBUG: sDeviceReference=5137
    2/19/2012 2:51:14 PM  - InControl_WP7 - TRACE: Exiting ReturnDevice
    2/19/2012 2:51:24 PM  - InControl_WP7 - TRACE: Entering ReturnDevice
    2/19/2012 2:51:24 PM  - InControl_WP7 - Sending device information to external device (Unlocked;5137;)
    2/19/2012 2:51:24 PM  - InControl_WP7 - Mobile Device Credentials Validated
    2/19/2012 2:51:24 PM  - InControl_WP7 - Getting device settings for HomeSeer Device
    2/19/2012 2:51:24 PM  - InControl_WP7 - DEBUG: sData=REF=5137;ACTION=UNLOCKED;DIMVAL=;
    2/19/2012 2:51:24 PM  - InControl_WP7 - TRACE: Entering modMain_ProcessMessage_Exec
    2/19/2012 2:51:24 PM  - InControl_WP7 - DEBUG: Waiting for command to be performed
    2/19/2012 2:51:24 PM  - InControl_WP7 - TRACE: Entering modMain_ProcessMessage_InitDevice
    2/19/2012 2:51:24 PM  - InControl_WP7 - TRACE: Entering modMain_GetStatusString
    2/19/2012 2:51:24 PM  - InControl_WP7 - DEBUG: Building device information
    2/19/2012 2:51:24 PM  - InControl_WP7 - DEBUG: sCustomLoc=Living Room
    2/19/2012 2:51:24 PM  - InControl_WP7 - DEBUG: sCustomName=Door Lock
    2/19/2012 2:51:24 PM  - InControl_WP7 - DEBUG: sDeviceReference=5137
    2/19/2012 2:51:24 PM  - InControl_WP7 - TRACE: Exiting ReturnDevice

  • #2
    Kevin,

    Sorry to hear it is not working. Can you follow the steps at http://board.homeseer.com/showpost.p...84&postcount=1. This will allow me to reproduce your exact device settings to try to replicate and fix the problem?

    Thanks!!

    Originally posted by kevini View Post
    The z-wave locks generally work very well with Incontrol. The only minor problem I'm having is that if I assign lock and unlock to the toggle when I flip the toggle nothing happens.

    All the other non lock toggles work perfectly

    This is what I see in the logs:

    Code:
     
    2/19/2012 2:51:14 PM  - InControl_WP7 - TRACE: Entering ReturnDevice
    2/19/2012 2:51:14 PM  - InControl_WP7 - Sending device information to external device (Locked;5137;)
    2/19/2012 2:51:14 PM  - InControl_WP7 - Mobile Device Credentials Validated
    2/19/2012 2:51:14 PM  - InControl_WP7 - Getting device settings for HomeSeer Device
    2/19/2012 2:51:14 PM  - InControl_WP7 - DEBUG: sData=REF=5137;ACTION=LOCKED;DIMVAL=;
    2/19/2012 2:51:14 PM  - InControl_WP7 - TRACE: Entering modMain_ProcessMessage_Exec
    2/19/2012 2:51:14 PM  - InControl_WP7 - DEBUG: Waiting for command to be performed
    2/19/2012 2:51:14 PM  - InControl_WP7 - TRACE: Entering modMain_ProcessMessage_InitDevice
    2/19/2012 2:51:14 PM  - InControl_WP7 - TRACE: Entering modMain_GetStatusString
    2/19/2012 2:51:14 PM  - InControl_WP7 - DEBUG: Building device information
    2/19/2012 2:51:14 PM  - InControl_WP7 - DEBUG: sCustomLoc=Living Room
    2/19/2012 2:51:14 PM  - InControl_WP7 - DEBUG: sCustomName=Door Lock
    2/19/2012 2:51:14 PM  - InControl_WP7 - DEBUG: sDeviceReference=5137
    2/19/2012 2:51:14 PM  - InControl_WP7 - TRACE: Exiting ReturnDevice
    2/19/2012 2:51:24 PM  - InControl_WP7 - TRACE: Entering ReturnDevice
    2/19/2012 2:51:24 PM  - InControl_WP7 - Sending device information to external device (Unlocked;5137;)
    2/19/2012 2:51:24 PM  - InControl_WP7 - Mobile Device Credentials Validated
    2/19/2012 2:51:24 PM  - InControl_WP7 - Getting device settings for HomeSeer Device
    2/19/2012 2:51:24 PM  - InControl_WP7 - DEBUG: sData=REF=5137;ACTION=UNLOCKED;DIMVAL=;
    2/19/2012 2:51:24 PM  - InControl_WP7 - TRACE: Entering modMain_ProcessMessage_Exec
    2/19/2012 2:51:24 PM  - InControl_WP7 - DEBUG: Waiting for command to be performed
    2/19/2012 2:51:24 PM  - InControl_WP7 - TRACE: Entering modMain_ProcessMessage_InitDevice
    2/19/2012 2:51:24 PM  - InControl_WP7 - TRACE: Entering modMain_GetStatusString
    2/19/2012 2:51:24 PM  - InControl_WP7 - DEBUG: Building device information
    2/19/2012 2:51:24 PM  - InControl_WP7 - DEBUG: sCustomLoc=Living Room
    2/19/2012 2:51:24 PM  - InControl_WP7 - DEBUG: sCustomName=Door Lock
    2/19/2012 2:51:24 PM  - InControl_WP7 - DEBUG: sDeviceReference=5137
    2/19/2012 2:51:24 PM  - InControl_WP7 - TRACE: Exiting ReturnDevice

    Comment


    • #3
      Thanks, I just emailed the files, sorry for the delay.

      Comment

      Working...
      X