Announcement

Collapse
No announcement yet.

Remote access ?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Remote access ?

    Installed on a windows 8.1 phone

    I can connect using my LAN IP

    trying to access via WAN

    entered my public IP address without port number

    entered my public IP address with port number 10200

    time out error 1020

    Running
    HS3 Standard Edition 3.0.0.152 (Windows)
    Z-Wave 3.0.0.189
    HSTouch Server 3.0.0.59

  • #2
    well, was hoping for some support.

    Comment


    • #3
      abandoned Plugin??

      Comment


      • #4
        Unfortunately it appears that way.
        -Rupp
        sigpic

        Comment


        • #5
          I use incontrol with HS3 and windows phone 8.1 + windows (metro) pc's with the incontrol for win8.

          I also use this through the internet pointed back at my server like you are attempting.

          This plug in is NOT abandoned, they have a direct email that they check more so than this forum.

          With that said, let me tell you that as long as your port is opened up in your firewall and "port forwarding" is pointed to your HS3 server, this works perfectly.

          I have my fully qualified domain as my address configured inside incontrol and that way whether I am home or outside of the home, it works without configuration changes.

          Curious as your setup to allow ports through? Are you certain the port is opened all the way to the computer running HS3 and the firewall on the HS3 box is also allowing the port inbound?

          Also, my configuration url is:
          http://www.mydomain.net:10200

          10200 port should be your web browser HS3 site.

          the HS3 side needs a couple incontrol plugins (I have all 3) but you need the core and then phone.

          see if you can hit hs3 outside your network using a browser and that URL should become your incontrol URL configuration path.

          Comment


          • #6
            went on my Hometroller s6 and did an open port check.
            Port 10200 is open.
            Firewall off
            port 10200 is forwarded to my s6 LAN IP in my router.

            I have all 3 incontrol plugins enabled.

            using my public ip:10200 but no luck

            I contacted the developer not just here omn the forum, but also sent a private message and used the help system that was available after the failed connections on my windows 8.1 phone, but no replies.


            I have 2 ip camera's that I can access via wan...

            Comment


            • #7
              so are you able to pull up the HS3 web interface when you browse to the port inside your LAN? then what happens when you step outside your network and hit it from the WAN?

              As soon as you can hit the HS3 web interface using the WAN -- you should be golden. I can try to help you achieve this -- let me know what happens with my inquiries as a starting point?

              Good luck!

              Comment


              • #8
                on LAN I can access anything, HS3 as well as incontrol on windows phone, using my LAN ip.

                When I enter my public ip address from wan, my router login pops up.

                In HS3 network settings I still have port 80 set

                Port 5900 and 10200 are forwarded and open to my HS3 interface.

                Firewall tuned off on my HS3 interface.

                public ip:10200 not working
                public ip:5900 not working

                Public ip >> router login

                I am using the foscam app Foscam Pro v1.1 to access my ip cameras from WAN using my public iport# and they work great.

                Ports for the ip cams have been forwarded in my router settings.

                Might it be that my HS3 is on port 80?

                I could change it to another port and forward that port, but what else would I have the change to keep HS3 and HStouch working if I change this port?

                Thanks for your help

                Comment


                • #9
                  BINGO. You caught it.

                  Change your incontrol setting on your phone to 80 like this: *wan*
                  http://ipaddress:80/

                  then port forward your port 80 to the hs3 box.

                  if it works, you can change your hs3 web port from 80 to 10200 and then use that instead...

                  Can't wait to hear if you get it working!!!

                  (not sure about the HSTouch settings though)

                  Comment


                  • #10
                    Originally posted by UltimateInternet View Post
                    Change your incontrol setting on your phone to 80 like this: *wan*
                    http://ipaddress:80/
                    I think this will still hit the router unless remote management is turned off and port forwarding to HS is configured.

                    Alternatively just change HS to use port 81 (or other) and forward that, leaving port 80 for remote management. However, as remote management seems to be active, I would also recommend turning that off unless you have a pressing and ongoing need for it to be active.
                    cheeryfool

                    Comment


                    • #11
                      Originally posted by cheeryfool View Post
                      I think this will still hit the router unless remote management is turned off and port forwarding to HS is configured.

                      Alternatively just change HS to use port 81 (or other) and forward that, leaving port 80 for remote management. However, as remote management seems to be active, I would also recommend turning that off unless you have a pressing and ongoing need for it to be active.
                      good call. I was thinking about it as it is set up in my network and forgot he had the router management page active as he described earlier.

                      Probably the easiest thing to do is to set the HS3 page from 80 to 10200 and just see if it works...

                      Comment


                      • #12
                        Change your incontrol setting on your phone to 80 like this: *wan*
                        http://ipaddress:80/

                        then port forward your port 80 to the hs3 box.

                        if it works, you can change your hs3 web port from 80 to 10200 and then use that instead...
                        doesn't work and also port 10200 can not be set in HS3 since it is already used.

                        Alternatively just change HS to use port 81 (or other) and forward that, leaving port 80 for remote management. However, as remote management seems to be active, I would also recommend turning that off unless you have a pressing and ongoing need for it to be active.

                        used port 8787. set in HS3 and forwarded the port in my router.
                        no luck

                        Remote management is turned off. If I set it to on, it would be on port 8080



                        probably not a good idea, but what about making my HS3 interface a DMZ server?

                        Comment


                        • #13
                          Originally posted by CarbJetKits View Post

                          used port 8787. set in HS3 and forwarded the port in my router.
                          no luck
                          As a matter of interest, did you restart HS3 after the port change, and/or have you confirmed that it works on the LAN. I think I recall that changing the port *may* not be dynamic. Anyway, I am sure you did, just checking.
                          cheeryfool

                          Comment


                          • #14
                            Might have found the problem

                            I was running hs3 without binding the ip address

                            so I did bind it to the hs3 interface lan address, but get this in my log:

                            Feb-20 5:51:17 PM Web Server Web server remote access is disabled. It can only be accessed from this computer
                            Feb-20 5:51:17 PM Web Server The web server has been bound specifically to IP address 192.168.0.40


                            so I went back and selected no binding:

                            Web Server started on localhost, port 80
                            Now, it seems that I need to bind it to my HS3 LAN ip, but how do I allow for remote access?

                            Comment


                            • #15
                              Originally posted by CarbJetKits View Post
                              Might have found the problem

                              I was running hs3 without binding the ip address

                              so I did bind it to the hs3 interface lan address, but get this in my log:



                              so I went back and selected no binding:



                              Now, it seems that I need to bind it to my HS3 LAN ip, but how do I allow for remote access?

                              hmmm. Mine isn't bound and has never been in HS2 or HS3 and has always worked remotely with the appropriate port forward. The only other thing I can think of is your firewall. Turn if off temporarily on your HS3 box and try WAN access again. You may well find that you need to add a rule in the FW.
                              cheeryfool

                              Comment

                              Working...
                              X