Announcement

Collapse
No announcement yet.

Data Parsing Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    New Issue

    Looks like a hit another problem with both WinPhone and WinStore.

    I have been steadily adding devices to the InControl Universal / InControl Phone clients. Have been adding graphics, toggles, etc and everything was working perfectly. I refreshed the Universal client to pick up a couple of new devices and it suddenly crashed out. Started it back up and all devices are gone. Restarted HS, all the plugins and all the interfaces - nothing.

    Here is a sample of the debug log file:

    2016-07-17 21:48:12 - A0001(M) - -------------------------------------------------------------
    2016-07-17 21:48:12 - A0002(M) - App Version: 1.1.12
    2016-07-17 21:48:12 - A0004(N) - System Version: 10.0.10586.420
    2016-07-17 21:48:12 - A0003(M) - Enabling automated HomeSeer Device Update
    2016-07-17 21:48:12 - M1001(N) - Preparing for http request (All Devices)
    2016-07-17 21:48:12 - M1014(D) - Establishing connection ZeeS2
    2016-07-17 21:48:12 - M1012(D) - Starting call to HomeSeer Server ZeeS2
    2016-07-17 21:48:42 - M1006(E) - Request cancellation error - TaskCanceledException_ctor_DefaultMessage
    2016-07-17 21:48:42 - M1007(E) - Request cancellation error - <unknown>
    2016-07-17 21:48:42 - M1003(N) - Initalizing HomeSeer Update Proces
    2016-07-17 21:48:42 - M1004(N) - Established timer for next update
    2016-07-17 21:48:42 - M1015(M) - Listener started on service name 22315
    2016-07-17 21:48:42 - M1033(M) - UDP Listener started on service name
    2016-07-17 21:48:42 - G8011(N) - Sending message - SOURCE=WSX;TYPE=ACK
    2016-07-17 21:48:42 - G8013(N) - Sending message complete - SOURCE=WSX;TYPE=ACK
    2016-07-17 21:49:36 - M1001(N) - Preparing for http request (All Devices)
    2016-07-17 21:49:36 - M1014(D) - Establishing connection ZeeS2
    2016-07-17 21:49:36 - M1012(D) - Starting call to HomeSeer Server ZeeS2
    2016-07-17 21:49:42 - M1005(N) - Performing timer update
    2016-07-17 21:49:42 - M1014(D) - Establishing connection ZeeS2
    2016-07-17 21:49:42 - M1012(D) - Starting call to HomeSeer Server ZeeS2
    2016-07-17 21:50:06 - M1006(E) - Request cancellation error - TaskCanceledException_ctor_DefaultMessage
    2016-07-17 21:50:06 - M1007(E) - Request cancellation error - <unknown>
    2016-07-17 21:50:12 - M1006(E) - Request cancellation error - TaskCanceledException_ctor_DefaultMessage
    2016-07-17 21:50:12 - M1007(E) - Request cancellation error - <unknown>
    2016-07-17 21:50:42 - M1005(N) - Performing timer update
    2016-07-17 21:50:42 - M1014(D) - Establishing connection ZeeS2
    2016-07-17 21:50:42 - M1012(D) - Starting call to HomeSeer Server ZeeS2
    2016-07-17 21:51:12 - M1006(E) - Request cancellation error - TaskCanceledException_ctor_DefaultMessage
    2016-07-17 21:51:12 - M1007(E) - Request cancellation error - <unknown>
    2016-07-17 21:51:42 - M1005(N) - Performing timer update
    2016-07-17 21:51:42 - M1014(D) - Establishing connection ZeeS2
    2016-07-17 21:51:42 - M1012(D) - Starting call to HomeSeer Server ZeeS2
    2016-07-17 21:52:12 - M1006(E) - Request cancellation error - TaskCanceledException_ctor_DefaultMessage
    2016-07-17 21:52:12 - M1007(E) - Request cancellation error - <unknown>
    2016-07-17 21:52:42 - M1005(N) - Performing timer update
    2016-07-17 21:52:42 - M1014(D) - Establishing connection ZeeS2
    2016-07-17 21:52:42 - M1012(D) - Starting call to HomeSeer Server ZeeS2
    2016-07-17 21:53:12 - M1006(E) - Request cancellation error - TaskCanceledException_ctor_DefaultMessage
    2016-07-17 21:53:12 - M1007(E) - Request cancellation error - <unknown>
    2016-07-17 21:53:42 - M1005(N) - Performing timer update
    2016-07-17 21:53:42 - M1014(D) - Establishing connection ZeeS2
    2016-07-17 21:53:42 - M1012(D) - Starting call to HomeSeer Server ZeeS2
    2016-07-17 21:54:12 - M1006(E) - Request cancellation error - TaskCanceledException_ctor_DefaultMessage
    2016-07-17 21:54:12 - M1007(E) - Request cancellation error - <unknown>
    2016-07-17 21:54:42 - M1005(N) - Performing timer update
    2016-07-17 21:54:42 - M1014(D) - Establishing connection ZeeS2
    2016-07-17 21:54:42 - M1012(D) - Starting call to HomeSeer Server ZeeS2

    I estimate that I have about 100 total devices enabled in IC - most are control and the rest are battery status, doors, etc.

    I set up the plug in to dump full debug info to the HS logs and it looks like when I connect it is trying to rebuild every device. I am wondering if I have so many devices that the process times out but I cannot tell.

    I have been getting error 1020s on the phone client since this afternoon after I added 20 or so more devices. I again suspect a timeout.

    Here is a sample from the HS logs - I see a continuous stream of this whenever I connect from the Uni client:

    Jul-17 22:00:40 InControl Server TRACE: Entering code 15000
    Jul-17 22:00:40 InControl Server Getting device settings for HomeSeer Device
    Jul-17 22:00:40 InControl Server Mobile Device Credentials Validated
    Jul-17 22:00:40 InControl Server TRACE: Entering code 14000
    Jul-17 22:00:40 InControl Server DEBUG: Adding All Lights
    Jul-17 22:00:40 InControl Server TRACE: Exiting code 14000
    Jul-17 22:00:40 InControl Server DEBUG: sDeviceReference=744
    Jul-17 22:00:40 InControl Server DEBUG: sCustomName=All Lights
    Jul-17 22:00:40 InControl Server DEBUG: sCustomLoc=Basement
    Jul-17 22:00:40 InControl Server DEBUG: Building device information
    Jul-17 22:00:40 InControl Server TRACE: Entering code 15000
    Jul-17 22:00:40 InControl Server Getting device settings for HomeSeer Device
    Jul-17 22:00:39 InControl Server Mobile Device Credentials Validated
    Jul-17 22:00:39 InControl Server TRACE: Entering code 14000
    Jul-17 22:00:39 InControl Server DEBUG: Adding All Lights
    Jul-17 22:00:39 InControl Server TRACE: Exiting code 14000
    Jul-17 22:00:39 InControl Server DEBUG: sDeviceReference=638
    Jul-17 22:00:39 InControl Server DEBUG: sCustomName=All Lights
    Jul-17 22:00:39 InControl Server DEBUG: sCustomLoc=All Areas
    Jul-17 22:00:39 InControl Server DEBUG: Building device information
    Jul-17 22:00:39 InControl Server TRACE: Entering code 15000
    Jul-17 22:00:39 InControl Server Getting device settings for HomeSeer Device
    Jul-17 22:00:39 InControl Server Mobile Device Credentials Validated
    Jul-17 22:00:39 InControl Server TRACE: Entering code 14000
    Jul-17 22:00:39 InControl Server DEBUG: Adding All Ceil Fans
    Jul-17 22:00:39 InControl Server TRACE: Exiting code 14000
    Jul-17 22:00:39 InControl Server DEBUG: sDeviceReference=650
    Jul-17 22:00:39 InControl Server DEBUG: sCustomName=All Ceil Fans
    Jul-17 22:00:39 InControl Server DEBUG: sCustomLoc=All Areas
    Jul-17 22:00:39 InControl Server DEBUG: Building device information
    Jul-17 22:00:39 InControl Server TRACE: Entering code 15000
    Jul-17 22:00:39 InControl Server Getting device settings for HomeSeer Device
    Jul-17 22:00:39 InControl Server Mobile Device Credentials Validated
    Jul-17 22:00:39 InControl Server TRACE: Entering code 14000
    Jul-17 22:00:39 InControl Server TRACE: Entering code 11004
    Jul-17 22:00:39 InControl Server TRACE: Entering code 11003
    Jul-17 22:00:37 InControl Server TRACE: Entering code 11002

    Comment


    • #17
      Let me get a build out that has a configurable timeout parameter.

      In the mean time, let's confirm it is the number of devices. Can you access the InControl3.Ini file in the HomeSeer Config directory? If so, make a back up of it then erase it. Set up one device and see if the app works again.

      Michael


      Originally posted by bebaldin View Post
      Looks like a hit another problem with both WinPhone and WinStore.

      I have been steadily adding devices to the InControl Universal / InControl Phone clients. Have been adding graphics, toggles, etc and everything was working perfectly. I refreshed the Universal client to pick up a couple of new devices and it suddenly crashed out. Started it back up and all devices are gone. Restarted HS, all the plugins and all the interfaces - nothing.

      Comment


      • #18
        Looks like that is probably it. I deleted the ini, stopped and started the plug in to rebuild it, and added one device. Both the universal and the winphone clients connected and showed the new device.

        Comment


        • #19
          Watch for a new build in a few days to appear in the store (version 1.1.13). Within the server settings a new Timeout option has been added.

          Originally posted by bebaldin View Post
          Looks like that is probably it. I deleted the ini, stopped and started the plug in to rebuild it, and added one device. Both the universal and the winphone clients connected and showed the new device.

          Comment


          • #20
            Installed 1.1.13 tonight. So far so good. I am adding back in the devices and I will post results this weekend.

            If this works will you also need to update the WinPhone app with a timeout value?

            Comment


            • #21
              Great news, thanks for the update. For Windows Phone, you indicated you are still on Windows Phone 8.1? Any plans to upgrade (if it is compat for you phone) to Windows Mobile 10? I' haven't made any changes to the Windows 8.1 app in a while and suspect not many users will be using that going forward, so want to be sure that is what you are on before adding the timeout parameter.

              Originally posted by bebaldin View Post
              Installed 1.1.13 tonight. So far so good. I am adding back in the devices and I will post results this weekend.

              If this works will you also need to update the WinPhone app with a timeout value?
              I got up to about 30 devices before WinPhone started issues 1020 errors. So far so good on Win Universal. I have the timeout value set to 120 on it and am having no issues so far. Still have a lot of devices to readd.
              Last edited by lamanmi; July 24th, 2016, 09:26 AM.

              Comment


              • #22
                Originally posted by bebaldin View Post
                Great news, thanks for the update. For Windows Phone, you indicated you are still on Windows Phone 8.1? Any plans to upgrade (if it is compat for you phone) to Windows Mobile 10? I' haven't made any changes to the Windows 8.1 app in a while and suspect not many users will be using that going forward, so want to be sure that is what you are on before adding the timeout parameter.



                I got up to about 30 devices before WinPhone started issues 1020 errors. So far so good on Win Universal. I have the timeout value set to 120 on it and am having no issues so far. Still have a lot of devices to readd.

                Unfortunately, I am running an HTC M8 and there is no plans to allow Win10 on it. Looks like 8.1 is the highest it will ever go.

                On the Universal app I am now up to 115 devices and it is working flawlessly. Haven't had a lot of time to play with the custom screens because I have been working on customizing my icons. Will attach a screenshot.

                Can we get the InControl tab added for some of the sensor functions such as temperature and humidity? I have quite a few of the Aeon 6-in-1 sensors and would like to monitor using IC.
                Attached Files

                Comment

                Working...
                X