Announcement

Collapse
No announcement yet.

AAG Wind Instrument parts?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • AAG Wind Instrument parts?

    The wind direction sensor in my AAG TAI8515 seems to have kicked the bucket today at 11:38AM. Not having had a need, I never noted what Dallas part was used for this function and now I can't read it. Add to this the fact that Dalas Semiconductors seems to have discontinued one of the components in the instrument (probably the one I need) so AAG is "out of stock".
    I'd like to simply replace the component if possible. Does anyone know what it might be?
    The other option is to wait until AAG has a replacement available for the entire instrument.
    Alternatively, are there any other 1-Wire wind instrumnents out there... Anyone have one for sale perhaps?

    Why does this always seem to happen when there's snow on the roof !!
    Real courage is not securing your Wi-Fi network.

  • #2
    There are two versions of the instrument. The original use switches and the more current one uses DS2450 and a network of resistors. It is likely that you have the DS2450-based design. The most likely problem will be with the resistor network and its connections. You can look at the voltage readings from the DS2450 via IO Window of xapmcs1wire. For each of the 16 wind direction postions the 4 A/D voltages will be in the neighborhood of the following

    Code:
    140       conv_table(0) = Array(0.06, 4.64, 4.64, 4.64)
    150       conv_table(1) = Array(0.06, 0.06, 4.6, 4.6)
    160       conv_table(2) = Array(4.64, 0.06, 4.64, 4.64)
    170       conv_table(3) = Array(4.62, 0.06, 0.06, 4.6)
    180       conv_table(4) = Array(4.64, 4.64, 0.06, 4.64)
    190       conv_table(5) = Array(4.6, 4.6, 0.06, 0.06)
    200       conv_table(6) = Array(4.64, 4.64, 4.64, 0.06)
    210       conv_table(7) = Array(2.36, 4.62, 4.6, 0.06)
    220       conv_table(8) = Array(2.38, 4.66, 4.66, 4.66)
    230       conv_table(9) = Array(3.2, 3.2, 4.66, 4.64)
    240       conv_table(10) = Array(4.66, 2.38, 4.66, 4.66)
    250       conv_table(11) = Array(4.66, 3.18, 3.2, 4.64)
    260       conv_table(12) = Array(4.66, 4.66, 2.38, 4.66)
    270       conv_table(13) = Array(4.66, 4.66, 3.18, 3.18)
    280       conv_table(14) = Array(4.66, 4.66, 4.66, 2.38)
    290       conv_table(15) = Array(0.06, 4.62, 4.62, 2.34)
    If you do not see the DS2450 responding in the IO window then you likely have a connection problem to it. It is a surface mount part so replacement needs good tools and eyes. If I recall the resistor connections are the weak point. If you google you can find the schematic at a couple different locations.

    Comment


    • #3
      Thanks for that info. It will be the later version... 1 year old. Perhaps the thing can be repaired. I think I'll buy the replacement anyway and fool with this one later. My eyes aren't that good anymore anyway. Ten years ago it would have been childs play. Now, I'd need an electron microscope to solder surface mount.
      Fact is, I dropped this unit from the roof a couple of weeks ago when I was reinstalling the rain bucket, so it is likely a trace may have been cracked on the board. I'm lucky it worked at all.
      Real courage is not securing your Wi-Fi network.

      Comment

      Working...
      X