Announcement

Collapse
No announcement yet.

Ambient Weather plugin critical error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Ambient Weather plugin critical error

    Hi,

    I've moved my new ws1550-IP outside with the Observer module finally connected. When I try to specify the address in the config of the plugin, the plugin creates an exception then disconnects. I went to the Observer module itself and set the IP to static there as well.
    The plugin blows up so much that I can't reconfigure or anything. Taking the AmbientWeather.ini from last nights backup, restores things to where it was before.

    My goal was to use the hybrid mode.

    Have I missed something?

    Robert

    Click image for larger version

Name:	Ambient1.jpg
Views:	33
Size:	54.1 KB
ID:	1265382
    HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

    #2
    Originally posted by langenet View Post
    Hi,

    I've moved my new ws1550-IP outside with the Observer module finally connected. When I try to specify the address in the config of the plugin, the plugin creates an exception then disconnects. I went to the Observer module itself and set the IP to static there as well.
    The plugin blows up so much that I can't reconfigure or anything. Taking the AmbientWeather.ini from last nights backup, restores things to where it was before.

    My goal was to use the hybrid mode.

    Have I missed something?

    Robert

    Click image for larger version

Name:	Ambient1.jpg
Views:	33
Size:	54.1 KB
ID:	1265382
    Update to 2.1.0.119 in the beta section.

    Comment


      #3
      Yup... that did it!

      Thanks,

      Robert
      HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

      Comment


        #4
        Another issue I noticed is that the temperature in the device management page never updates and that the Temperature Feels like is in fact the temperature found in the live data of the ObserverIP module when in Hybrid mode - actually in any mode. Is this right?

        Robert
        HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

        Comment


          #5
          Originally posted by langenet View Post
          Another issue I noticed is that the temperature in the device management page never updates and that the Temperature Feels like is in fact the temperature found in the live data of the ObserverIP module when in Hybrid mode - actually in any mode. Is this right?

          Robert
          The "Feels Like" is a computed value only available from AmbientWeather.Net. Hybrid mode is automatic if you are using the ObserverIP and have the IP address filled in. Do NOT check the Local Only checkbox for Hybrid.

          Comment


            #6
            This is what I assumed. I don't have the Local Only checked. But as you can see, the first section shows that the temperature hasn't changed since the last plugin restart - almost 3 hours ago. The second picture shows what the Live data is - which just updated to -1.2 after I took the screen snipit. The temperature is not updating at all. In fact the feels like seems to be the temp read from the ObserverIP. Again, just updated the device after I wrote this. So Temperature outside doesn't work. Going to the dashboard.ambientweather.net shows the temp as -1.2 C.


            Click image for larger version  Name:	Ambient2.jpg Views:	1 Size:	99.8 KB ID:	1265498
            HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

            Comment


              #7
              Running debug shows feels like temp but not temperature.

              Dec-09 8:10:03 PM AmbientWeather Debug -------------------------------------------------
              Dec-09 8:10:03 PM AmbientWeather Debug Local Update Wind Speed: 0
              Dec-09 8:10:03 PM AmbientWeather Debug Local Update Wind Gust Daily Max: 32.51
              Dec-09 8:10:03 PM AmbientWeather Debug Local Update Wind Gust: 0
              Dec-09 8:10:03 PM AmbientWeather Debug -------------------------------------------------
              Dec-09 8:10:03 PM AmbientWeather Debug Local Update Wind Direction: 228
              Dec-09 8:10:03 PM AmbientWeather Debug Local Update UV Index: 0
              Dec-09 8:10:02 PM AmbientWeather Debug Local Update Luminance: 0
              Dec-09 8:10:02 PM AmbientWeather Debug Local Update Solar Radiation: 0.00
              Dec-09 8:10:02 PM AmbientWeather Debug Update Feels Like: -1.3
              Dec-09 8:10:02 PM AmbientWeather Debug Local Update Rain Weekly: 0
              Dec-09 8:10:02 PM AmbientWeather Debug Local Update Yearly Rain Total: 0
              Dec-09 8:10:02 PM AmbientWeather Debug Local Update Rain Monthly: 0
              Dec-09 8:10:02 PM AmbientWeather Debug Update Rain Last: 129
              Dec-09 8:10:02 PM AmbientWeather Debug Local Update Rain Hourly: 0
              Dec-09 8:10:02 PM AmbientWeather Debug Local Update Rain Daily: 0
              Dec-09 8:10:02 PM AmbientWeather Debug Local Update Humidity Outdoor: 74
              Dec-09 8:10:02 PM AmbientWeather Debug Update Dew Point: -5.3
              Dec-09 8:10:02 PM AmbientWeather Debug -------------------------------------------------
              Dec-09 8:10:02 PM AmbientWeather Debug ObserverIP Updating
              Dec-09 8:10:02 PM AmbientWeather Debug AmbientWeather.Net Updating
              Dec-09 8:10:00 PM AmbientWeather Debug Connection Success.
              Dec-09 8:10:00 PM AmbientWeather Debug Connecting to AmbientWeather.Net...

              HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

              Comment


                #8
                Interesting. Post screenshots of the plugin configuration and What PWS you have.

                Do all devices updated if you disable the OIP? Just remove the IP address to disable it and check if devices are all updating from AmbientWeather.Net. That debug info would be interesting to see as well.

                Comment


                  #9
                  Looks like having the IP address specified causes the problem.

                  The second image shows debug after removing the IP address for the observerIP.

                  Click image for larger version  Name:	Ambient3.jpg Views:	1 Size:	289.6 KB ID:	1265519


                  Click image for larger version  Name:	Ambient4.jpg Views:	1 Size:	270.7 KB ID:	1265520

                  dashboard.ambientweather.net/dashboard does show the outside temperature.

                  Not sure, but they seem to be the same -they update the same temp at the same time. I'll need to give that more time to be sure.

                  Robert
                  HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

                  Comment


                    #10
                    Now we have something....

                    1. Plugin is working and updating data from AmbientWeather.Net which is what it's supposed to do. This data will be the same as what is in the Dashboard when browsing from a computer as this is coming from their API and is not a web scrape or any hack or anything.

                    2. What PWS do you have? I ask because there are some models that actually have different keys in the API for the data. I've so far only ran across this once with the Yearly Rain.

                    3. I have to ask so don't be insulted. Do you REALLY have an ObserverIP Module? Or one of the Display Consoles? There has been confusion about this before and it went for days until it was realized that they did not in fact have an ObserverIP Module. If it has a screen it is not an OIP.

                    Comment


                      #11
                      No problem. I have the WS-1550-IP as noted in the first post. This one does come with the Observer module. I don't have a display console...

                      Robert

                      Here's a shot when I access the Observer directly.

                      Click image for larger version

Name:	Ambient5.jpg
Views:	16
Size:	49.7 KB
ID:	1265525
                      HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

                      Comment


                        #12
                        I'm sending you a PM with some further questions and a command.

                        Comment


                          #13
                          Sent you a PM as well. Looks like Ambient Weather dashboard shows both being the same as well.

                          Temperature -12.3°C
                          Dew Point -15.2°C
                          From Yesterday -4.1°C
                          Feels Like -12.3°C


                          EDIT:

                          ... and when you setup the Observer module for hybrid use, you only get the feels like temperature.
                          Dec-10 9:00:08 AM AmbientWeather Debug -------------------------------------------------
                          Dec-10 9:00:08 AM AmbientWeather Debug Update Feels Like: -10.2
                          Dec-10 9:00:08 AM AmbientWeather Debug Update Rain Last: 129
                          Dec-10 9:00:08 AM AmbientWeather Debug Update Dew Point: -15.0
                          Dec-10 9:00:08 AM AmbientWeather Debug -------------------------------------------------
                          Dec-10 9:00:08 AM AmbientWeather Debug AmbientWeather.Net Updating
                          Dec-10 9:00:06 AM AmbientWeather Debug -------------------------------------------------
                          Dec-10 9:00:06 AM AmbientWeather Debug Local Update Wind Speed: 1.1
                          Dec-10 9:00:06 AM AmbientWeather Debug Local Update Wind Gust Daily Max: 18.02
                          Dec-10 9:00:06 AM AmbientWeather Debug Local Update Wind Gust: 2.9
                          Dec-10 9:00:06 AM AmbientWeather Debug Local Update Wind Direction: 173
                          Dec-10 9:00:06 AM AmbientWeather Debug Local Update UV Index: 0
                          Dec-10 9:00:06 AM AmbientWeather Debug Local Update Luminance: 4832
                          Dec-10 9:00:06 AM AmbientWeather Debug Local Update Solar Radiation: 38.17
                          Dec-10 9:00:06 AM AmbientWeather Debug Local Update Rain Weekly: 0
                          Dec-10 9:00:06 AM AmbientWeather Debug Local Update Yearly Rain Total: 0
                          Dec-10 9:00:06 AM AmbientWeather Debug Local Update Rain Monthly: 0
                          Dec-10 9:00:06 AM AmbientWeather Debug Local Update Rain Hourly: 0
                          Dec-10 9:00:06 AM AmbientWeather Debug Local Update Rain Daily: 0
                          Dec-10 9:00:06 AM AmbientWeather Debug Local Update Humidity Outdoor: 67
                          Dec-10 9:00:06 AM AmbientWeather Debug ObserverIP Updating

                          Robert
                          HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

                          Comment


                            #14
                            If the AmbientWeather.Net dashboard shows the same values there's not much that can be done with that. I don't know what Ambient Weather uses to compute the feels like value. I would advise you to ask their support if that particular metric is important to you.

                            Comment


                              #15
                              I suppose they calculate it using Temperature and Relative Humidity. There are quite a few formulas and Wikipedia has a rundown on this. But, I think the bottom line is that at -12.3°C, even with a relative humidity of 79%, won't give you an answer. Some formulas will not calculate a feels like value for temperatures less than a certain value.

                              Note that the "feels like" value is calculated on the ambientweather.net server and just reported by the client software.
                              HomeSeer Version: HS3 Pro Edition 3.0.0.500
                              Operating System: Microsoft Windows 10 Pro - Work Station

                              Enabled Plug-Ins:
                              2.1.0.119: AmbientWeather | 3.0.21.0: BLLock | 2.0.24.0: BLUPS | 1.3.6.0: Device History | 3.0.0.56: EasyTrigger | 3.1.0.7: MeiHarmonyHub | 3.0.6681.34300: UltraCID3 | 3.0.6644.26753: UltraLog3 | 3.0.6554.33094: UltraMon3 | 3.0.0.91: weatherXML | 3.0.1.245: Z-Wave | 3.0.51: HS Touch Designer | 3.0.0.40 Z-Seer+

                              Comment

                              Working...
                              X