Announcement

Collapse
No announcement yet.

HS3 plugin licenses couldn't be registered on HS4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    HS3 plugin licenses couldn't be registered on HS4

    I try to apply HS3 license on HS4. it doesn't work. Do I need to buy it again?

    #2
    This plugin has not been tested on HS4 and currently I don't have plans on upgrading it just yet. I'm not sure why HST is allowing people to download plugins that aren't flagged for HS4 on HS4.
    MeiAutomtion Home

    Comment


      #3
      Originally posted by sirmeili View Post
      This plugin has not been tested on HS4 and currently I don't have plans on upgrading it just yet. I'm not sure why HST is allowing people to download plugins that aren't flagged for HS4 on HS4.
      As has been stated all along HS3 plugins are supposed to run in HS4.
      -Rupp
      sigpic

      Comment


        #4
        Originally posted by Rupp View Post

        As has been stated all along HS3 plugins are supposed to run in HS4.
        "Supposed to" and "do" are 2 completely different things. I have not validated that it runs in HS4. I was pretty sure that we had the ability to mark a plugin not HS4 compatible and if we don't we should. I dont' want to support a new platform I haven't validated yet especially with all the changes made in HS4.

        I don't have time to support HS4 and l don't have time to validate that it "just works". Hence every time someone asks I state "I have not approved this plugin for HS4"
        MeiAutomtion Home

        Comment


          #5
          Rupp If they are all supposed to "just work", can you explain to me why I have this checkbox in the admin and why my plugins that are specifically not marked to run on HS4 are somehow marked for running on HS4?

          Click image for larger version

Name:	2020-05-28_19-23-25.png
Views:	68
Size:	61.2 KB
ID:	1389323

          Click image for larger version

Name:	2020-05-28_19-23-16.png
Views:	64
Size:	255.3 KB
ID:	1389324

          Heck, I just noted the big notice right on the top (NOT ADDED BY ME) that says "Product Compatibility: HS3 Only"
          MeiAutomtion Home

          Comment


            #6
            I have the AmbientWeather PI and it does run under HS4 but sometimes you have to kick it after you reboot HS4. After reboot about half the time it shows status of INFO: Plugin start is pending. The only way I have found to get it to the correct status is to cycle the PI. Also at some point in one of the HS4 upgrades it duplicated all the devices, which I have not bothered to fix yet. I figure HS4 is at least 1 - 2 years from being Production at my house.

            Comment


              #7
              Originally posted by PFL View Post
              I try to apply HS3 license on HS4. it doesn't work. Do I need to buy it again?
              The error you are getting is because the license has no unlocks left, not because it doesnt work on HS4. PM your license and I will fix it or email support@homeseer.com and someone will get to it tomorrow.
              Jon Smith
              website | products | support | youtube

              Comment


                #8
                Originally posted by sirmeili View Post
                Rupp If they are all supposed to "just work", can you explain to me why I have this checkbox in the admin and why my plugins that are specifically not marked to run on HS4 are somehow marked for running on HS4?

                Click image for larger version

Name:	2020-05-28_19-23-25.png
Views:	68
Size:	61.2 KB
ID:	1389323

                Click image for larger version

Name:	2020-05-28_19-23-16.png
Views:	64
Size:	255.3 KB
ID:	1389324

                Heck, I just noted the big notice right on the top (NOT ADDED BY ME) that says "Product Compatibility: HS3 Only"
                That's a question for the portal devs at HST. Put in a support ticket if this isn't correct.
                -Rupp
                sigpic

                Comment

                Working...
                X