Announcement

Collapse
No announcement yet.

Annoying error in logs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Annoying error in logs

    I've been using this plugin going coming up to 2 years now and aside from a couple of quirks, it has been fine. However, in the past couple of months I seem to be getting frequent errors each day now. I have not made any changes wth this setup. So, the question is, is it my OIP or has Ambient Weather made changes to their end?
    Jun-09 2:41:54 PM AmbientWeather ERROR Exception ObserverIP.LiveData(): System.NullReferenceException: Object reference not set to an instance of an object. at HSPI_AmbientWeather.Simplex.Classes.ObserverIP.TransformLive Data(String mac, Dictionary`2 livedata)
    Does anyone have some suggestions?

    Robert
    HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

    #2
    I will crack open the code this week and see about adding some more specific logging to try and track it down. It might take a few tries as it appears to happen when you're not actively using it.
    MeiAutomtion Home

    Comment


      #3
      I've made an observation with this error and it seems to happen somewhere between 6:30 - 8:30 AM to about 6:50 PM. I've never had errors during the night. Bizzar..
      HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

      Comment


        #4
        Frank, I just wanted to let you know that the issue I have is not the plugin, so you can take it off your list. The issue is related to RF from my pool pump as the OIP is about 8-10 feet from my Pentair VS pool pump. I'm not sure why, but last year I ran the pump at night and had no issues. This year I changed it to run during the day and this is when the issue appeared. I'll need to think about relocating the OIP further away...

        Sorry about that..

        Robert
        HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

        Comment

        Working...
        X