Announcement

Collapse
No announcement yet.

Arrrrghhhh... how do I modify default scripts?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Arrrrghhhh... how do I modify default scripts?

    I'm using the 1 day forecast, and want it spoken every morning. Easy enough, but for some reason it only includes the low for the day. I'm in Texas. We need the high! How can I modify this so that it says the high temp instead of low?

    I've tried changing the weather forecast template to:

    Weather forecast for $station:
    $forecast1 and high of $todays-high

    but it simply speaks the dollar sign and 'today's high'. It speaks the forecast itself just fine.

    What am I missing here? I appreciate the assist!

  • #2
    Also, is there anywhere I can edit these default scripts? I want to replace 'wind' with 'winnd' so that the speech sounds correct. As it is it uses a long 'i' as in 'winding a watch.' That's fixed by spelling it as winnd.

    Thanks!

    Comment


    • #3
      The problem with the weather plugins and scripts is caused by changes made to the weather websites. The websites are updating their sites to make them more attractive, user friendly, mobile compatible, etc.

      So I gave up a long time ago trying to use the available plugins and scripts. I have written my own script and have learned enough in the process to make whatever changes I need to keep it working.

      I used the script "weather.txt", which was one of the first weather scripts posted on Homeseer, as a starting point for my own scripts.

      The Weather.txt script is attached if you want to have a look. I have not tried to use it for years. I'm not sure what happens when you run it!

      Good Luck!
      Steve Q
      Attached Files
      HomeSeer Version: HS3 Pro Edition 3.0.0.368, Operating System: Microsoft Windows 10 - Home, Number of Devices: 373, Number of Events: 666, Enabled Plug-Ins
      2.0.83.0: BLRF, 2.0.10.0: BLUSBUIRT, 3.0.0.75: HSTouch Server, 3.0.0.58: mcsXap, 3.0.0.11: NetCAM, 3.0.0.36: X10, 3.0.1.25: Z-Wave,Alexa,HomeKit

      Comment


      • #4
        Thanks Steve... I'll take a look. It seems like this one will do what I want... I've tried them all I think... I just want to know where it's pulling the script info from so I can modify the text to speak, and why it won't read the variable I enter. Frustrating, but overall a pretty nice plugin.

        Comment


        • #5
          It may not be the plug-in that's causing you the grief. UltraWeatherBug use the weatherbug service, it may be that your particular area is not using the high in the forecast, if they don't the plug-in won't either. In my area the forecast does usually include the expected high and low tems. it's probably different from one area or even station to another.

          You could within the same event use a small script that speaks the high-low temps using your ultraweatherbug device codes, even that though I believe only gives you the high/low temps so far that day, not the expected highs and lows.

          As far as getting wind to speak correctly, I had the same problem but I use a speech processor, BLSpeech. It allows me to correct spoken word anytime they are spoken in HomeSeer so you're not tied to a particular plug-in or scripts way of speaking. It can also be different for different voices. Some do better than others.
          Marty
          ------
          XPpro SP3 /w HS Standard 2.5.0.80, HSTouch Server - 1.0.0.70, HSTouch Client 1.0.0.73 HSTouch Android - 1.0.0.2, HSTouch iPhone - 1.0.0.2
          Playing with HS3 a bit but it's just play at this point.

          Comment


          • #6
            I think the todays-high forecast is available until noon, then gets replaced with "--".

            I added support for "weather conditions" and "forecast" replacement variables to all speak templates. In addition, I add the following new replacement variables:

            Forecast Related:

            $todays-short-prediction
            $todays-high
            $todays-low
            $tomorrows-short-prediction
            $tomorrows-high
            $tomorrows-low

            Alert Related:

            $last-alert-type
            $last-alert-title
            Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

            Comment


            • #7
              Ahhh ok. I was trying $temp-high. Let me see if todays-high does the trick. Otherwise I'm loving the plugin.

              As a side note, I bought the IVONA 'Amy' British voice and it says 'wind' with the short 'i' in context, vs' long 'i' as in winding a watch. The voice is natural and SO much better than the Windows 7 default TTS voice. A little bit ridiculous at $50 U.S. for a voice... but we're all nuts on this forum anyways!

              Comment


              • #8
                So for Speech / Weather Forecast Template I have:

                Weather forecast for Fort Worth:
                $forecast1. High temperature for today is $todays-high

                It speaks everyhting correctly, gives the forecast for the day based on the $forecast1 variable, but then speaks out the second portion, including saying "dollar sign today's high" vs. the variable value.

                Can you tell me what I'm doing wrong here? I just want to include the high temp in the morning spoken forecast (that I have as part of my wake up alarm in the AM before calling Internet Explorer and playing a specific Pandora channel.)

                Thanks!

                Comment


                • #9
                  OK I'm talking to myself a bit... but upon testing, I can add $temp-high to the Speech / Live Weather Template and it works fine. If I add it to the Weather Forecast Template it does not work. Hmmm... then if I try to use $forecast1 in the Live Weather Template it just speaks out 'dollar forecast one.'

                  So I have part of what I need available in each section. I guess for now I'll just put $temp-high in Live Weather, and $forecast1 in weather forecast template, and then have it speak both back to back until it gets figured out.

                  Comment


                  • #10
                    Please confirm you have UltraWeatherBug version 1.0.4511.31933 installed.

                    I have the following text in the speak forecast template, and it replaced the variables properly.

                    Weather forecast for $stationcity:
                    $forecast1. High temperature for today is $todays-high
                    Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                    Comment


                    • #11
                      Originally posted by Adam12hicks View Post
                      OK I'm talking to myself a bit... but upon testing, I can add $temp-high to the Speech / Live Weather Template and it works fine. If I add it to the Weather Forecast Template it does not work. Hmmm... then if I try to use $forecast1 in the Live Weather Template it just speaks out 'dollar forecast one.'

                      So I have part of what I need available in each section. I guess for now I'll just put $temp-high in Live Weather, and $forecast1 in weather forecast template, and then have it speak both back to back until it gets figured out.
                      Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                      Comment


                      • #12
                        Interesting.. I used the Updater to install, and have version:

                        1.0.4505.37293

                        vs.

                        1.0.4511.31933

                        What's the best method of updating to the most recent version? Obviously I'll check Updater first...

                        Thanks again for the assist.

                        Comment


                        • #13
                          UltraJones - thanks for the head's up. I went into Updateder and pulled down the latest version (was this just released? I've only had the software for a few days) and things are working as expected. Currently it's saying the high temp is '--' as you mentioned earlier, but I only speak the forecast in the mornings, to which you say it's there so I should be good to go.

                          I'm going to register and pay for the software shortly. Very useful.

                          Adam

                          Comment

                          Unconfigured PHP Module

                          Collapse

                          Working...
                          X