Announcement

Collapse
No announcement yet.

Live not updating

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Live not updating

    I turned on debug and captured the url and tested it. Th log is showing error 403

    I got this using the url from the log
    <error><messages><message>Exceeded developer limit configuration - </message><message>Is Developer Suspended - true </message></messages></error>

    Forecast is working ok.

    It has been working fine for many months but a few days ago I received 15 emails on the same day all with the same time of 5:35AM. The message said
    "You have exceeded the limit for your plan called for. Your calls are blocked till $expiry date. Please upgrade your plan or wait till your limit is replenished in order to continue to access this product."
    Very strange. I was not home at the time this happened.

    The HS log looks normal except for this problem with UltraWeatherBug which shows in the log at 5:33AM. . The HS log on the day it happened at 5:33 AM I see that there were 10 queries of the earthnetworks.com web site within 3 seconds then several more over the next 2 seconds which all returned the 403 error. After that when the query is made every 15 minutes the error 403 is returned.

    How can I restore things? Or, do I just have to wait - for how long?
    Last edited by noopara; October 2nd, 2014, 04:27 PM.

  • #2
    Did you sign up for the free Pro API key? That should allow you 15,000 queries per month. It's October 2, so it is unlikely you have already exceed the limit.

    Send an e-mail to apisupport@earthnetworks.com and ask them why you're getting that error.

    Regards,
    Ultrajones
    Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

    Comment


    • #3
      How many stations do you have configured> It could be possible you exceeded 15,000 if you have multiple stations using the default refresh of every 15 minutes.

      Regards,
      Ultrajones
      Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

      Comment


      • #4
        I had four stations. I have now reduced it to two and changed the query to every 30 minutes. The event that speaks a weather report uses only one station. Does your plug-in always query all the stations that are configured. I thought it only queried one and then the others if there was no response from the primary.

        I have emailed weatherbug as you suggested and am waiting for an answer.

        Comment


        • #5
          I check mine today and it to is not updating, I tried to add a new station thinking maybe it was the station and the search returns nothing at all.

          Comment


          • #6
            Still not working

            I heard back from earthnetworks and they said that the 30 day limit would be reset on Oct 6 which is the date when I first signed up.

            After that I still was not able to get the data for live weather but do still get the forecast weather.

            Today I noticed that I hit the limit again and am locked out until the 6th of next month. This is after I reduced the number of stations from 4 to 2 and changed the queries from 15 minutes to 30 minutes before Oct 6th.

            So, there seems to be some major problem here.

            It seems strange that its able to get the forecast data but not the live data???

            I notice in my HS log that every 30 minutes there are 6 query attempts by UltraWeahterBug. Shouldn't there be only 2 since I have only 2 stations configured?

            Every morning I have UltraWeatherBug speak the live weather and forcast. What it is doing is speaking the live weather like this
            "10/8/2014 9:15:19 AM ~!~TTS~!~Speak:[host]:Current weather conditions for Gig Harbor: Temperature is -- and Drizzle. Humidity is -- (feels like --). Winds -- at -- with wind gusts -- at --."

            And speaking the forecast like this
            10/8/2014 9:15:39 AM ~!~TTS~!~Speak: [host]:Weather forecast for Gig Harbor: Today, Foggy with patchy drizzle, Becoming partly sunny in the afternoon. Highs near 70. Light wind Tonight, Partly cloudy in the evening then becoming mostly cloudy. Patchy fog late in the evening. Areas of fog after midnight. Lows in the upper 40s to mid 50s. Light wind. Tomorrow, Cloudy in the morning then becoming partly sunny.......it continues for the week - it's working as it always has.

            Another difference between live and forecast is that when it speaks the live weather it uses my default speaking host (which is what I want) but when it speaks the forecast it uses *:* and speaks on my touch pads which I don't want. I don't see any settings for this. How can the speaking host be changed for the forecast?

            Should I uninstall and re-install the plug-in?

            Comment


            • #7
              Originally posted by GaryDN View Post
              I check mine today and it to is not updating, I tried to add a new station thinking maybe it was the station and the search returns nothing at all.
              It looks like their is something going on with your API key. Please send an e-mail to apisupport@earthnetworks.com and ask them if your account is locked.
              Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

              Comment


              • #8
                Originally posted by noopara View Post
                I heard back from earthnetworks and they said that the 30 day limit would be reset on Oct 6 which is the date when I first signed up.

                After that I still was not able to get the data for live weather but do still get the forecast weather.

                Today I noticed that I hit the limit again and am locked out until the 6th of next month. This is after I reduced the number of stations from 4 to 2 and changed the queries from 15 minutes to 30 minutes before Oct 6th.

                So, there seems to be some major problem here.

                It seems strange that its able to get the forecast data but not the live data???

                I notice in my HS log that every 30 minutes there are 6 query attempts by UltraWeahterBug. Shouldn't there be only 2 since I have only 2 stations configured?

                Every morning I have UltraWeatherBug speak the live weather and forcast. What it is doing is speaking the live weather like this
                "10/8/2014 9:15:19 AM ~!~TTS~!~Speak:[host]:Current weather conditions for Gig Harbor: Temperature is -- and Drizzle. Humidity is -- (feels like --). Winds -- at -- with wind gusts -- at --."

                And speaking the forecast like this
                10/8/2014 9:15:39 AM ~!~TTS~!~Speak: [host]:Weather forecast for Gig Harbor: Today, Foggy with patchy drizzle, Becoming partly sunny in the afternoon. Highs near 70. Light wind Tonight, Partly cloudy in the evening then becoming mostly cloudy. Patchy fog late in the evening. Areas of fog after midnight. Lows in the upper 40s to mid 50s. Light wind. Tomorrow, Cloudy in the morning then becoming partly sunny.......it continues for the week - it's working as it always has.

                Another difference between live and forecast is that when it speaks the live weather it uses my default speaking host (which is what I want) but when it speaks the forecast it uses *:* and speaks on my touch pads which I don't want. I don't see any settings for this. How can the speaking host be changed for the forecast?

                Should I uninstall and re-install the plug-in?
                For each station, you'll see 3 queries: 1) Live Weather, 2) Forecast, 3) Alerts. If they are all set to 30 minutes, then you'll see 6 queries every 30 minutes (3 per station). You can probably push the forecast query back to once per hour to save on queries.

                I'll add an option to keep a running total of the number of queries.

                There are about 744 hours in a month (assuming 31 days). Using the default settings, you'll get 12 queries per hour. That's 8,928 queries per month per station using default settings. If you're using the free Pulse API, you're best bet is to reduce the forecast and alert queries on the secondary station so you don't exceed the allowed queries.

                I'll look into the speaker issue. I never noticed that.

                By the way, deleting and reinstalling the plug-in won't solve any of the issues you're experiencing.

                Regards,
                Ultrajones
                Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                Comment


                • #9
                  According to earthnetworks my limit should have been reset on Oct 6. If it was it only took 3 days for it to be reached again with only two stations. I have the live weather and alerts set at 30 minutes and forecast set at 60 minutes. Before Oct 6 I had live weather and forecast set to 15 minutes and alerts at 60.

                  I will contact earthnetworks again. I am using the free API.

                  Comment


                  • #10
                    I forgot to follow up here with an update.

                    A few days after I sent the last email to them telling them that I was still not able to query the data base, they sent me an email back saying:
                    We are investigating the reported issue and have escalated it.

                    Then several days later it started working again. I didn't hear back from them.

                    If anyone is having problems getting the queries to work, just email the earthnetworks folks at apisupport@earthnetworks.com and they will work the problem. If it doesn't get fixed, email them again.

                    Comment

                    Working...
                    X