Announcement

Collapse
No announcement yet.

UltraWeatherBug Conditional Event

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • UltraWeatherBug Conditional Event

    I am attempting to automate turning off my walkway snow melting pads when there is no snow / freezing rain in the forecast. The conditional event I have shown below triggers regardless of whether or not there is snow in the forecast. My assumption was that "No Chance of Precipitation" would NOT be true if there was Snow in the forecast, but based on my experience, it would seem that "No Chance of Precipitation" would only apply to rain and not snow. Can anyone offer some insight on this?

    Thanks.

    Condition
    Station1, Today's Prediction: No Chance of Precipitation
    AND
    Station1, Tonight's Prediction: No Chance of Precipitation
    AND
    Station1, Tomorrow's Prediction: No Chance of Precipitation
    AND
    Device: ZWave Sensors & Thermostats Z-Wave Outside Snow Melters Switch Binary is ON
    AND
    Station1, Current Condition: No Precipitation

  • #2
    Hi Ultra,

    I am also having a problem using a weatherbug condition in an event. In my case I wanted the current status to be "not sunny". But the event would never run. When I clicked on the current status device for station one, the device took ~10 minutes to open. Normally my hs machine idles at 2-3% cpu, and it is a quad core xeon. If I had to guess it is that the webserver is slow and the gazillion potential status strings take a long time to load, and thus make the device useless as a condition in a trigger.

    Have you tested something like this on your own systems?
    _______________________________________________

    HS3 : HSpro (3.0.0.460) on Win2012 (vm on ESXi)
    Plugins: HSTouch, UPBSpud, Kinect, Nest, IFTTT, DirecTV, EasyTrigger, Imperihome, Zwave, RFXcom, UltraMon3, UltraWeatherBug3, UltraGCIR3, UltraLog3, UltraPioneer, PHLocation, Pushover, Pushalot, MCSSPrinklers S, JowiHue
    Jon00 Plugins: Bluetooth Proximity, Performance Monitor, DB Chart, Links

    Comment


    • #3
      The ON Conditional Event seems to be working fine... (at the moment, it covers off SNOW anywhere in the forecast, and a current condition of freezing rain) ...

      Condition
      Station1, Current Condition: Sleet/Freezing Rain/Freezing Drizzle
      AND
      Device: ZWave Sensors & Thermostats Z-Wave Outside Snow Melters Switch Binary is OFF
      OR

      Station1, Current Condition: Snow/Snow Showers/Flurries
      AND
      Device: ZWave Sensors & Thermostats Z-Wave Outside Snow Melters Switch Binary is OFF
      OR

      Station1, Today's Prediction: Snow/Snow Showers/Flurries
      AND
      Device: ZWave Sensors & Thermostats Z-Wave Outside Snow Melters Switch Binary is OFF
      OR

      Station1, Tonight's Prediction: Snow/Snow Showers/Flurries
      AND
      Device: ZWave Sensors & Thermostats Z-Wave Outside Snow Melters Switch Binary is OFF
      OR

      Station1, Tomorrow's Prediction: Snow/Snow Showers/Flurries
      AND
      Device: ZWave Sensors & Thermostats Z-Wave Outside Snow Melters Switch Binary is OFF

      Comment


      • #4
        Is your question related to HS2 or HS3?

        Regards,
        Ultrajones
        Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

        Comment


        • #5
          Originally posted by Ultrajones View Post
          Is your question related to HS2 or HS3?

          Regards,
          Ultrajones
          Not sure about OP, my observation related to HS3. Any idea what is going on? I would like to use weatherbug devices in my events. What can I do to help?
          _______________________________________________

          HS3 : HSpro (3.0.0.460) on Win2012 (vm on ESXi)
          Plugins: HSTouch, UPBSpud, Kinect, Nest, IFTTT, DirecTV, EasyTrigger, Imperihome, Zwave, RFXcom, UltraMon3, UltraWeatherBug3, UltraGCIR3, UltraLog3, UltraPioneer, PHLocation, Pushover, Pushalot, MCSSPrinklers S, JowiHue
          Jon00 Plugins: Bluetooth Proximity, Performance Monitor, DB Chart, Links

          Comment


          • #6
            Please provide a screenshot of the event so I can try to duplicate/debug.

            Regards,
            Ultrajones
            Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

            Comment


            • #7
              Originally posted by Ultrajones View Post
              Please provide a screenshot of the event so I can try to duplicate/debug.

              Regards,
              Ultrajones
              It may be simpler than that. If I try to edit the s1 current condition device it takes a long time to open. By edit I mean show the list of devices in the hs3 page (click on home), filter by plugin type: ultraweatherbug3, then click on the "s(x) current condition" device.

              I just did this and it took about a minute to open. Is this duration limiting how it can be used in an event?
              _______________________________________________

              HS3 : HSpro (3.0.0.460) on Win2012 (vm on ESXi)
              Plugins: HSTouch, UPBSpud, Kinect, Nest, IFTTT, DirecTV, EasyTrigger, Imperihome, Zwave, RFXcom, UltraMon3, UltraWeatherBug3, UltraGCIR3, UltraLog3, UltraPioneer, PHLocation, Pushover, Pushalot, MCSSPrinklers S, JowiHue
              Jon00 Plugins: Bluetooth Proximity, Performance Monitor, DB Chart, Links

              Comment


              • #8
                Originally posted by jlrichar View Post
                It may be simpler than that. If I try to edit the s1 current condition device it takes a long time to open. By edit I mean show the list of devices in the hs3 page (click on home), filter by plugin type: ultraweatherbug3, then click on the "s(x) current condition" device.

                I just did this and it took about a minute to open. Is this duration limiting how it can be used in an event?
                No, there is no relationship between the delay when displaying the HS device configuration and using the device within an event. It's taking a long time to load due to the inefficient qQuery HS uses to try to sort the graphic/status pairs. It works great with less than a handful of graphic pairs, but if you try using > 100 it just bogs down the browser. I reported this to HomeSeer a long time ago. It was never resolved.

                Regards,
                Ultrajones
                Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                Comment


                • #9
                  Originally posted by Ultrajones View Post
                  No, there is no relationship between the delay when displaying the HS device configuration and using the device within an event. It's taking a long time to load due to the inefficient qQuery HS uses to try to sort the graphic/status pairs. It works great with less than a handful of graphic pairs, but if you try using > 100 it just bogs down the browser. I reported this to HomeSeer a long time ago. It was never resolved.

                  Regards,
                  Ultrajones
                  You do indeed have an impressive amount of status graphics on this device, that must have been a lot of work to put together.

                  OK then on to the event. What I am trying to do is for not sunny days enable some of my day lighting events. I have my day lighting grouped, and tried to put some of the not sunny logic in the group conditions. I tried it a few months ago using the status of the s(x) current status device as a condition but the events would never fire even though the condition was met. I have long since deleted this from the group conditions and given up on using it because I thought this slow loading issue was causing it. Perhaps I was quick to get to that conclusion and I just flubbed the event logic somehow. At any rate, now I will try again and report back if I have issues. Thanks for clarifying what is going on.
                  _______________________________________________

                  HS3 : HSpro (3.0.0.460) on Win2012 (vm on ESXi)
                  Plugins: HSTouch, UPBSpud, Kinect, Nest, IFTTT, DirecTV, EasyTrigger, Imperihome, Zwave, RFXcom, UltraMon3, UltraWeatherBug3, UltraGCIR3, UltraLog3, UltraPioneer, PHLocation, Pushover, Pushalot, MCSSPrinklers S, JowiHue
                  Jon00 Plugins: Bluetooth Proximity, Performance Monitor, DB Chart, Links

                  Comment


                  • #10
                    My issues with snow melters and UltraWeatherBug

                    My issue re: No Precipitation seemingly not accounting for Snow in the forecast relates to HS2, Thanks.

                    Comment

                    Working...
                    X