Announcement

Collapse
No announcement yet.

Incorrect weather data

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Incorrect weather data

    Now that my radar maps have been normal for a few weeks, leave it to something else to break. I've already seen this happen a few times. The days in the forecast will change and the forecast data is wrong, too.
    The days in the photo are all 2 days ahead of what they should be, and forecast data is not for this area. I looked at the 10-day forecast on the WU page for the same station WeatherXML is using, and it doesn't line up.

    (on version 3.0.0.78)
    Attached Files

  • #2
    This has been happening about once a day now. It usually only lasts a few minutes before the correct forecast comes in, but what's strange is that it's always the same incorrect data. Always starts with Wednesday and the forecasted weather and temps are always the same. Any idea how this is happening?
    Current conditions seem legit, just nothing from the forecast.
    Here's another from just a few minutes ago:
    Attached Files

    Comment


    • #3
      And after a forecast refresh, it returns to normal:
      Attached Files

      Comment


      • #4
        Are you pulling data from a weather station or are you using the lat and lon setting?
        --
        Jeff Farmer
        HS 3, HSPhone
        My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
        Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

        Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

        Comment


        • #5
          Originally posted by CFGuy View Post
          Are you pulling data from a weather station or are you using the lat and lon setting?
          Both?

          I have both a lat/lon setting as well as a station selected, so maybe just the station.

          Comment


          • #6
            Change the dropdown that has the station selected to Use Lat/Lon
            --
            Jeff Farmer
            HS 3, HSPhone
            My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
            Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

            Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

            Comment


            • #7
              Originally posted by CFGuy View Post
              Change the dropdown that has the station selected to Use Lat/Lon
              Sounds good.

              Comment


              • #8
                Changed to lat/lon. No dice. FWIW, it only lasts for about 1 forecast update.

                Comment


                • #9
                  Seems to be happening multiple times a day now despite the location setting.

                  Comment


                  • #10
                    When the data is showing incorrect, please check the XML file to see if it has that data. I don't save any old data in the devices so I don't know how the device values would be getting set to old values.
                    --
                    Jeff Farmer
                    HS 3, HSPhone
                    My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
                    Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

                    Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

                    Comment


                    • #11
                      Mine is doing this too. Maybe once per day. The forecast is way off. I'll try to capture the xml next time.

                      Sent from my Galaxy S7 Edge using Tapatalk
                      HS3Pro Running on a Raspberry Pi3
                      64 Z-Wave Nodes, 168 Events, 280 Devices
                      UPB modules via OMNI plugin/panel
                      Plugins: Z-Wave, BLRF, OMNI, HSTouch, weatherXML, EasyTrigger
                      HSTouch Clients: 3 Android, 1 Joggler

                      Comment


                      • #12
                        If you go to the wxml schedules page there is an option checkbox labeled Backup and a textbox to set how many backup xml files to save. That way you can find a copy of the xml file. The backups are in the HS3\Data\weatherXML\backup\ directory.
                        --
                        Jeff Farmer
                        HS 3, HSPhone
                        My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
                        Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

                        Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

                        Comment


                        • #13
                          I got my XML file and I see dates in there from January 3 - January 9. I'm guessing this is where the "old" data is coming from, but why?

                          I sent a copy to your email.

                          I then did a refresh of the forecast, and the XML file shows only the current 8 days with no reference to the January days. So this looks to be on WU's end....again.
                          Attached Files

                          Comment


                          • #14
                            At least with this one I can add some code to look at the import date. If it's in the past I can stop the update of the data.
                            I've added that to my to do list.

                            Just curious, how often do you have the forecast data being downloaded?
                            --
                            Jeff Farmer
                            HS 3, HSPhone
                            My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
                            Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

                            Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

                            Comment


                            • #15
                              Originally posted by CFGuy View Post
                              At least with this one I can add some code to look at the import date. If it's in the past I can stop the update of the data.
                              I've added that to my to do list.

                              Just curious, how often do you have the forecast data being downloaded?
                              The schedule is set for every 1 hour.

                              Comment

                              Working...
                              X