Announcement

Collapse
No announcement yet.

Radar Image Updates Not Working After Recent Update

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Radar Image Updates Not Working After Recent Update

    Radar_1.gif has not been updating, since I updated to the latest version on Saturday.

    Deleting the *.gif file, does not recreate it.

    However, I see the time stamp on the device update.

    Using WUnderground for data source.

    NO, I have not hit my limits. Other data is updating correctly, just the radar images aren't. This did happen once in the past too after an update.

    NOTE: I also tried the latest beta, want to find the older version I had, but I can't see to find it, I think it was .79

    Thoughts?

  • #2
    Go to the settings page and put the logging level to debug.
    Then go to the schedules page and manually run the Maps schedule. Check the HS log for any errors. Grab the weatherXML log entries before and after any error. Either post them here or email them to me so I can try to figure out what is happening.
    --
    Jeff Farmer
    HS 3, HSPhone
    My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
    Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

    Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

    Comment


    • #3
      This is before. Only a few lines.

      Mar-04 4:47:00 PM weatherXML Check for timer items to run
      Mar-04 4:46:01 PM weatherXML Count: 1
      Mar-04 4:46:01 PM weatherXML add device 415 to the dropdownlist
      Mar-04 4:46:01 PM weatherXML Found RefID: 409
      Mar-04 4:46:01 PM weatherXML Check if this address exists: Location 1 Map Group
      Mar-04 4:46:01 PM weatherXML Found RefID: 408
      Mar-04 4:46:01 PM weatherXML Check if this address exists: Location 1 Map 1
      Mar-04 4:46:01 PM weatherXML Found RefID: 474
      Mar-04 4:46:01 PM weatherXML Set Map2
      Mar-04 4:46:01 PM weatherXML Set Map Device 2
      Mar-04 4:46:01 PM weatherXML Reset Map Dropdown for location 1
      Mar-04 4:46:01 PM weatherXML Check if this address exists: Location 1 Weather Map
      Mar-04 4:46:01 PM weatherXML Set Map1
      Mar-04 4:46:01 PM weatherXML Set Map Device 1
      Mar-04 4:46:01 PM weatherXML Swap the values
      Mar-04 4:46:01 PM weatherXML HS web URL: /images/weatherXML/radar_1.gif
      Mar-04 4:46:01 PM weatherXML mapSwapValue: LocID: 1, ChildRefID: 415
      Mar-04 4:46:01 PM weatherXML RefID: 415
      Mar-04 4:46:00 PM weatherXML downloadFromURL: /images/weatherXML/radar_1.gif
      Mar-04 4:46:00 PM weatherXML Triggers to check: 0
      Mar-04 4:46:00 PM weatherXML Check if this address exists: Location 1 Map Group
      Mar-04 4:46:00 PM weatherXML Found RefID: 408


      That is debug logging. I always have had this setup for debug logging.

      There is no error, yet the image never updates, even though it states it downloaded it.

      Further, if I delete it, it never creates it.

      Other suggestions?

      Comment


      • #4
        Can you go to the map device, and post a screen shot of how you have the map device setup?

        Also the setup for the Map Device for the Location Map Group device.
        --
        Jeff Farmer
        HS 3, HSPhone
        My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
        Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

        Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

        Comment


        • #5
          These, if I recall are the two places that I have setup details. It has been a long time since I needed to review this, as it was working well....

          If there is another location you require, please let me know. I just want to restate, the schedule runs, seems to update the timestamp of the device, but the image itself is never saved.
          Attached Files

          Comment


          • #6
            Go to the HS device management page.
            Look for a device called weatherXML weatherMaps Location 1 Map Group.

            Click on the name to edit. When you get to the page with Configuration and Status Graphics, look for a tab labeled weatherXML.
            There is a textbox labeled "Maps Save To Folder". By default it will have "maps\" in it. There is also a red circle icon that when clicked will open an pdf file with instructions for the changes to maps.

            Look in the directory HS 3/html/images/weatherXML/maps/
            This textbox is controlling where the images are being saved.
            It was changed in version .74 to stop using ini files to save the map information. There was an issue where the ini file would get corrupted and lose the information for the maps. That info is now stored in map devices and the ini file is no longer used.
            --
            Jeff Farmer
            HS 3, HSPhone
            My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
            Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

            Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

            Comment


            • #7
              @Jeff,

              Seeing an issue here relating to my WeatherXML running in Linux.

              Thinking I mentioned the two updates on the HS3 Pro box earlier.

              Looking at the HS3 Lite box running V.3.0.0.83. Maps are updating fine.

              Looking at the HS3 Pro box running V3.0.0.82. There is no update to 3.0.0.83 listed.

              That said the maps are being updated but in the wrong directory.

              Note this is only in Linux HS3 Pro running 3.0.0.82.

              [ATTACH]67248[/ATTACH]

              Note to test I deleted all of the maps on the two boxes.

              I had no issues adding maps to the HS3 Lite (zee2) box running 3.0.0.83.

              As mentioned above I do not see an update to 3.0.0.83 from 3.0.0.82 on the HS3 Pro box.
              - Pete

              Auto mator
              Homeseer 3 Pro - 3.0.0.500 (Linux) - Ubuntu 18.04 64 bit Intel CPU - Mono 5.18
              Homeseer Zee2 (Lite) - 3.0.0.500 (Linux) - Ubuntu 18.04 64 bit Arm CPU - Mono 5.20

              X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

              Comment


              • #8
                Well, that explains a lot, and is working now!

                I must have missed some of the release notes on that, I did see the "add new" and "Update Maps", but really did not look into those.

                So, I assume the other, rouge, devices that are not updating now are safe to physically delete from the HS device management page?

                Thank you for the help.

                Comment


                • #9
                  Originally posted by Pete View Post
                  @Jeff,

                  Seeing an issue here relating to my WeatherXML running in Linux.

                  Thinking I mentioned the two updates on the HS3 Pro box earlier.

                  Looking at the HS3 Lite box running V.3.0.0.83. Maps are updating fine.

                  Looking at the HS3 Pro box running V3.0.0.82. There is no update to 3.0.0.83 listed.

                  That said the maps are being updated but in the wrong directory.

                  Note this is only in Linux HS3 Pro running 3.0.0.82.

                  Note to test I deleted all of the maps on the two boxes.

                  I had no issues adding maps to the HS3 Lite (zee2) box running 3.0.0.83.

                  As mentioned above I do not see an update to 3.0.0.83 from 3.0.0.82 on the HS3 Pro box.

                  Looks like the weatherXML beta was removed from the beta section in the updater. I went ahead and moved .83 to the current release so you can update to it.

                  The directory that the maps are saved in is controlled by the main Map device. In the Plug-ins dropdown menu go to weatherXML then click on Documentation. There is a PDF titled "Map Devices. Setup and use of map devices."

                  If you go to the HS Device Management page, look for the device Location 1 Map Group. In the Map Device pdf there is an explanation on how to set what directory the maps will be saved in. By default this will be set to "maps\" but you can control it by location so you could have "maps1\" and "maps2\" to separate maps by location. You could do "maps\My City\" .
                  Up to you where you store them. When the map schedule runs it will check your settings to know where to save the maps and how to add them to the Status Graphics tab for use in HSTouch or other places.
                  --
                  Jeff Farmer
                  HS 3, HSPhone
                  My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
                  Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

                  Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

                  Comment


                  • #10
                    Thank you Jeff. I will update.

                    Yes here the maps are in the html/images/weatherxml/maps directory on V.83.
                    Last edited by Pete; March 6th, 2018, 04:38 PM.
                    - Pete

                    Auto mator
                    Homeseer 3 Pro - 3.0.0.500 (Linux) - Ubuntu 18.04 64 bit Intel CPU - Mono 5.18
                    Homeseer Zee2 (Lite) - 3.0.0.500 (Linux) - Ubuntu 18.04 64 bit Arm CPU - Mono 5.20

                    X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

                    Comment

                    Working...
                    X