Announcement

Collapse
No announcement yet.

NOAA Forecast and Alerts stopped working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • NOAA Forecast and Alerts stopped working

    After the 4:05 pm update on April 2, the import of forecasts and alerts from NOAA stopped working. Conditions import works for data, but errors sometimes on the image. If I click on the links in a browser, it successfully loads the web page. Using version 3.0.0.83. I have made no changes to my setup. Log errors are as follows:

    for Alerts:
    Apr-04 9:15:00 AM weatherXML Error downloadFile: NOAA Weather Alerts from: http://alerts.weather.gov/cap/wwaatm...p?x=NCC081&y=0. Error: The underlying connection was closed: An unexpected error occurred on a send.


    For forecasts:
    Apr-04 9:23:13 AM weatherXML Error File: C:\Program Files\HomeSeer HS3\Data\weatherXML\NOForecast1.xml does not exist. Unable to continue import.
    Apr-04 9:23:13 AM weatherXML Error downloadFile: NOAA Weather Forecast from: http://forecast.weather.gov/MapClick...&FcstType=dwml. Error: The underlying connection was closed: An unexpected error occurred on a send.
    Apr-04 9:22:59 AM weatherXML Error downloadFile: weatherXML: curcond.jpg from: http://forecast.weather.gov/images/wtf/small/bkn.png. Error: The underlying connection was closed: An unexpected error occurred on a send.

    For conditions:
    Apr-04 6:05:00 AM weatherXML Error downloadFile: weatherXML: curcond.jpg from: http://forecast.weather.gov/images/wtf/small/novc.png. Error: The underlying connection was closed: An unexpected error occurred on a send.

    Any help greatly appreciated!
    Fred

    HomeSeer Pro 3.0.0.478, HS3Touch, Zwave 3.0.1.249, Envisalink DSC 3.0.0.40, WeatherXML, Z-stick, HS phone, Way2Call

  • #2
    I'm seeing the same error messages.
    Dick
    HS PRO 2.5.0.81, WinXP, IE8, Shuttle XS35V3, 2.13GHz, 4GB, 40GB SSD drive, AC-RF2, ADIOcelot, Message Server, TI103, SNEVL CID, pjcOutlook, MCSTemperature, Powertrigger, BLBackup, BLFloorplan, BLIcon, BLOccupied, BLRadar, BLRfid, BLLogMonitor, ACPUPSD, UltraECM, WeatherXML & Stipus' script connector. 500+ devices, 260+ events, 1-wire weather station + temp/humidity sensors & Oregon Scientific temp & humidity sensors & 2 Brultech ECM-1240s

    Comment


    • #3
      NOAA Forecast and Alerts stopped working

      I began seeing exactly the same messages as well, beginning with my 16:15 EDT update on April 2. Thinking it was my system, I restarted the plugin, restarted HS3, cold started my machine, all to no avail. I also replicated that the URL works in a browser. Your report pretty much confirms it is probably an issue at NOAA. The only difference I see is that I am using version 3.0.0.73. Incidentally, I only noticed this yesterday when I happened to check the log because my wife noted that the system spoke a forecast that didn't make sense... I don't check the log daily. I wish there was a way to get a notification whenever the log records such errors.

      Comment


      • #4
        For the alerts the URL is entered wrong.
        On the page to setup the alerts the url starts with:
        http://alerts.weather.gov/
        In the textbox you need to have:
        /cap/ks.php?x=0

        The only change would be to replace the ks with the 2 letter abbreviation for your state.
        Anything else will not return an xml file that can be imported.

        For the conditions and forecast, I'll keep an eye on my setup tomorrow to see if I can duplicate this.

        Originally posted by ITguyHS View Post
        After the 4:05 pm update on April 2, the import of forecasts and alerts from NOAA stopped working. Conditions import works for data, but errors sometimes on the image. If I click on the links in a browser, it successfully loads the web page. Using version 3.0.0.83. I have made no changes to my setup. Log errors are as follows:

        for Alerts:
        Apr-04 9:15:00 AM weatherXML Error downloadFile: NOAA Weather Alerts from: http://alerts.weather.gov/cap/wwaatm...p?x=NCC081&y=0. Error: The underlying connection was closed: An unexpected error occurred on a send.

        For forecasts:
        Apr-04 9:23:13 AM weatherXML Error File: C:\Program Files\HomeSeer HS3\Data\weatherXML\NOForecast1.xml does not exist. Unable to continue import.
        Apr-04 9:23:13 AM weatherXML Error downloadFile: NOAA Weather Forecast from: http://forecast.weather.gov/MapClick...&FcstType=dwml. Error: The underlying connection was closed: An unexpected error occurred on a send.
        Apr-04 9:22:59 AM weatherXML Error downloadFile: weatherXML: curcond.jpg from: http://forecast.weather.gov/images/wtf/small/bkn.png. Error: The underlying connection was closed: An unexpected error occurred on a send.

        For conditions:
        Apr-04 6:05:00 AM weatherXML Error downloadFile: weatherXML: curcond.jpg from: http://forecast.weather.gov/images/wtf/small/novc.png. Error: The underlying connection was closed: An unexpected error occurred on a send.

        Any help greatly appreciated!
        --
        Jeff Farmer
        HS 3, HSPhone
        My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
        Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

        Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

        Comment


        • #5
          Thanks, Jeff. Made the change. Still getting the error. As before, going to the URL with a browser returns the XML page.

          Apr-05 9:55:00 AM weatherXML Error downloadFile: NOAA Weather Alerts from: http://alerts.weather.gov/cap/nc.php?x=0. Error: The underlying connection was closed: An unexpected error occurred on a send.
          Fred

          HomeSeer Pro 3.0.0.478, HS3Touch, Zwave 3.0.1.249, Envisalink DSC 3.0.0.40, WeatherXML, Z-stick, HS phone, Way2Call

          Comment


          • #6
            I've been running 2 locations using NOAA and have not gotten any errors.

            Can you try stopping the plugin and restarting it?
            See if that clears whatever is keeping the files from downloading.
            --
            Jeff Farmer
            HS 3, HSPhone
            My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
            Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

            Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

            Comment


            • #7
              Hmmm... I can report that I tried restarting the plugin (along with restarting everything else including the machine) to no avail. Note that when I first noticed the issue I was on version 3.0.0.73, and yesterday I updated to the current version, but the error keeps on comin'.
              - Bill

              Comment


              • #8
                Originally posted by CFGuy View Post
                I've been running 2 locations using NOAA and have not gotten any errors.

                Can you try stopping the plugin and restarting it?
                See if that clears whatever is keeping the files from downloading.
                Have tried all the following, error still exists.
                1. Stop/start plugin
                2. Stop/start HS3
                3. Change latitude/longitude, then restart plugin

                One thing I noticed is that if I bring up the forecast page in a browser, I get a message at the top that says "This XML file does not appear to have any style information associated with it. The document tree is shown below." May have absolutely nothing to do with the problem, but thought I should mention it.

                Jeff, could you give us the latitude/longitude of a location that's working for you and let us try it?

                Thanks!
                Fred

                HomeSeer Pro 3.0.0.478, HS3Touch, Zwave 3.0.1.249, Envisalink DSC 3.0.0.40, WeatherXML, Z-stick, HS phone, Way2Call

                Comment


                • #9
                  Jeff,

                  I created a new location to see if that would make any difference. Still errors out. Here's the "debug mode" log entries.


                  Apr-07 10:28:50 AM weatherXML Download Status: Failure
                  Apr-07 10:28:50 AM weatherXML Error downloadFile: NOAA Weather Forecast from: http://forecast.weather.gov/MapClick...&FcstType=dwml. Error: The underlying connection was closed: An unexpected error occurred on a send.
                  Apr-07 10:28:49 AM weatherXML Downloading the NOAA Weather Forecast file at http://forecast.weather.gov/MapClick...&FcstType=dwml.
                  Apr-07 10:28:49 AM weatherXML Replacement URL: http://forecast.weather.gov/MapClick...&FcstType=dwml
                  Apr-07 10:28:49 AM weatherXML Forecast Source: noaa
                  Apr-07 10:28:49 AM weatherXML Running Forecast
                  Apr-07 10:28:32 AM weatherXML page: weatherXML_loc, data: locNOAAForecastlon_3=-79.9742
                  Apr-07 10:28:23 AM weatherXML Locations Allowed: 10, In Use: 3
                  Apr-07 10:28:23 AM weatherXML Found RefID: 311
                  Apr-07 10:28:23 AM weatherXML Check if this address exists: Location 3 Map Group
                  Apr-07 10:28:23 AM weatherXML Found RefID: 311
                  Apr-07 10:28:23 AM weatherXML Check if this address exists: Location 3 Map Group
                  Apr-07 10:28:23 AM weatherXML Found RefID: 220
                  Apr-07 10:28:23 AM weatherXML Check if this address exists: Speak Items Root
                  Apr-07 10:28:23 AM weatherXML Found RefID: 220
                  Apr-07 10:28:23 AM weatherXML Check if this address exists: Speak Items Root
                  Apr-07 10:28:23 AM weatherXML page: weatherXML_loc, data: id=deviceSelector&deviceSelector=3
                  Apr-07 10:28:15 AM weatherXML Locations Allowed: 10, In Use: 3
                  Apr-07 10:28:15 AM weatherXML Found RefID: 289
                  Apr-07 10:28:15 AM weatherXML Check if this address exists: Location 1 Map Group
                  Apr-07 10:28:15 AM weatherXML Found RefID: 289
                  Apr-07 10:28:15 AM weatherXML Check if this address exists: Location 1 Map Group
                  Apr-07 10:28:15 AM weatherXML Found RefID: 220
                  Apr-07 10:28:15 AM weatherXML Check if this address exists: Speak Items Root
                  Apr-07 10:28:15 AM weatherXML Found RefID: 220
                  Apr-07 10:28:15 AM weatherXML Check if this address exists: Speak Items Root
                  Fred

                  HomeSeer Pro 3.0.0.478, HS3Touch, Zwave 3.0.1.249, Envisalink DSC 3.0.0.40, WeatherXML, Z-stick, HS phone, Way2Call

                  Comment


                  • #10
                    Here is what I am using for the location I have setup to use NOAA.
                    For current conditions:
                    KLWC

                    For Forecast:
                    Latitude: 38.93721329
                    Longitude: -95.21652899

                    Alerts:
                    /cap/ks.php?x=0


                    The thing that stands out as weird on your error logs is that it says:
                    Error: The underlying connection was closed: An unexpected error occurred on a send.

                    It's not erroring on what would normally be sent back to you. It is erroring on the outgoing. On sending from the HS comoputer.
                    Are you running Windows 10? If so, have you had any recent updates from Microsoft? Wondering if something got updated and isn't letting the request out.
                    --
                    Jeff Farmer
                    HS 3, HSPhone
                    My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
                    Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

                    Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

                    Comment


                    • #11
                      Similarly, I also ran debug logging:
                      Apr-06 17:01:00 weatherXML Staus: Failure
                      Apr-06 17:01:00 weatherXML Error downloadFile: NOAA Weather Alerts from: http://alerts.weather.gov/cap/wwaatm...p?x=OHZ078&y=0. Error: The underlying connection was closed: An unexpected error occurred on a send.
                      Apr-06 17:01:00 weatherXML Downloading the NOAA Weather Alerts file at http://alerts.weather.gov/cap/wwaatm...p?x=OHZ078&y=0.
                      Apr-06 17:01:00 weatherXML Replacement URL: http://alerts.weather.gov/cap/wwaatm...p?x=OHZ078&y=0
                      Apr-06 17:01:00 weatherXML URL: http://alerts.weather.gov/cap/wwaatm...p?x=OHZ078&y=0
                      Apr-06 17:01:00 weatherXML Last Update: 04.02.18 16:00:58
                      Apr-06 17:01:00 weatherXML Alert to check: 1
                      Apr-06 17:01:00 weatherXML Existing alert file last updated at 2018-04-02T20:00:58+00:00
                      Apr-06 17:01:00 weatherXML The file C:\Program Files\HomeSeer HS3\Data\weatherXML\NOAlerts1.xml is ready for import.
                      Apr-06 17:01:00 weatherXML The file C:\Program Files\HomeSeer HS3\Data\weatherXML\NOAlerts1.xml is ready for import.
                      Apr-06 17:01:00 weatherXML Running Alert for location 1
                      Apr-06 17:01:00 weatherXML Triggers to check: 0
                      Apr-06 17:01:00 weatherXML Check for timer items to run
                      Apr-06 17:00:00 weatherXML Check for timer items to run

                      In my case, the machine is running XP so I'm pretty sure there were no OS updates. I will check to see if maybe a router or cable modem received an update, but what are the odds that all three of us had equipment updates at the same time? This is an odd one.
                      - Bill

                      Comment


                      • #12
                        Originally posted by CFGuy View Post
                        Are you running Windows 10? If so, have you had any recent updates from Microsoft? Wondering if something got updated and isn't letting the request out.
                        Nope. Running XP with updates turned off. I tried a new location with your settings. Same Error.

                        I did notice one thing - when you enter the URL in a browser, it gets changed from http: to https:. Is it possible that that isn't happening when WXML tries to access the page and maybe NOAA now requires https?
                        Fred

                        HomeSeer Pro 3.0.0.478, HS3Touch, Zwave 3.0.1.249, Envisalink DSC 3.0.0.40, WeatherXML, Z-stick, HS phone, Way2Call

                        Comment


                        • #13
                          Have discovered this is NOT a WeatherXML problem. Installed test setup of HS on a Win10 machine. Copied over WXML settings from the XP machine. Everything about WXML runs fine! This eliminates network, router, etc. problems as a possible cause. Also turned off firewall on the XP machine to see if that could be the problem. That didn't help.

                          I'm now suspecting an expired certificate on XP. Still investigating. Will post more when I have some answers.
                          Fred

                          HomeSeer Pro 3.0.0.478, HS3Touch, Zwave 3.0.1.249, Envisalink DSC 3.0.0.40, WeatherXML, Z-stick, HS phone, Way2Call

                          Comment


                          • #14
                            That's a step forward! Seems we are all using XP. The good news is, regarding the current conditions, is that although I still get "downloadFile: weatherXML: curcond.jpg from: http://forecast.weather.gov/images/wtf/small/skc.png. Error: The underlying connection was closed: An unexpected error occurred on a send", the database still populates the data as seen on the user pages/data page. Seems it only fails when it gets to the skc.png image file. Not sure why that would be.

                            Comment


                            • #15
                              Arrrrrgh! Took me hours to find out how to update the certificates in XP. But that didn't solve the problem!

                              Is anyone using WeatherXML on an XP machine and still have forecasts working?
                              Fred

                              HomeSeer Pro 3.0.0.478, HS3Touch, Zwave 3.0.1.249, Envisalink DSC 3.0.0.40, WeatherXML, Z-stick, HS phone, Way2Call

                              Comment

                              Working...
                              X