Announcement

Collapse
No announcement yet.

WeatherXML and NOAA log error "Index was outside the bounds of the array"

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • WeatherXML and NOAA log error "Index was outside the bounds of the array"

    I am getting the following errors in my log today when troubleshooting why WeatherXML stopped loading forecast for me:
    Aug-05 07:26:03 PM weatherXML Error adminWeb map select: Index was outside the bounds of the array.
    Aug-05 07:23:31 PM weatherXML Error triggerList: Index was outside the bounds of the array.
    Aug-05 05:38:49 PM weatherXML Error adminHST: Index was outside the bounds of the array.
    Aug-05 07:21:53 PM weatherXML Error Index was outside the bounds of the array.
    Aug-05 05:38:48 PM weatherXML Error advImages: Index was outside the bounds of the array.
    Aug-05 05:38:46 PM weatherXML Error alertSetup: Index was outside the bounds of the array.
    Aug-05 05:37:41 PM weatherXML Error adminWeb map select: Index was outside the bounds of the array.
    Aug-05 05:38:04 PM weatherXML Error Index was outside the bounds of the array.
    I get errors when I choose many of the choices inside the controls for the plugin and when is says anything beyond error its about being outside the bounds of the array.

    I have looked around the forum and can't find anything I can do to correct my problem. I'd appreciate some help getting the forecast back up and functioning again.

    Thanks in advance for any help.

    Oscar

    System Profile
    Current Date/Time: 8/5/2018 07:37:12 PM
    HomeSeer Version: HS3 Standard Edition 3.0.0.318
    Operating System: Microsoft Windows 10 Home - Work Station
    System Uptime: 3 Days 0 Hours 1 Minute 40 Seconds
    IP Address: 192.168.1.15
    Number of Devices: 399
    Number of Events: 216
    Available Threads: 200

    Enabled Plug-Ins
    3.0.0.22: Autelis
    3.7.2.0: Harmony Hub
    3.0.0.68: HSTouch Server
    3.0.0.21: Sonos
    3.0.6678.32449: UltraECM3
    3.0.0.88: weatherXML
    3.0.0.36: X10
    3.0.1.190: Z-Wave

  • #2
    The error you are seeing, is usually caused by the ini files being corrupted. Look in a backup in the directory, HomeSeer HS3/config/weatherxml. Grab the ini files there and copy them to your install. There have been issues when HS was closing down while the ini files are being written to, they get corrupted.
    --
    Jeff Farmer
    HS 3, HSPhone
    My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
    Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

    Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

    Comment


    • #3
      That fixed the problem. Thank you!

      Comment

      Working...
      X