Announcement

Collapse
No announcement yet.

WeatherXML Event Trigger error

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • WeatherXML Event Trigger error

    I started noticing that a few of my HVAC events stopped triggering every morning and when I went to look at the event I noticed that one of my triggers had an error that I've never seen before. One of the conditions of this event is a WeatherXML condition but I'm not sure if it would be an issue with WeatherXML or an HS3 issue. Thought I would start here first.
    Click image for larger version

Name:	Untitled.png
Views:	1
Size:	6.3 KB
ID:	1260577
    HS3 3.0.0.500 &HSTouch Designer 3.0.71 with 782 Devices, 479 Events
    Plugin's:
    BLBackup, BLOccupied, BLShutdown, EasyTrigger, Ecobee,
    EnvisaLink DSC, PHLocation, Pushover, SONOS, Blue Iris, UltraRachio3,
    weatherXML, Jon00 Alexa Helper, Network Monitor, Z-Wave 3.0.1.252

  • #2
    Are you seeing any errors in the log? Do you remember which condition the AND IF is?
    --
    Jeff Farmer
    HS 3, HSPhone
    My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
    Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

    Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

    Comment


    • #3
      Originally posted by CFGuy View Post
      Are you seeing any errors in the log? Do you remember which condition the AND IF is?
      I don't have any errors relating to WeatherXML getting the information needed for the condition (weather forecast), the only error in the log is the one relating to the fact that the condition no longer exists:
      Nov-19 6:00:17 AM Warning Exception attempting to evaluate a plug-in trigger in event HVAC HVAC - Office On Day-Cold Forcast: Index was outside the bounds of the array.
      Nov-19 6:00:17 AM Warning Exception attempting to evaluate a plug-in trigger in event HVAC HVAC - Office On Day-Cold Forcast: Index was outside the bounds of the array.
      Nov-19 6:00:17 AM Warning Exception attempting to evaluate a plug-in trigger in event HVAC HVAC - Office On Day-Hot Forcast: Index was outside the bounds of the array.
      Nov-19 6:00:17 AM Warning Exception attempting to evaluate a plug-in trigger in event HVAC HVAC - Office On Day-Hot Forcast: Index was outside the bounds of the array.
      I looked in the other events that I use the same condition for and all of them are showing the same error. The original trigger/condition that was used evaluated the forecast high for the day. I tried to edit it but you can see that once I select Forcast it greys out the area where I could make my next selection.
      Click image for larger version

Name:	Untitled.png
Views:	3
Size:	27.1 KB
ID:	1260612


      I just went to the location setup screen, the location is no longer there and gives the same error as the trigger/conditions.
      Click image for larger version

Name:	Untitled1.png
Views:	1
Size:	17.5 KB
ID:	1260613
      HS3 3.0.0.500 &HSTouch Designer 3.0.71 with 782 Devices, 479 Events
      Plugin's:
      BLBackup, BLOccupied, BLShutdown, EasyTrigger, Ecobee,
      EnvisaLink DSC, PHLocation, Pushover, SONOS, Blue Iris, UltraRachio3,
      weatherXML, Jon00 Alexa Helper, Network Monitor, Z-Wave 3.0.1.252

      Comment


      • #4
        I suspect the ini files have gotten corrupted. Stop the plugin and find a backup of the ini files that are in the HS3/config/weatherXML directory. Put the backup files in the drectory over-writing the ones that are currently there. Restart the plugin.
        --
        Jeff Farmer
        HS 3, HSPhone
        My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
        Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

        Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

        Comment


        • #5
          Originally posted by CFGuy View Post
          I suspect the ini files have gotten corrupted. Stop the plugin and find a backup of the ini files that are in the HS3/config/weatherXML directory. Put the backup files in the drectory over-writing the ones that are currently there. Restart the plugin.
          Ok, retrieved a backup that I did before the last event trigger date and copied all of the files from the folder you indicated and pasted them in after disabling the plugin and everything is back to normal including the events!

          Thank you Jeff!


          Sent from my iPad using Tapatalk
          HS3 3.0.0.500 &HSTouch Designer 3.0.71 with 782 Devices, 479 Events
          Plugin's:
          BLBackup, BLOccupied, BLShutdown, EasyTrigger, Ecobee,
          EnvisaLink DSC, PHLocation, Pushover, SONOS, Blue Iris, UltraRachio3,
          weatherXML, Jon00 Alexa Helper, Network Monitor, Z-Wave 3.0.1.252

          Comment

          Working...
          X