Announcement

Collapse
No announcement yet.

Precipitation is not updating

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Precipitation is not updating

    Click image for larger version

Name:	Screen Shot 2019-02-16 at 3.21.39 PM.png
Views:	1
Size:	410.1 KB
ID:	1285450
    For some reason, the precipitation values quit updating for me. Today is 2/16, and they have not updated in many days. Any thoughts? Everything else seems to be working great.

    Thanks.

  • #2
    Which provider are you using for the the weather info?
    Are you getting any errors in the log?
    --
    Jeff Farmer
    HS 3, HSPhone
    My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
    Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

    Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

    Comment


    • #3
      I assume NOAA since Weatherbug does not offer APIs any longer. No errors seen in the Homeseer log.

      Comment


      • #4
        Originally posted by cmdrcrank View Post
        I assume NOAA since Weatherbug does not offer APIs any longer. No errors seen in the Homeseer log.
        It could also be World Weather Online, which did you configure in the Plugin?
        HS3 SEL running Pro Edition 3.0.0.531 on Ubuntu 18.04, mono 5.20, 656 devices, 209 events.
        Plug-Ins: Chromecast, Device History, EasyTrigger, Ecobee, JowiHue, LutronCaseta, MeiUnifi, PHLocation2, Pushover 3P, SDJ-Health, Sonos, WeatherFlow, weatherXML
        Scripts: SparkMan's Lock Event, 5 of Jon00 scripts.

        Comment


        • #5
          Click image for larger version

Name:	Screen Shot 2019-02-16 at 7.31.11 PM.png
Views:	1
Size:	133.0 KB
ID:	1285512 Nope, it is NOAA

          Comment


          • #6
            Jeff, any thoughts? I can post a copy of my weatherXML schedule if that helps. I have debugging turned on and get a ton of verbose weatherXML log data, but don't see anything indicating an error for precipitation. It is as if the plug-in simply no longer requests that data from NOAA as my values never update. Thanks.

            Comment


            • #7
              Until this is fixed, I created a script to parse the text of the forecast for today: (the code is not optimized, but it will do until the values start populating again)

              Dim precipitation as Integer
              precipitation = hs.DeviceValue(159)
              If precipitation <> -999 Then
              Dim results1 = SetDeviceByControlValue(451, precipitation)
              hs.WriteLog("Precipitation ", precipitation)
              Else
              ‘Chance of precipitation is
              ‘Today’s forecast 153
              Dim todaysForecast as String = hs.DeviceString(153)
              hs.WriteLog(“Todays forecast to be parsed “, todaysForecast)
              Dim loc1 as Integer = InStr(todaysForecast,”Chance of precipitation is ")
              Dim precipitationStr as String = Mid(todaysForecast, loc1)
              hs.WriteLog("Precipitation Str Value 1 ", precipitationStr)
              precipitationStr = Mid(precipitationStr, 28)
              hs.WriteLog("Precipitation Str Value 2 ", precipitationStr)
              loc1 = InStr(precipitationStr, ”%”)
              precipitationStr = Left(precipitationStr, loc1 - 1)
              hs.WriteLog("Precipitation Str Value 3 ", precipitationStr)
              precipitation = precipitationStr
              Dim results1 = SetDeviceByControlValue(451, precipitation) ' this is a function. I can post it if anyone needs it
              hs.WriteLog(“Parsed Precipitation ", precipitation)
              End If

              Comment


              • #8
                Email me one of the NOForecast xml files. I want to confirm that the data is in the file.

                jeff at myautomatedhome.net
                Last edited by CFGuy; February 17th, 2019, 04:30 PM. Reason: Add Email
                --
                Jeff Farmer
                HS 3, HSPhone
                My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
                Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

                Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

                Comment


                • #9
                  I sent it the day you requested it.

                  Comment


                  • #10
                    The data is in the file.
                    Delete the Precipitation devices.
                    Then go to the Settings page. For logging level, select weatherXML webpage.
                    Then go to the HSTouch\Data page and reselect the precipitation devices.
                    Confirm they are recreated.
                    You should now have an extra menu button labeled Misc.
                    Click on the page and when the log entries load, click on clear log.
                    Next, go to the Schedules page and manually Run the forecast schedule.
                    Wait until the start and end times update, the click on the menu button labeled Misc.
                    When the page loads, click on the button Save To File.
                    Go back to the settings page, and change the logging level back to errors.

                    There will be a file in the Homeseer HS3/data/weatherXML directory called logOutput.txt.
                    Please send that to me.
                    --
                    Jeff Farmer
                    HS 3, HSPhone
                    My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
                    Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

                    Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

                    Comment


                    • #11
                      Thanks for the instructions. Here is the file. Thanks.
                      Attached Files

                      Comment


                      • #12
                        Are you using the phLocation plugin? From the file it looks like you have the same device selected for both the Latitude device and the Longitude device. The device refID is 260 for both. Device 260 does not have a string value set so it looks to the device value. That is coming back as a 1. In effect, the forecast gets run with a latitude of 1 and a longitude of 1.
                        Since NOAA uses a StationID for conditions and the Lat and Long for Forecast, this would cause issues with the forecast.

                        When the logOutput gets to the forecast section here is the url that is using.
                        PHP Code:
                        http://forecast.weather.gov/MapClick.php?lat=1&lon=1&FcstType=dwml 

                        Note the lat and lon values. You will need to set the lat and lon to the values for your location. Also if you are not using PHLocation that provides the Lat and Lon value, then on the weatherXML Locations page, select the 'Please Select' option in the dropdowns for the 3 PHLocation devices.

                        --
                        Jeff Farmer
                        HS 3, HSPhone
                        My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
                        Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

                        Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

                        Comment


                        • #13
                          Yes, I am using PhLocation2, and the Lat/Long are setup correctly (see attachments).
                          Attached Files

                          Comment


                          • #14
                            there is another place in the WeatherXML Locations Setup for forecast that contains a lat/long. I have manually set that 5 times, but it does default to 1/1. I do not know why. My PhLocation2 location is correct. All of my other forecast values for WeatherXML are for Chattanooga, TN, which is accurate.
                            Attached Files

                            Comment


                            • #15
                              I can set the value, but once the scheduled forecast download occurs, something changes the values back to 1/1.
                              Attached Files

                              Comment

                              Working...
                              X