Announcement

Collapse
No announcement yet.

weatherXML changes for DarkSky

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Does anyone know if DarkSky provides Last Years High/Low temp? I've got the devices checked in the devices page but the value in HS web UI hasn't populated for the last several days.
    HS3 3.0.0.548 &HSTouch Designer 3.0.71 with 887 Devices, 515 Events
    Plugin's:
    BLBackup, BLOccupied, BLShutdown, EasyTrigger, Ecobee,
    EnvisaLink DSC, PHLocation, Pushover, SONOS, Blue Iris, UltraRachio3,
    weatherXML, Jon00 Alexa Helper, Network Monitor, MyQ, Z-Wave 3.0.1.252

    Comment


    • They are part of the values that will only update once a day. Go to the Locations page and look for the Daily Section. You have the option to select Last Year Temps and/or Moon Phases. Next go to the Schedules page and make sure that you have the Daily Schedule activated.
      --
      Jeff Farmer
      HS 3, HSPhone
      My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
      Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

      Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

      Comment


      • Originally posted by CFGuy View Post
        They are part of the values that will only update once a day. Go to the Locations page and look for the Daily Section. You have the option to select Last Year Temps and/or Moon Phases. Next go to the Schedules page and make sure that you have the Daily Schedule activated.
        Thank you! I had the daily schedule setup to run everyday, I just missed the check mark next to the “Last Year Temperature” under the Daily Setup.


        Sent from my iPad using Tapatalk
        HS3 3.0.0.548 &HSTouch Designer 3.0.71 with 887 Devices, 515 Events
        Plugin's:
        BLBackup, BLOccupied, BLShutdown, EasyTrigger, Ecobee,
        EnvisaLink DSC, PHLocation, Pushover, SONOS, Blue Iris, UltraRachio3,
        weatherXML, Jon00 Alexa Helper, Network Monitor, MyQ, Z-Wave 3.0.1.252

        Comment


        • The idea with the checkboxes is it will allow me to add more items under the daily section and allow you to pick and choose which ones you want to use. It will also allow a way to get an any extra info needed to get that particular data. Ex. If you were using NOAA as the condtion and forecast provider but wanted to get the Last Year data as well, there would be an API, Lat and Lon textbox so you could enter the info for DarkSky.
          --
          Jeff Farmer
          HS 3, HSPhone
          My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
          Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

          Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

          Comment


          • Jeff,

            Im currently running .7

            I'm still getting these errors whenever I access the Current weather page (/weatherXML?page=1) set for NOAA
            Apr-18 10:33:33 AM weatherXML Error Requested value '
            DeviceNightIconNameVal0' was not found.

            Not seeing anything wrong with the page as far as I can tell.


            Click image for larger version

Name:	current.png
Views:	78
Size:	124.5 KB
ID:	1299705

            Also getting a different error every time the NOAA current forecast is run
            Apr-18 10:30:01 AM weatherXML Error convertTempValues: Conversion from string "" to type 'Double' is not valid.
            Looks like Barometer and Barometer Direction haven't update for a week and Visibility hasn't updated in several days and Wind Gust is a question mark.

            Click image for larger version

Name:	conditions current.png
Views:	73
Size:	388.7 KB
ID:	1299706

            Comment


            • Something that I did was to go through each of my weather devices and any that hadn't updated today I removed. I then went in to the device settings and toggled the check boxes for each of the devices. That cleared all of my errors (this was back a week or so ago when this fun all started.
              HomeSeer Version: HS3 Pro Edition
              Operating System: Microsoft Windows 10 Pro
              Processor Type and Speed: i7 - 3.26 GHz
              Total Physical Memory: 16Gig

              Plugins: BlBackup | EasyTrigger | FitbitSeer | HSTouchServer | Insteon | WeatherXML

              Comment


              • Originally posted by prsmith777 View Post
                Jeff,

                Im currently running .7

                I'm still getting these errors whenever I access the Current weather page (/weatherXML?page=1) set for NOAA
                Apr-18 10:33:33 AM weatherXML Error Requested value '
                DeviceNightIconNameVal0' was not found.

                Not seeing anything wrong with the page as far as I can tell.
                Mentioning that it is happening when you accessed the current weather page was the clue that I needed.

                Got it fixed and it will be available in the next release.

                --
                Jeff Farmer
                HS 3, HSPhone
                My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
                Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

                Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

                Comment


                • Originally posted by prsmith777 View Post
                  Jeff,


                  Click image for larger version  Name:	current.png Views:	1 Size:	124.5 KB ID:	1299705

                  Also getting a different error every time the NOAA current forecast is run
                  Apr-18 10:30:01 AM weatherXML Error convertTempValues: Conversion from string "" to type 'Double' is not valid.
                  Looks like Barometer and Barometer Direction haven't update for a week and Visibility hasn't updated in several days and Wind Gust is a question mark.

                  Click image for larger version  Name:	conditions current.png Views:	1 Size:	388.7 KB ID:	1299706

                  With error that are happening each time a schedule runs, I really need a logoutput to be able to see what it going on in the background.

                  --
                  Jeff Farmer
                  HS 3, HSPhone
                  My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
                  Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

                  Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

                  Comment


                  • Originally posted by CFGuy View Post


                    With error that are happening each time a schedule runs, I really need a logoutput to be able to see what it going on in the background.
                    Strange. I can't seem to reproduce this error now. When it pops up again, I will send a logoutput file.

                    Comment


                    • I do notice that the NOAA barometer and barometer devices are not changing or updating. They have been stuck at the same level for over a week.

                      I thought I'd try to delete the devices and recreate them. So I did that this morning and I'm not seeing them correlate with the NOAA station I am using. For instance the NOAA barometer reading is 30.22 yet my device is still saying 30 and has said 30 for over a week.

                      Comment


                      • Originally posted by CFGuy View Post


                        With error that are happening each time a schedule runs, I really need a logoutput to be able to see what it going on in the background.
                        I've seen this error come and go over the last few days. It seems to happen each run for 4 or 5 runs then stops for 12 hours or so. I pull DS current every 30 minutes. So my guess is something in the DS feed is missing or malformed. I'll try to capture a log and the DS feed if it happens again.
                        Last edited by drparker151; April 19th, 2019, 11:20 AM. Reason: changed NOAA to DarkSky
                        HS3 SEL running Pro Edition 3.0.0.531 on Ubuntu 18.04, mono 5.20, 656 devices, 209 events.
                        Plug-Ins: Chromecast, Device History, EasyTrigger, Ecobee, JowiHue, LutronCaseta, MeiUnifi, PHLocation2, Pushover 3P, SDJ-Health, Sonos, WeatherFlow, weatherXML
                        Scripts: SparkMan's Lock Event, 5 of Jon00 scripts.

                        Comment


                        • Why is it that even though I'm using Darksky, that the daily schedule is referring to Weather Underground? I'd like to get Max high/Min low temps for a given day.

                          Click image for larger version

Name:	darksky.jpg
Views:	82
Size:	58.9 KB
ID:	1300045
                          HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

                          Comment


                          • Originally posted by langenet View Post
                            Why is it that even though I'm using Darksky, that the daily schedule is referring to Weather Underground? I'd like to get Max high/Min low temps for a given day.

                            Click image for larger version

Name:	darksky.jpg
Views:	82
Size:	58.9 KB
ID:	1300045

                            The Daily Schedule only handles things that can be updated just once per day. New Moon, Full Moon, First Quarter, Last Quarter, The Today Last Year high and the Today Last Year Low. The message you are seeing about Weather Underground is for the Hourly Forecast. That has not been updated yet. If you are looking for the forecasted high and low temp values that would be in the forecast schedule. Go to the Devices page and select which of the forecast days you want the forecasted high and low values for.
                            --
                            Jeff Farmer
                            HS 3, HSPhone
                            My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
                            Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

                            Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

                            Comment


                            • Jeff,
                              I managed to catch the error this morning and a few others. Here is the log file.

                              logOutput.txt

                              Comment


                              • I can see where the error is happening but couldn't tell which of the temp values was causing it. I've added some more logging and will have you make another log file when I release .7 to the HS Updater.
                                --
                                Jeff Farmer
                                HS 3, HSPhone
                                My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
                                Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

                                Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

                                Comment

                                Working...
                                X