Announcement

Collapse
No announcement yet.

weatherXML changes for DarkSky

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • CFGuy
    replied
    I've been saving the last 100 condition download files. I need to go through them and see if the once an hour value adds up to the correct amount for a day.
    If not, I have found a source for the rain total. If we grab a history summary of the previous day right after midnight then I can save the amount to a device. I already have the code in place as I was doing this with the data from WU. 14 devices are created Day 1 through Day 7 where each device is the amount of rain on that day. And 7 are used for accumulated total of rain. Ex. Day 7 would be the sum of day 1 through day 7 total rain.

    Leave a comment:


  • fungun
    replied
    I was wondering, since the Dark Sky precip device only reports for a hour at a time. How could I set up a virtual device to get the rain total for the whole day?
    And then maybe a device for the last 5 or 7 days.

    Thanks,
    Tim

    Leave a comment:


  • donstephens
    replied
    Originally posted by CFGuy View Post

    In hindsight I should have waited instead of rushing a new release yesterday. I hurried to get it out before I had to leave for the day.
    After today, my schedule will be back to normal and I do a better job of testing.. I will have the htmlrenderer error fixed in the next release.
    Jeff, you do an amazing job. Appreciate all the work.

    Leave a comment:


  • CFGuy
    replied
    Originally posted by tenholde View Post
    New release did not fix the htmlrenderer errors
    In hindsight I should have waited instead of rushing a new release yesterday. I hurried to get it out before I had to leave for the day.
    After today, my schedule will be back to normal and I do a better job of testing.. I will have the htmlrenderer error fixed in the next release.

    Leave a comment:


  • tenholde
    replied
    New release did not fix the htmlrenderer errors

    Leave a comment:


  • fungun
    replied
    That's weird, because they all updated at 8:01 pm tonight.
    I will delete them anyway.

    Thanks,
    Tim

    Leave a comment:


  • codemonkey
    replied
    I had to manually move htmlrenderer as the new version of your installer did not fix it. I also deleted the unzipped installer as this was mentioned above.

    As of now I only have one remaining error:
    Apr-05 6:07:44 PM weatherXML Error downloadFile: Moon Phase Information from: https://api.usno.navy.mil/moon/phase...=4&ID=WEATHERX. Error: The underlying connection was closed: An unexpected error occurred on a send.
    I am getting moon phase data it would appear but this error still shows up.

    Thanks for working so hard on this for us.

    Regards,
    Tony

    Leave a comment:


  • codemonkey
    replied
    I found that over the years I've accumulated a LOT of unneeded devices. To clean this up I did the following.

    1. I ran the schedules for so that all valid devices were updated.
    2. I then went through my devices in "Device Management" and deleted any devices that did not have today's date.
    3. I then went to the legacy device section and unchecked everything but the marquee as I still use that.
    4. Once that was done I noticed that several weather groups had devices shown out of order or in the wrong group. To fix this I just went WeatherXML Settings / Devices and toggled the check box for each device that I wanted.

    The result is now I have a clean list of only the devices I need. Make sure to check your rules and edit any that were using devices that are now gone.

    The clean up was long over due so I'm happy it's done now.

    Leave a comment:


  • CFGuy
    replied
    Originally posted by fungun View Post
    Click image for larger version

Name:	send2JeffWXML2.jpg
Views:	21
Size:	70.6 KB
ID:	1297377 Thought I would try this.
    I took the "IN" out of the box next to Precipitation on the "Units" page.
    The "IN" next to the precip forecast like in the first image I sent are no longer there.
    Click image for larger version

Name:	send2JeffWXML.jpg
Views:	21
Size:	63.4 KB
ID:	1297378
    DarkSky does not provide a night time forecast. I suspect that these are leftover data from the previous provider. Delete the night forecast 6 and 7. Then go to the Devices page. You should not be able to add them back. Or you can ignore them until I get the hourly forecast added and add a way to pick which hour you want to use for the night forecast.

    Leave a comment:


  • fungun
    replied
    Click image for larger version

Name:	send2JeffWXML2.jpg
Views:	21
Size:	70.6 KB
ID:	1297377 Thought I would try this.
    I took the "IN" out of the box next to Precipitation on the "Units" page.
    The "IN" next to the precip forecast like in the first image I sent are no longer there.
    Click image for larger version

Name:	send2JeffWXML.jpg
Views:	21
Size:	63.4 KB
ID:	1297378

    Leave a comment:


  • fungun
    replied

    Originally posted by fungun View Post
    I didn't have anything in those boxes, so I changed it to %, but it still shows the same. I re-ran the Forecast schedule.
    It's like it is picking it up from the "Units" page of the settings.

    Thanks,
    Tim



    What data provider are you using?
    Dark Sky.

    Thanks,
    Tim

    Leave a comment:


  • CFGuy
    replied
    Originally posted by flatbush97 View Post
    Jeff,
    Thanks for updating the plugin. I was able to get this working on a Linux device using Raspbian Stretch. I see one message in the log at the moment,
    Apr-05 4:02:12 PM weatherXML Error Check if SQLite exists for location 1

    I do see date being stored in the onboard database.
    Anything to be concerned with?
    Thanks again
    Nothing to be concerned with. I should have set it as an info log entry and not an error. It is just a log entry right before the function runs that adds any new changes to the database.

    Leave a comment:


  • flatbush97
    replied
    Jeff,
    Thanks for updating the plugin. I was able to get this working on a Linux device using Raspbian Stretch. I see one message in the log at the moment,
    Apr-05 4:02:12 PM weatherXML Error Check if SQLite exists for location 1

    I do see date being stored in the onboard database.
    Anything to be concerned with?
    Thanks again

    Leave a comment:


  • MNB
    replied
    That was quick, many thanxs Tony

    Like the new wind direction icons, question is there a key for the Weather Images as their numeric, I thought that WeatherXML and Darksky need them to be uniquely named? Mike

    Leave a comment:


  • codemonkey
    replied
    Happy to share. Enjoy!
    Attached Files

    Leave a comment:

Working...
X