Announcement

Collapse
No announcement yet.

Weatherxml question on status display?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • CFGuy
    replied
    New version posted at the URL received in the email about DarkSky. Fixes several issues.

    Leave a comment:


  • Jon19
    replied
    Originally posted by CFGuy View Post
    I posted in the DarkSky thread that I put a new version out just about 10 minutes ago. Download from the email URL. The forecast should be honoring the unit selected on the weatherXML Units page.
    That worked like a charm! Thanks for all your work on this project!

    Leave a comment:


  • CFGuy
    replied
    I posted in the DarkSky thread that I put a new version out just about 10 minutes ago. Download from the email URL. The forecast should be honoring the unit selected on the weatherXML Units page.

    Leave a comment:


  • Jon19
    replied
    When I use the forecast feature, I am getting a decimal place of either 1 or 2 digits following. Is there a way to get rid of the decimal and just round up or down on the forecast temp?

    Leave a comment:


  • Jon19
    replied
    Originally posted by CFGuy View Post
    I suspect that you ran into is there are 2 places where you can create devices. I know the documentation needs updated. I am about halfway in updating documentation.
    The one labeled Legacy Devices is the older (HomeSeer 2) devices that used html to put a string of text into the DeviceString value.
    The html would make the nice looking display in a web browser but didn't work with HSTouch.
    The other page is the one labeled Devices, this is the HSTouch friendly devices. This is the one that I put an image of in the post above.
    The device in weather current is the Legacy one. The device in HSTouch current is the one for HSTouch.
    As you were trying, you must have clicked the temperature checkbox on both pages. That is why you have both devices.
    For the majority of users there is no need to use any of the Legacy devices.
    Great, I appreciate the information. This should help me with getting rid of unwanted devices and sticking with the HSTouch ones only. Thanks for the help!

    Leave a comment:


  • CFGuy
    replied
    I suspect that you ran into is there are 2 places where you can create devices. I know the documentation needs updated. I am about halfway in updating documentation.
    The one labeled Legacy Devices is the older (HomeSeer 2) devices that used html to put a string of text into the DeviceString value.
    The html would make the nice looking display in a web browser but didn't work with HSTouch.
    The other page is the one labeled Devices, this is the HSTouch friendly devices. This is the one that I put an image of in the post above.
    The device in weather current is the Legacy one. The device in HSTouch current is the one for HSTouch.
    As you were trying, you must have clicked the temperature checkbox on both pages. That is why you have both devices.
    For the majority of users there is no need to use any of the Legacy devices.

    Leave a comment:


  • Jon19
    replied
    Ok, so somehow, through trial and error, I figured it out. When I selected to create a new device such as temperature, it creates 2 devices, 1 in floor weather current and 1 in floor HSTouch current. If I select the HSTouch current one as my source for my HS Device, then select "Use Status Text", it provides the display exactly as I would like it to. Just wanted to pass this along in case anyone else needed this info. Thanks CFGuy for making this plugin work with DarkSky!

    Leave a comment:


  • Jon19
    replied
    So I have tried everything without success. I found in the help section, Device Values Setup, that after version 3.0.0.71, the prepend and append and "to add text to the new devices you can modify each device as wanted by setting the Status. Enter the text you want to use for Prefix, Suffix, and Decimal Places. See the Precipitation Totals Section below." I have tried everything and using the "use values" checkbox, I can't get any additional text/symbols to display. Thoughts?

    Leave a comment:


  • CFGuy
    replied
    The way the devices update is when the schedule runs. Go to the Schedules page and click the Run Now button for the Conditions Schedule. I would go ahead and copy the text from the feels like Append into the Temperature Append. That way they will match each other. For the future, I will modify this to update the device when you edit the append or prepend.

    Leave a comment:


  • Jon19
    replied
    Originally posted by CFGuy View Post
    By admin I just mean all of the pages where you set things.
    When you edit an append and prepend value the changes will not show until the next time the devices are updated.
    does a computer reboot update the devices? Or do I have to do something to update them? Also see the attached picture, I have data in the append section, not sure if its the right format or not.

    Click image for larger version

Name:	devices.jpg
Views:	17
Size:	80.5 KB
ID:	1291878

    Leave a comment:


  • CFGuy
    replied
    By admin I just mean all of the pages where you set things.
    When you edit an append and prepend value the changes will not show until the next time the devices are updated.

    Leave a comment:


  • Jon19
    replied
    Originally posted by CFGuy View Post
    Are you testing the beta version?
    If so Go to the weatherXML admin pages and click on Devices.

    If not, Go to the weatherXML admin pages and click on Advanced, then click on HSTouch\Data.

    Find the Device for Temperature and add a space and the letter F in the Append box. That will add an F on the end of the number for temperature. Use Device String.
    I am not seeing "admin" anywhere. Am I correct to go to the plugins dropdown menu, then selecting weatherxml, then selecting devices? I tried leaving a space then the letter F, then I also used the exact same info from the feels like append box, which is °#sp#F, and that didn't work either. For whatever reason I can't get it to replicate the same as the real feel box. Odd, am i missing a setting somewhere else?

    Leave a comment:


  • Jon19
    replied
    Originally posted by CFGuy View Post
    Are you testing the beta version?
    If so Go to the weatherXML admin pages and click on Devices.

    If not, Go to the weatherXML admin pages and click on Advanced, then click on HSTouch\Data.

    Find the Device for Temperature and add a space and the letter F in the Append box. That will add an F on the end of the number for temperature. Use Device String.
    I’m using Beta, thank you I will give this a try.

    Leave a comment:


  • CFGuy
    replied
    Are you testing the beta version?
    If so Go to the weatherXML admin pages and click on Devices.

    If not, Go to the weatherXML admin pages and click on Advanced, then click on HSTouch\Data.

    Find the Device for Temperature and add a space and the letter F in the Append box. That will add an F on the end of the number for temperature. Use Device String.

    Leave a comment:


  • Jon19
    started a topic Weatherxml question on status display?

    Weatherxml question on status display?

    Can someone help me figure this out. I use to be able to get both data reports to report with the degree symbol and F. Under the status/device category, I select the proper device that was created by weatherxml,.

    If I select Use value, I get just the temperature for my Current Temp with the number only, where the real feel shows the degree symbol and the F designator. I want the Current Temp to show just like the Real Feel.

    If I choose the use status text, I get the other photo with way more info than I want. Any suggestions?


    Attached Files
Working...
X