Announcement

Collapse
No announcement yet.

weather radar in HSTouch

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • weather radar in HSTouch

    Is it possible to get the weather radar working in HSTouch?

    When added i can see it in the designer, working. But when uploaded it's blank. Tried setting it as a video but that doesn't help either.

    EDIT:

    For some reason I'm not getting the status images or text to show in HSTouch app. But in designer I'm getting both images and text.
    Attached Files
    Last edited by U5tabil; July 12th, 2015, 11:05 AM.
    Certified installer for HomeSeer, Control4, KNX and Eaton/xComfort

  • #2
    Not sure why you are having these issues.
    I'm using both the status images, text and radar image in my HSTouch app (using Android)

    Are you seeing any errors in the log?

    Comment


    • #3
      Originally posted by Toby View Post
      Not sure why you are having these issues.
      I'm using both the status images, text and radar image in my HSTouch app (using Android)

      Are you seeing any errors in the log?
      I don't see any erros. But i have manage to get the pictures/info showing. A restart was all that was needed.

      But the radar i only get 1 picture. not a "gif" that is moving/updating.
      What seetings are you using in the designer to show this on your android hstouch app?
      Certified installer for HomeSeer, Control4, KNX and Eaton/xComfort

      Comment


      • #4
        I have to send the details when I'm back from vacation.

        Hs touch have issues with gif animation that needs a workaround : http://board.homeseer.com/showthread.php?t=156325

        Comment


        • #5
          Ok. I will wait don't worry Enjoy your holiday
          Certified installer for HomeSeer, Control4, KNX and Eaton/xComfort

          Comment


          • #6
            I tired adding the radar to HSTOuch. But all i get is a static picture. But in HStouch Designer the radar is live and full of actions. I tried setting the image to "IsVideo True". But that does not help at all. Is there any idea on how to get this working. Would be great to have a live and working radar image in the app
            Certified installer for HomeSeer, Control4, KNX and Eaton/xComfort

            Comment


            • #7
              Personally I use weatherunderground api and have it create url that I use in a text field. Only updates when called upon but that is fine for me.

              Comment


              • #8
                Oh and to add mine does have the motion also for the last 2 hrs roughly.

                Comment


                • #9
                  Yeah but i like this plugin. Mostly cause Yr.no is norwegian and works much better than any other for Norway.
                  Certified installer for HomeSeer, Control4, KNX and Eaton/xComfort

                  Comment


                  • #10
                    Here noticed with my Wintel HSTouch clients that I get no motion anymore on hi resolution GIF weather maps.

                    I do have a bugzilla ticket open on this issue. The motion is seen just fine using the browser on the touchscreen client.

                    This is one that I use.

                    http://weather.unisys.com/radar/wrad_us_loop.gif

                    The weatherXML downloads the image for display in the HSTouch client.
                    Last edited by Pete; August 27th, 2015, 07:10 PM.
                    - Pete

                    Auto mator
                    Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
                    Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
                    HS4 Pro - V4.0.5.0 - Ubuntu 18.04/W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.8X
                    HS4 Lite -

                    X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                    Comment


                    • #11
                      Originally posted by Pete View Post
                      The weatherXML downloads the image for display in the HSTouch client.
                      The YR weather plugin also downloads the images for dispalying in HSTouch. the issue was more on how to get it to work in HSTouch.

                      What I did earlier was to wrap the image url around some HTML code to get it to work like this:
                      Code:
                      <html lang="en"> <head><META HTTP-EQUIV=Refresh CONTENT=600></head> <body bgcolor="MidnightBlue" leftmargin="0" topmargin="0" marginwidth="0" marginheight="0"> <img src="http://192.168.1.xx:xxxx/NYRad.gif" height="100%" width="100%"></img> </body> </html>
                      Although this was a long time ago and I'm just about to try it again with the latest HSTouch release. (Sorry for the delay , but this case skipped my mind)

                      How do you show the animated GIF image from WeatherXML?


                      Originally posted by Pete View Post
                      Here noticed with my Wintel HSTouch clients that I get no motion anymore on hi resolution GIF weather maps.

                      I do have a bugzilla ticket open on this issue. The motion is seen just fine using the browser on the touchscreen client.
                      This might be the issue here as the radar is high resolution, but how high does it need to be to trigger this bug?

                      I will test during the weekend.

                      Comment


                      • #12
                        How do you show the animated GIF image from WeatherXML?
                        Here same as always. Using a direct link to the downloaded GIF from weatherXML. It still works on the non HD older style images whether they are downloaded from the HS3 box or direct from the internet.

                        This might be the issue here as the radar is high resolution, but how high does it need to be to trigger this bug?
                        I have no idea. I also think that the format of the GIF has changed a bit as I have had other issues with internet GIFs lately.

                        Personally here too have tested this on Windows 10 HSTouch clients and the issue remains. Don't use anything but windows clients here for HSTouch.

                        BTW WeatherXML is just about non functional these days in Linux - many pieces of it do not work anymore.

                        I opened a new bugzilla ticket as I couldn't find old one which I closed after a time.

                        Bugzilla ticket is: 2953 located here Bug 2953

                        Easy way to test is a direct link on a Wintel Homeseer 3 client to a GIF in the same directory that HS3 Wintel client runs in.

                        What I did earlier was to wrap the image url around some HTML code to get it to work like this
                        Will give this a try today. Not sure how you are inserting these lines on an HS3 client object? Are you statically writing this in the HTML directory then just reading it with Homeseer 3 client?

                        <html lang="en"> <head><META HTTP-EQUIV=Refresh CONTENT=600>
                        </head> <body bgcolor="MidnightBlue" leftmargin="0" topmargin="0" marginwidth="0" marginheight="0">
                        <img src="hxxp://192.168.1.xx:xxxx/NYRad.gif" height="100%" width="100%"></img> </body> </html>

                        OK I got it to work with the HD gif files. It would be nicer just to use the gif link which does work with low resolution pics.
                        Last edited by Pete; August 29th, 2015, 10:40 AM.
                        - Pete

                        Auto mator
                        Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
                        Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
                        HS4 Pro - V4.0.5.0 - Ubuntu 18.04/W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.8X
                        HS4 Lite -

                        X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                        Comment


                        • #13
                          U5tabil:
                          I could not figure out how to get around this bug so I will shortly release a new version of the plugin where you will find the latest radar animation image at this URL:

                          http://<serverIP>/images/YR/images/radaranimation_1.gif

                          Where the number 1 is the module number of the station.

                          this URL you can add to you HSTouch

                          Comment


                          • #14
                            Originally posted by Toby View Post
                            U5tabil:
                            I could not figure out how to get around this bug so I will shortly release a new version of the plugin where you will find the latest radar animation image at this URL:

                            http://<serverIP>/images/YR/images/radaranimation_1.gif

                            Where the number 1 is the module number of the station.

                            this URL you can add to you HSTouch
                            I tried this after updating the plugin. But I'm just getting a static image of the radar. Am i doing anything wrong?
                            Certified installer for HomeSeer, Control4, KNX and Eaton/xComfort

                            Comment


                            • #15
                              Originally posted by U5tabil View Post
                              I tried this after updating the plugin. But I'm just getting a static image of the radar. Am i doing anything wrong?
                              That's strange.
                              What have you done?

                              I just added the URL in the text area of a text box in HSTouch and that shows the animation on my android devices.

                              Comment

                              Working...
                              X