Announcement

Collapse
No announcement yet.

Error from YR plugin at startup

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error from YR plugin at startup

    For some reason each time i start HS i get this error:

    First at startup i get this:
    Starting up....

    09.11.2015 11:54:51 ~!~YR Weather Error~!~Exception in Find_Create_Devices/Find: The given key was not present in the dictionary.Startup Complete, 1 errors detected, check the log for more information.
    Then in log I see this:
    nov-09 12:00:44 YR Weather Error Exception in Find_Create_Devices/Find: The given key was not present in the dictionary.
    I then try to disable and then enable the plugin from management, and that gives me these errors in log:

    nov-09 12:03:47 Plug-In Finished initializing plug-in YR Weather
    nov-09 12:03:47 Error Initializing plug-in(2): YR Weather Instance::Object reference not set to an instance of an object.STACK: Server stack trace: Exception rethrown at [0]: at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessag e(IMessage reqMsg, IMessage retMsg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type) at HomeSeerAPI.IPlugInAPI.InitIO(String port) at Scheduler.clsHSPI.CheckInterfaces()
    nov-09 12:03:47 YR Weather Error Exception in Find_Create_Devices/Find: The given key was not present in the dictionary.
    nov-09 12:03:46 Warning Attempt by plugin to register a duplicate link of Weather Status. Plugin: YR Weather Instance:
    nov-09 12:03:46 Warning Attempt by plugin to register a duplicate link of Weather Config. Plugin: YR Weather Instance:
    nov-09 12:03:46 Info Plugin YR Weather has connected. IP:127.0.0.1:49669
    nov-09 12:03:44 Plug-In Finished initializing plug-in YR Weather
    nov-09 12:03:44 Error Initializing plug-in(2): YR Weather Instance::Object reference not set to an instance of an object.STACK: Server stack trace: Exception rethrown at [0]: at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessag e(IMessage reqMsg, IMessage retMsg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type) at HomeSeerAPI.IPlugInAPI.InitIO(String port) at Scheduler.clsHSPI.CheckInterfaces()
    nov-09 12:03:44 YR Weather Error Exception in Find_Create_Devices/Find: The given key was not present in the dictionary.
    What does this mean?
    Certified installer for HomeSeer, Control4, KNX and Eaton/xComfort

  • #2
    Sounds like there are some duplication somewhere.

    Are there any hidden or dead/old/duplicated devices?
    Duplicated processes running?

    Did you do something special prior to detecting this message?

    Comment


    • #3
      Originally posted by Toby View Post
      Sounds like there are some duplication somewhere.

      Are there any hidden or dead/old/duplicated devices?
      Duplicated processes running?

      Did you do something special prior to detecting this message?
      No all I have done is to update the system. I will have to look and see if there are some duplicates in there.
      Certified installer for HomeSeer, Control4, KNX and Eaton/xComfort

      Comment


      • #4
        I've checked but there is no duplications from what I see. How can i fix this? What files can i delete? Can i delte the plugin from plugin manager then reinstall it without loosing the settings?

        Im still getting this:
        nov-12 14:51:34 Error Initializing plug-in(2): YR Weather Instance::Object reference not set to an instance of an object.STACK: Server stack trace: Exception rethrown at [0]: at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessag e(IMessage reqMsg, IMessage retMsg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type) at HomeSeerAPI.IPlugInAPI.InitIO(String port) at Scheduler.clsHSPI.CheckInterfaces()
        nov-12 14:51:34 YR Weather Error Exception in Find_Create_Devices/Find: The given key was not present in the dictionary.
        Last edited by U5tabil; November 12th, 2015, 08:52 AM.
        Certified installer for HomeSeer, Control4, KNX and Eaton/xComfort

        Comment


        • #5
          Ok i tried removing the plugin from the list then adding it. Also tried taking away the settings then setting it up again. Now i do not get any errors when starting the plugin or HS. But I am not getting any information it seems. Can't remember if I am forgetting something here.
          Attached Files
          Certified installer for HomeSeer, Control4, KNX and Eaton/xComfort

          Comment


          • #6
            Did you delete the existing yr devices before re-adding the plugin?

            There's nothing more to it than starting the plugin, configure the location and start adding devices.

            Sent fra min E6653 via Tapatalk

            Comment


            • #7
              Originally posted by Toby View Post
              Did you delete the existing yr devices before re-adding the plugin?

              There's nothing more to it than starting the plugin, configure the location and start adding devices.

              Sent fra min E6653 via Tapatalk
              I got it working. A normal delete plugin and restore from plugin manager page was not enough. I had to delete all YR files i could find then install it again. Now it all works like it should.
              Certified installer for HomeSeer, Control4, KNX and Eaton/xComfort

              Comment


              • #8
                Good, glad to hear that you got it working again. :-)

                Comment

                Working...
                X