Announcement

Collapse
No announcement yet.

FAQ / Troubleshooting programming a channel

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • FAQ / Troubleshooting programming a channel

    Hi Toby,

    Just got the plugin working again so thanks for re-uploading.

    I've managed to migrate the settings over relatively easily, but for one of my curtains, the control isn't working any more. I've tried how I remember to program it (press the program button on the remove, wait / confirm that it jogs on the curtain, press the program button in the web page, confirm that it jogs) but this doesn't appear to be working.

    I migrated the channels over 1-1 and the rest worked, but this one didn't (channel 2)

    I also tried adding it on another channel (channel 9) which appeared to already have a programming on it/was not being used or configured in the plugin/was controlling an awning that was also on another channel, but whilst this added it fine and I could then control the unit, it added it to the control of the existing channel.

    I'm therefore thinking what when the plugin is programming the RS485, it is adding it to the existing channel, rather than clearing the existing channel and then adding it. Not sure if this process is possible, but this is definitely what i'd be wanting in this case at least, or alternatively the ability to clear a channel as needed prior to starting programming.

    I then tried to program it on a higher number channel (i.e. 11) but this appeared to have the same problem as channel 2.

    Grateful if you can please:
    - Advise correctly how to program / advise how i can troubleshoot this
    - Advise if there is a way to clear the channels
    - Consider providing a FAQ as a sticky with the instructions on how to use

    Thanks,

    Kieran

  • #2
    Hi,

    if you are re-using a already programmed HW unit, then there should be no need to reprogram as the programing is in the HW. So if you try to re-program an existing channel with the same hw/channel, then you are most likely deleting it as it's already programed.

    For the RTS motors, then up, down, fav and program buttons work as the buttons on the somfy remote -
    http://www.expertshutters.com/SomfyS...it-Setting.pdf

    Adding or deleting a Transmitter or a Channel
    Programmed Transmitter
    STEP 1: Using already programmed transmitters select the transmitter (single channel) or the channel, (1-5) of a multi-channel transmitter.
    STEP 2: Press and hold the programming button of that transmitter until the shade jogs.
    Transmitter to add or delete
    STEP 3: Select the transmitter (single channel) or the channel of a multi-channel transmitter, to be added or deleted.
    STEP 4: Press and hold the programming button of that transmitter until the shade jogs.

    Comment


    • #3
      Hi,

      Thanks for the info, but this doesn't appear to be working for me for adding the curtain on Channel 2 - to be clear on the exact steps i'm doing:
      - In the Plugin, I type in a new name in #2, select Curtain, then Create
      - I then on the (physical) remote control, select the correct channel, double check it by putting the curtains up/down
      - I then press the program button on the back until the curtain jogs (up/down)
      - I then press or press and hold the program button in the plugin (both have the same result) and wait for the curtain to jog - this does not occur
      - After a couple of minutes, the curtain jogs again to indicate that it is out of program mode

      I have tried troubleshooting as follows:
      - I've tried doing this in both IE and Chrome
      - I've tried holding, pressing once, pressing repeatedly the Program button for the channel
      - I've tried restarting / stopping the plugin

      Other points:
      - I dont think its a a range problem, as
      - The RS485 is controlling the awning on the other side of the window
      - I could add the curtain to the other channel (#11) noting the issue above, but couldn't add it to others
      - I've checked the HS logs, but there doesn't appear to be any debug info
      - I've found the MyS0mfy log file and i've attached that, but that doesn't show any debug level info/the requests to the curtains/awnings, and the entry appear to coincide with when i've been updating my events

      Grateful if you can please advise how we can troubleshoot further.

      Thanks,

      Kieran
      Attached Files
      Last edited by schnark; September 22nd, 2018, 06:50 PM.

      Comment


      • #4
        Just to make sure I understand your problem.
        - you are able to program every other channel, and you can program the curtain intended for channel 2 on another channel?

        I'm struggling to see how there can be a bug in the code just for channel 2 as the output from the code to separate the channel is basically the last digit representing the channel number (0-15).

        I have not looked at this code for some years now - but had a look today and did do som clean-up in the logging part.
        to do debug login you need to add the following in the ini file:
        Debug=True
        LogToFile=True
        LogToWeb=True

        and you need to create a folder called "Debug Logs" in the homeseer root folder (typically C:\Program Files (x86)\HomeSeer HS3\Config )

        in addition you need to load the latest file (attached) to the C:\Program Files (x86)\HomeSeer HS3 folder - replacing the one there.
        This should provide better logging.
        Attached Files

        Comment


        • #5
          Hey,

          So right now I have channels 0-8 used (excl 2) and 2, 10-15 does cannot be programmed and 9 only can be. Agree that it's weird!

          I've installed the update but can't find the ini file you mentioned - do I need to create it and if so where?

          Cheers,

          Kieran

          Comment


          • #6
            the ini file should be in the config folder

            Comment


            • #7
              It doesn't appear to be - should I create it?

              Comment


              • #8
                the file should be created automatically once you set the Node ID in the config page.
                If you create it manually it needs to have this name: MyS0mfy.ini and contain the following:

                [General]
                Debug=True
                HWDevice=RS485
                LogToFile=True
                LogToWeb=True
                NodeID=

                Comment


                • #9
                  Did you manage to get this working?

                  Comment

                  Working...
                  X