Announcement

Collapse
No announcement yet.

RFXLAN Problem?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • RFXLAN Problem?

    Afternoon Bert,
    I'm having a problem with my RFXLAN - when I connect to RFXMGR I don't get any received protocols at all and I can't select any of the protocols. Am I doing something wrong?

    Cheers
    Scott
    Attached Files

  • #2
    You have to use the RFreceiver and RFXmitter programs.
    RFXmngr is for the RFXtrx and RFXrec devices.

    Comment


    • #3
      Thank You Bert, I have found that now. Thank You

      Is there any plan for a replacement to the RFXLAN?

      Cheers
      Scott

      Comment


      • #4
        The easiest solution for a replacement is the RFXtrx433E connected to a small Linux system for example a Raspberry PI with ser2net installed.

        Attached the installation instructions for ser2net.
        Attached Files

        Comment


        • #5
          OK. Thank you again for the help Bert. Cheers, Scott

          Comment


          • #6
            Hi Bert,
            This is something I would be interested in,as I need to extend the range of my RFXtrx433E. Current it is upstairs plugged into my HS3 PC via USB. I have an unused PI3. Does this mean I could put the PI and RFXtrx433E downstairs and it could communicate back to HS3 PC wirelessly??
            Regs
            Liam
            Last edited by slayer; January 2nd, 2019, 02:12 PM. Reason: Spelling

            Comment


            • #7
              Hi,


              you can probably use ser2net but I have no knowledge of WiFi on the RPI. I guess you know how to configure WiFi.

              here the installation instructions for ser2net:

              Disable Serial Console (if configured)
              ======================
              sudo nano /etc/inittab
              insert a # sign in front of this line:
              T0:23:respawn:/sbin/getty -L ttyAMA0 115200 vt100
              ctrl-O
              Enter
              ctrl-x


              Remove console (if configured)
              ==============
              sudo nano /boot/cmdline.txt
              delete these 2 fields: console=ttyAMA0,115200 kgdboc=ttyAMA0,115200
              ctrl-O
              Enter
              ctrl-x



              Add ser2net
              ===========
              sudo apt-get install ser2net

              sudo nano /etc/ser2net.conf
              10001:raw:0:/dev/ttyUSB0:38400 8DATABITS NONE 1STOPBIT
              10002:raw:0:/dev/ttyUSB1:38400 8DATABITS NONE 1STOPBIT

              sudo /etc/init.d/ser2net restart


              Autostart ser2net
              =================
              sudo nano /etc/rc.local

              add the next line before exit o :
              /usr/local/sbin/ser2net -n


              Optionally add this line to connect an ACM device to an USB device (if USB not FTDI, for example Microchip MCP2200)
              ============================================================ =======================================================
              ln -sf /dev/ttyACM0 /dev/ttyUSB0

              BR Bert

              Comment


              • #8
                Bert,

                Thanks for the reply, still wondering how does the PI talk to the homeseer PC, is there a cable from the PC to the remote PI ?

                Regs

                Liam

                Comment


                • #9
                  ser2net operates on a LAN connection.
                  If you enable WiFi on the RPI it should be possible to use WiFi.

                  Comment

                  Working...
                  X