Announcement

Collapse
No announcement yet.

Using a LightwaveRF Mood controller JSJSLW101 to control devices in HS3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Using a LightwaveRF Mood controller JSJSLW101 to control devices in HS3

    I bought a 5 switch battery operated LightwaveRF switch to control devices in HS3. I cannot get my head around how to get it to work. I have a couple of LightwaveRF dimmers, and to pair them, I put them into pairing mode, then press a RFXtrx device (created via PI output devices) to pair.
    Now, this switch, I want it to send a command, to be received by a Rfxtrx device which I can then use to trigger events. I thought it was easy... I set up 5 Rfxtrx output devices all with different codes, which I now want to pair with my switch. Then that switch should be paired to that code. But how do I set a code to the switch without pairing it to something ? I am also not sure if I can do what I wanted to do with the switch, which is to control 5 different devices. It has a on, a off, and 3 mood switches. Could I pair the mood switches to a device in HS3 ?

    This is part of the manual

    OPERATION
    Basic Operation
    ‘ON’ Button: Press once to switch paired devices ‘ON’.
    Press and hold the button to raise the dim level of any
    paired dimmable receivers.
    ‘OFF’ Button: Press once to switch paired devices ‘OFF’.
    Press and hold the button to lower the dim level of
    any paired dimmable receivers.
    ‘ALL OFF’ Button: Press once to switch off all
    paired receivers at the same time.
    ‘MOOD 1, 2, 3’ Button: Press any one of the mood
    buttons to recall that particular stored mood (see
    ‘setting up a mood’).
    Setting Slider Switch (rear of device)
    WHEN SLIDE SWITCH IS AT ‘0/1’
    When this setting is selected the main ‘ON’ and ‘OFF’
    buttons when pressed will turn on and o all devices
    with which they are paired.
    WHEN SLIDE SWITCH IS AT ‘M’
    When this setting is selected, the main ‘ON’ and ‘OFF’
    buttons, when pressed, instead of switching every
    paired device on or o, activate two main user dened
    moods called and ‘ENTRY’ & ‘EXIT‘ moods. These are
    designed to act as the main favorite settings for paired
    devices when the room is entered or vacated.

    Setting up a Mood
    1. Firstly set the desired status of each paired receiver
    (i.e. on or o ) or the desired dim level of any
    dimmable receivers to be included in the mood.
    2. Select which mood button (1,2, or 3) is to be used to
    save and recall the new mood. The ‘ON’ & ‘OFF’ buttons
    can also be used to save a mood if the slider switch is
    set to ‘M’.
    3. Hold down the desired mood button until the LED
    starts to ash.
    4. The LEDs on the receivers that are included in the
    new mood should ash to indicate that they are now
    recognised as a part of that mood.
    To recall a mood:
    Press the desired ‘Mood’ button (1,2 or 3) to recall the
    corresponding mood. If the slider switch is set to ‘M’
    this includes the main ‘ENTRY’ and ‘EXIT’ moods
    activated using the main ‘ON’ and ‘OFF’ switches once
    they are set up.

  • #2
    Enable the LightwaveRF protocol in the RFXtrx.
    Push a button on the LWRF switch.
    Add the device on the RFXCOM Input devices page.

    Comment


    • #3
      I have the LightwaveRf protocol enabled on both my Rfxtrx, the switch is close and I pressed all buttons, no new input device is showing up

      Comment


      • #4
        Which RFXtrx do you use? RFXtrx433, RFXtrx433E or RFXtrx433XL?
        Which firmware is used?

        Connect the RFXtrx to a Windows system and check with RFXmngr if the LWRF switch is received.

        Comment


        • #5
          I have 2 Rfxtrx 433E with pretty new firmware (I updated 3 or 4 weeks ago). I am not at home at the moment so cannot check exactly which firmware. I used my wife as a remote control to press the buttons on the switch... I have a few LightwaveRF dimmers which I control with them, and they have worked and still work for a long time

          Will check on a PC tonight

          Comment


          • #6
            Something is very wrong here... I started Rfxmngr 19.0.0.16, and after connecting to my Rfxtrx everything was greyed out. I could not change anything. enable/disable protocols, set mode etc. It did say upgrade firmware. So I did. to Pro 1 v 1041. And I updated Rfxmngr to 19.0.0.23 (I reinstalled a few times but same result)
            But there is no text next to the tickboxes for the protocols now ?

            Attached Files

            Comment


            • #7
              Ok that issue is resolved. I unplugged the power to the Rfxtrx and restarted it.

              But the Switch is not showing up in the input devices. Pressing the buttons repeatedly, nothing shows up. But on Rfxmngr I can see them:

              30/10/2019 08:05:36:845= 0A14000CF2FA3601010070
              Packettype = Lighting5
              subtype = LightwaveRF
              Sequence nbr = 12
              ID = F2FA36 decimal:15923766
              Unit = 1
              Command = On
              Signal level = 7 -64dBm


              30/10/2019 08:07:32:219= 0A14002EF2FA3610030070
              Packettype = Lighting5
              subtype = LightwaveRF
              Sequence nbr = 46
              ID = F2FA36 decimal:15923766
              Unit = 16
              Command = Group Mood 1
              Signal level = 7 -64dBm

              30/10/2019 08:07:45:015= 0A14002FF2FA3610020070
              Packettype = Lighting5
              subtype = LightwaveRF
              Sequence nbr = 47
              ID = F2FA36 decimal:15923766
              Unit = 16
              Command = Group Off
              Signal level = 7 -64dBm
              Attached Files

              Comment


              • #8
                I have unticked all protocols except Owl and Lightwave. Now it has picked up the device. Which protocol interferes with the Lightwave reception ?

                It seems the Opus protocol might have interfered. It all seems to be working fine now.

                Comment

                Working...
                X