Announcement

Collapse
No announcement yet.

RGB LED's

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • RGB LED's

    Trying to control the RGB led controller (white one) from dx. How do you determine what the address is so you can input it into the plugin output config?
    HS3 Prod - Win10 - DSC - HVAC-GC-TBZ48 x3 - CurrentCost - BLRadar - RFXCOM/FRXTRX433 -ADIO - HSTOUCH - BLUPS - AB8SS - SONOS - Alexa - 1 wire - BlueIris -MyQ

  • #2
    I used rfxmngr to look at the traffic from the remote. It shows the address.

    Cheers
    Al

    Sent from my SGH-I547C using Tapatalk
    HS 3.0.0.531: 1985 Devices 1128 Events
    Z-Wave 3.0.1.260: 122 Nodes on one Z-Net

    Comment


    • #3
      RGB LED's

      Got it thanks. Had to upgrade the firmware as well.
      HS3 Prod - Win10 - DSC - HVAC-GC-TBZ48 x3 - CurrentCost - BLRadar - RFXCOM/FRXTRX433 -ADIO - HSTOUCH - BLUPS - AB8SS - SONOS - Alexa - 1 wire - BlueIris -MyQ

      Comment


      • #4
        see also the RFXCOM HS3 User Guide chapter 8.40
        This pdf is in the HS3 Docs directory

        Comment


        • #5
          I get this in RFXmngr:
          080301371C04808010
          Packettype = UNDECODED RF Message
          UNDECODED ARC:1C04808010

          ...so the code would be...? Sorry...:-)

          Comment


          • #6
            Originally posted by mk1 black limited View Post
            I get this in RFXmngr:
            080301371C04808010
            Packettype = UNDECODED RF Message
            UNDECODED ARC:1C04808010
            ...so the code would be...? Sorry...:-)
            You need to flash the RFXtrx with version 71 of the RFXtrx433 Type2 Firmware (http://www.rfxcom.com/Downloads).

            Cheers
            Al
            HS 3.0.0.531: 1985 Devices 1128 Events
            Z-Wave 3.0.1.260: 122 Nodes on one Z-Net

            Comment


            • #7
              Yes, I've done that.

              Just to be safe I've tried both Type 1 and 2. Doesn't seem to help much...

              Comment


              • #8
                I'm assuming you've already done this, but just in case, did you turn on the AD/LightwaveRF protocol? If you have, maybe attach a screen shot of RFXmngr after you click the Get Status button.

                Cheers
                Al
                HS 3.0.0.531: 1985 Devices 1128 Events
                Z-Wave 3.0.1.260: 122 Nodes on one Z-Net

                Comment


                • #9
                  Yep, done that. I get this with the Type 2 firmware:

                  Set Mode:0D 00 00 02 03 53 00 00 02 00 00 00 00 00
                  ------------------------------------------------
                  0D0100020353AB00020001010000
                  Packettype = Interface Message
                  subtype = Interface Response
                  Sequence nbr = 2
                  response on cmnd = Set Mode
                  Transceiver type = 433.92MHz
                  Firmware version = 171
                  Hardware version = 1.1
                  Undec off
                  X10 disabled
                  ARC disabled
                  AC disabled
                  HomeEasy EU disabled
                  Meiantech disabled
                  Oregon Scientific disabled
                  ATI disabled
                  Visonic disabled
                  Mertik disabled
                  AD enabled
                  Hideki disabled
                  La Crosse disabled
                  FS20 disabled
                  ProGuard disabled
                  BlindsT0 disabled
                  BlindsT1 disabled
                  AE disabled
                  RUBiCSON disabled
                  FineOffset disabled
                  RFU protocol 3 disabled
                  RFU protocol 4 disabled
                  RFU protocol 5 disabled
                  RFU protocol 6 disabled
                  ------------------------------------------------
                  0A140602FCCFE300010061
                  Packettype = Lighting5
                  ERROR: Unknown Sub type for Packet type=14: 6
                  Signal level = 6
                  ------------------------------------------------
                  0A140603FCCFE300010061
                  Packettype = Lighting5
                  ERROR: Unknown Sub type for Packet type=14: 6
                  Signal level = 6
                  ------------------------------------------------
                  0A140604FCCFE300010061
                  Packettype = Lighting5
                  ERROR: Unknown Sub type for Packet type=14: 6
                  Signal level = 6

                  Comment


                  • #10
                    OK, got it: The code is FCCFE3, now controllable in HS3. Thanks!

                    Comment


                    • #11
                      I'm at a loss. Your settings look just like mine. Which RGB controller do you have?

                      This is what I get for each packet:
                      PHP Code:
                      ------------------------------------------------
                      0A140600FCC51000010061
                      Packettype    
                      Lighting5
                      subtype       
                      RGB TRC02
                      Sequence nbr  
                      0
                      ID            
                      FCC510
                      Command       
                      On
                      Signal level  

                      Based on that, your ID will be FCCFE3, but the transceiver doesn't look like it's decoding your packets properly. Try it with that ID, but if it doesn't work, Bert will have to jump in.

                      Cheers
                      Al
                      HS 3.0.0.531: 1985 Devices 1128 Events
                      Z-Wave 3.0.1.260: 122 Nodes on one Z-Net

                      Comment


                      • #12
                        Looks like I just cross-posted. Glad you got it working.

                        Cheers
                        Al
                        HS 3.0.0.531: 1985 Devices 1128 Events
                        Z-Wave 3.0.1.260: 122 Nodes on one Z-Net

                        Comment


                        • #13
                          Yes, but as you say, it looks like my transceiver doesn't decode the packet right. Bert?

                          Comment


                          • #14
                            Add a dx.com RGB LED strip driver

                            - Flash the RFXtrx433 with Type2 firmware to be able to receive the remote ID in RFXmngr.
                            - In RFXmngr enable only the AD protocol and press a button on the remote.
                            - If necessary flash the RFXtrx433 back to Type1 if Type2 does not support devices you need. (See chapter 2.2 in the RFXtrx User Guide.pdf)
                            - Go to the PLUG-INS - RFXCOM - Output Devices configuration page
                            - Add the RGB LED output device with the ID found in RFXmngr

                            Comment


                            • #15
                              Hi Bert, something broke my color device for my dx.com LED controller after the upgrade to .38. The control device seems to be fine, but the color device now has an RFXCom tab that is not filled out. Looking at the manual it indicates that color device should not have an RFXCom tab. Thoughts on how to resolve?

                              Thanks
                              Al

                              EDIT: I recreated the output devices and deleted the old devices and all is well. Not sure how it got messed up in the upgrade, so you may want to check the code associated with that.

                              Click image for larger version  Name:	Capture2.PNG Views:	1 Size:	10.3 KB ID:	1294512

                              Click image for larger version  Name:	Capture.PNG Views:	1 Size:	14.1 KB ID:	1294511
                              HS 3.0.0.531: 1985 Devices 1128 Events
                              Z-Wave 3.0.1.260: 122 Nodes on one Z-Net

                              Comment

                              Working...
                              X