HomeSeer Message Board

HomeSeer Message Board (http://board.homeseer.com/index.php)
-   HomeSeer DSC Plug-in (http://board.homeseer.com/forumdisplay.php?f=834)
-   -   DSC plugin release version 2.0.0.14 (http://board.homeseer.com/showthread.php?t=148252)

rjh April 1st, 2011 03:21 PM

DSC plugin release version 2.0.0.14
 
Release 2.0.0.14 is available through the HomeSeer Updater.

ccat April 1st, 2011 07:05 PM

I get the following error message using both .14 and .13 when I try to disarm my panel from an event.

4/1/2011 5:39:03 PM Event Event Trigger "DisArm Partition"
4/1/2011 5:39:03 PM DSC DEBUG Sending command to panel...
4/1/2011 5:39:03 PM DSC DEBUG Send Data: 040XXXX00BF <-XXXX is the correct Mstr Code
4/1/2011 5:39:03 PM DSC DEBUG Processing command: Command_Acknowlege->50004029
4/1/2011 5:39:03 PM DSC DEBUG Command Acknowledge: Last Command Received: 040
4/1/2011 5:39:04 PM DSC DEBUG Processing command: Invalid_Access_Code->6701CE
4/1/2011 5:39:04 PM DSC Security Invalid Access Code1


pwr 864 panel and PC5401 interface card.

Disarming from an event worked in the past with plugin version: 1.1.2911.21807

rjh April 1st, 2011 09:01 PM

Can you disarm from the status page? From the status page it will get the code from the users code screen in the DSC setup. Make sure there is a code set for the web user that is logging into HomeSeer.

ccat April 2nd, 2011 12:30 AM

1 Attachment(s)
No, I get the following error message in my log file...


4/1/2011 11:16:41 PM DSC Security Partition 1 disarmed from website by user cXXX
4/1/2011 11:16:41 PM DSC DEBUG Sending command to panel...
4/1/2011 11:16:41 PM DSC DEBUG Send Data: 0401C5
4/1/2011 11:16:41 PM DSC DEBUG Processing command: System_Error->5020252E
4/1/2011 11:16:41 PM DSC Security System Error, Code: 25

Thanks

rjh April 2nd, 2011 10:08 AM

Are you using the it100 interface?

Dafunktyfunk April 2nd, 2011 10:12 AM

Quote:

Originally Posted by rjh (Post 967750)
Are you using the it100 interface?

Rich,

Looks like he is using,"pwr 864 panel and PC5401 interface card."

Dafunktyfunk April 2nd, 2011 10:14 AM

Quote:

Originally Posted by ccat (Post 967696)
I get the following error message using both .14 and .13 when I try to disarm my panel from an event.

4/1/2011 5:39:03 PM Event Event Trigger "DisArm Partition"
4/1/2011 5:39:03 PM DSC DEBUG Sending command to panel...
4/1/2011 5:39:03 PM DSC DEBUG Send Data: 040XXXX00BF <-XXXX is the correct Mstr Code
4/1/2011 5:39:03 PM DSC DEBUG Processing command: Command_Acknowlege->50004029
4/1/2011 5:39:03 PM DSC DEBUG Command Acknowledge: Last Command Received: 040
4/1/2011 5:39:04 PM DSC DEBUG Processing command: Invalid_Access_Code->6701CE
4/1/2011 5:39:04 PM DSC Security Invalid Access Code1


pwr 864 panel and PC5401 interface card.

Disarming from an event worked in the past with plugin version: 1.1.2911.21807

Correct, this new version is optimized for the IT-100 board. I would suggest you stay on the older version of plug or update to the new IT-100. They are not very expensive.

There are MANY changes in the way DSC coded the IT-100 from the PC5401. It also has MANY improvements too.

ccat April 4th, 2011 09:37 AM

Rich,

Please let me know what you plan on doing. Staying with the older plug-in is not an option for me because of the problems it has with indicating a single correct status for a zone and the values that are now associated with the different zone statuses. This new plug-in is really nice! If you plan on making this work with the PC5401, then I'll stick with that, if not then I guess I'll buy the IT100.

Thanks

Mogulbasher April 4th, 2011 08:24 PM

Is it possible to use home seer with the IT 120 web services device

Rupp April 4th, 2011 08:26 PM

Quote:

Originally Posted by Mogulbasher (Post 968099)
Is it possible to use home seer with the IT 120 web services device

What is this device?

Mogulbasher April 4th, 2011 09:57 PM

It is an add on that connects the dsc panel to your network via Ethernet allowing control of the panel via tcp

Rupp April 4th, 2011 10:10 PM

No the latest plugin only works with the IT-100 interface.

rjh April 5th, 2011 08:38 AM

There are no plans to do further work on this plugin at this time, we are on other projects right now. I would just get an IT100 interface, I think they are around $50. It works much better anyway.

hart2hart April 9th, 2011 12:40 PM

Events do not execute
 
I installed above .14 version and made no other changes. Simple events that should be triggered such as Arm Away event that I've had for years are NOT triggered after the install. I am and have always used the It-100 interface on an 1864 panel/

Dafunktyfunk April 11th, 2011 10:26 PM

Correct. That is because the new plugin makes all new devices. You will need to update your events.

You can also use the device update feature in the Tools section. This will allow you to make global device replacements.

hart2hart April 11th, 2011 10:35 PM

Okay, I'll evaluate if it is worth the extra effort? Why were new devices created -- I only saw the same ones that had existed for a few years? Also, Did I miss this change being listed?

Dafunktyfunk April 11th, 2011 10:37 PM

Quote:

Originally Posted by hart2hart (Post 968992)
Okay, I'll evaluate if it is worth the extra effort? Why were new devices created? Did I miss this major change being listed?

It is definitely worth the effort!!!!

They added new devices so you can do a better job setting events based on status. It also allows you to get very creative with the user names and email and announcements. When you install the new plug, read the updates Help Guide.

I worked with Rich closely on this one to get this perfect and very flexible.

rragan June 8th, 2011 11:47 PM

I keep getting this:

6/8/2011 10:43:47 PM DSC Security Could Not match Command: 1

Any pointers? I've rebooted HS box and power cycled the alarm panel. It was working fine before.

Rupp June 9th, 2011 09:22 AM

Quote:

Originally Posted by rragan (Post 974720)
I keep getting this:

6/8/2011 10:43:47 PM DSC Security Could Not match Command: 1

Any pointers? I've rebooted HS box and power cycled the alarm panel. It was working fine before.

These "types" of messages are almost always caused by invalid communications with the panel. Are you connected to an onboard serial port or are you using a USB2Serial adapter?

rragan June 9th, 2011 10:56 AM

I believe it is a communications issue. I'm trying to figure out what is going on. I'm using a regular serial port which I've verified is working with a loopback plug. For some reason the IT-100 or the panel isn't talking.


All times are GMT -4. The time now is 12:30 AM.


Copyright HomeSeer Technologies, LLC