View Single Post
Old November 8th, 2017, 10:51 PM
randycboone randycboone is offline
Seer Deluxe
Join Date: Jan 2009
Location: NL, Canada
Posts: 199
Originally Posted by rileydogmi View Post
I am now on day three trying to troubleshoot this issue to I am hoping the wizards here can help.

Speaker client, running local, works a few times after restart then stops responding. The speaker isn't locked-up or anything, I can interact with the speaker client and click on the sample voice and it is working great. It just stops taking announcements from HS.

Environment - running latest HS (just tried with latest beta, .382) - speaker client is local, Windows 10 with all updates installed, windows firewall off

What I have done - speaker has been working great since I built this machine a few years ago - once I updated to .368 a few weeks ago, speaker no longer worked. This weekend I had time to troubleshoot - speaker shows connected, all green status lights. HS server shows connected to the speaker in the HS logs. After restart of HS I can issue a few commands to speak, they show in the speaker log (with the bubble popping up indicating speaking) and the HS log, all is well. After a few minutes, the speaker no longer responds to commands but there are no errors in the logs, no errors in the speaker logs. Restarting the speaker app does nothing - I have to reboot the whole system in order to get a few speech commands to work. The speaker client is "default" and is logged-in using an admin user account. I even tried not logging into HS local and used the IP address. Same result.

I tried checking the firewall - it is off, but I went ahead and added the speaker client to the list of OK apps to allow. I also just checked the security of the folders to make sure all the directories have no security issues. I am not running any anti-virus on the server.

To make it simple, I am just issuing a simple speak command from a manual event - the event shows in the log as it executing but that speech doesn't make it to the speaker client.

I am really stumped on this - would appreciate anyone who can point me in other areas I can try.

I had a similar problem recently which I think I have resolved. The local speaker would stop working if I used Windows Remote Desktop to connect to it, even after disconnecting. The only resolve was to reboot the HS3 machine. I've since switched to using VNC instead of RDP and the problem seems to have gone.
Reply With Quote