View Single Post
  #32  
Old May 9th, 2016, 10:37 PM
Daweeze's Avatar
Daweeze Daweeze is offline
Seer Deluxe
 
Join Date: Dec 2009
Location: North Bay
Posts: 488
Quote:
Originally Posted by spud View Post
Yes this version is supposed to fix the issue were the High channel device was updated incorrectly when you press physically the switch:

You should see some debug log messages like this one:
"Ignoring device state report for fan controller"
I am now seeing these messages with version 3.0.0.34.

Quote:
Originally Posted by spud View Post
Could you try to delete your channel devices and then reimport or restart the plug-in. Thanks.

could you try again with version 3.0.0.34
I did this just as you asked.

Quote:
Originally Posted by spud View Post
I tried importing your upe file with version .33, and got the following error:
ERROR UPStart_IMPORT:: Unable to create tailored device instance -- No parameterless constructor defined for this object.

It is now fixed in .34, but what is weird is that this error is not in your logs. Have you ever seen it?
I don't believe that I have. For reference, I am using UpStart 8.0 Build 47 for my most recent Export files.


Quote:
Originally Posted by spud View Post
When you install make sure both HSPI_UPBSpud.exe and bin/UPBSpud/UPB4CSharp.dll are updated and that you don't have any other UPB4CSharp.dll in the HS3 folder.

thanks
Both files updated. There was not an occurance of UPB4CSharp.dll in the HS3 Folder.

Neither activating the Links or using the Controller changes the Ceiling Fan LED Indicators in HS3 anymore. I can see the commands in the Log that look like they should be changing them but the status is now "Off" all of the time.

I did notice that I am no longer seeing this message that I am used to seeing after a level change in the log:

"DEBUG FAN_CONTROLLER_DEVICE[135]:: Confirmed request to set device to level succeedded -- updating internal state".

Maybe you accidentally filtered the state change that was needed?

Here's the test logs with this version:

(1) Starting with the controller being on High speed, press the off button on the physical switch



May-09 7:09:31 PM UPBSpud DEBUG UPB_RCVR:: Message already received and treated -- message ignored
May-09 7:09:31 PM UPBSpud DEBUG UPB_RCVR:: Received UPB command [PU08050200878608DC]
May-09 7:09:31 PM UPBSpud DEBUG FAN_CONTROLLER_DEVICE[135]:: Ignoring device state report for fan controller
May-09 7:09:31 PM UPBSpud DEBUG UPB_RCVR:: Received UPB command [PU08040200878608DD]
May-09 7:09:31 PM UPBSpud DEBUG UPB_RCVR:: Message already received and treated -- message ignored
May-09 7:09:31 PM UPBSpud DEBUG UPB_RCVR:: Received UPB command [PU890502048720FFFFC7]
May-09 7:09:30 PM UPBSpud DEBUG FAN_CONTROLLER_DEVICE[135]:: Level changing on channel 0 from 100 to 0
May-09 7:09:30 PM UPBSpud DEBUG Device 135 transmitted link 4 with action Activate => Firing event 9686
May-09 7:09:29 PM UPBSpud DEBUG LINK[4]:: Got Link ACTIVATE
May-09 7:09:29 PM UPBSpud DEBUG UPB_RCVR:: Received UPB command [PU890402048720FFFFC8]



(2) Starting with the controller being off, press the High button on the physical switch



May-09 7:10:07 PM UPBSpud DEBUG UPB_RCVR:: Message already received and treated -- message ignored
May-09 7:10:07 PM UPBSpud DEBUG UPB_RCVR:: Received UPB command [PU08050200878601E3]
May-09 7:10:07 PM UPBSpud DEBUG FAN_CONTROLLER_DEVICE[135]:: Ignoring device state report for fan controller
May-09 7:10:07 PM UPBSpud DEBUG UPB_RCVR:: Received UPB command [PU08040200878601E4]
May-09 7:10:07 PM UPBSpud DEBUG UPB_RCVR:: Message already received and treated -- message ignored
May-09 7:10:07 PM UPBSpud DEBUG UPB_RCVR:: Received UPB command [PU890502018720FFFFCA]
May-09 7:10:06 PM UPBSpud DEBUG FAN_CONTROLLER_DEVICE[135]:: Level changing on channel 0 from 0 to 100
May-09 7:10:06 PM UPBSpud DEBUG Device 135 transmitted link 1 with action Activate => Firing event 9335
May-09 7:10:06 PM UPBSpud DEBUG Device 135 transmitted link 1 with action Activate => Firing event 8232
May-09 7:10:05 PM UPBSpud DEBUG LINK[1]:: Got Link ACTIVATE
May-09 7:10:05 PM UPBSpud DEBUG UPB_RCVR:: Received UPB command [PU890402018720FFFFCB]



(3) Starting with the controller being on High speed, press the Low button on the physical switch



May-09 7:10:41 PM UPBSpud DEBUG UPB_RCVR:: Message already received and treated -- message ignored
May-09 7:10:41 PM UPBSpud DEBUG UPB_RCVR:: Received UPB command [PU08050200878604E0]
May-09 7:10:41 PM UPBSpud DEBUG FAN_CONTROLLER_DEVICE[135]:: Ignoring device state report for fan controller
May-09 7:10:41 PM UPBSpud DEBUG UPB_RCVR:: Received UPB command [PU08040200878604E1]
May-09 7:10:41 PM UPBSpud DEBUG UPB_RCVR:: Message already received and treated -- message ignored
May-09 7:10:41 PM UPBSpud DEBUG UPB_RCVR:: Received UPB command [PU890502038720FFFFC8]
May-09 7:10:40 PM UPBSpud DEBUG FAN_CONTROLLER_DEVICE[135]:: Level changing on channel 0 from 100 to 0
May-09 7:10:40 PM UPBSpud DEBUG Device 135 transmitted link 3 with action Activate => Firing event 2737
May-09 7:10:40 PM UPBSpud DEBUG LINK[3]:: Got Link ACTIVATE
May-09 7:10:40 PM UPBSpud DEBUG UPB_RCVR:: Received UPB command [PU890402038720FFFFC9]

Thanks,

-Travis
Reply With Quote