www.homeseer.com    
 

Go Back   HomeSeer Message Board > Security Systems Plug-ins > Security System Discussion > HAI/OMNI Panel for HS3 Plug-in (rmasonjr)

HAI/OMNI Panel for HS3 Plug-in (rmasonjr) Discussion about Rob Mason's HAI/OMNI Panel Plug-in

Closed Thread
 
Thread Tools Display Modes
  #1  
Old September 11th, 2017, 12:09 PM
rmasonjr's Avatar
rmasonjr rmasonjr is offline
OverSeer
 
Join Date: May 2001
Location: Brookhaven, MS USA
Posts: 6,160
OMNI Plugin v3.0.2.3

v3.0.2.3 was released to the updater today. It might take a day or so before it shows up in the list.

Changes in this version:
  • Fixed - Omni buttons not showing as available in Alexa after restart (@AndrewR)
  • Fixed - Button changes to Status Graphics are not being 'saved' on a restart (Scott,@AndrewR)

Always make a backup of your system before loading a new version.

Post any issues you have with this version in this thread.
__________________

HS3Pro Running on a Raspberry Pi2 (Raspbian)
61 Z-Wave Nodes, 162 Events, 293 Devices
UPB modules via OMNI plugin/panel
Plugins: Z-Wave, BLRF, HAI, HSTouch, weatherXML, EasyTrigger
HSTouch Clients: 3 Android, 1 Joggler
  #2  
Old September 11th, 2017, 12:09 PM
rmasonjr's Avatar
rmasonjr rmasonjr is offline
OverSeer
 
Join Date: May 2001
Location: Brookhaven, MS USA
Posts: 6,160
The plugin is now available in the updater...

Last edited by rmasonjr; September 12th, 2017 at 04:31 PM.
  #3  
Old September 11th, 2017, 12:09 PM
rmasonjr's Avatar
rmasonjr rmasonjr is offline
OverSeer
 
Join Date: May 2001
Location: Brookhaven, MS USA
Posts: 6,160
This version was an emergency fix for buttons. No other changes were made.
  #4  
Old September 12th, 2017, 06:17 PM
Pete's Avatar
Pete Pete is offline
OverSeer
 
Join Date: Jan 2001
Location: House
Posts: 14,123
Thank you Rob.

Updated today to Omni Plugin 3.0.2.3.

Installation logs look fine. Same one entry in logs.

Sep-12 5:15:52 PM Info Plugin OMNI has connected. IP:127.0.0.1:37948
Sep-12 5:15:52 PM Warning Attempt by plugin to register a duplicate link of Logs. Plugin: OMNI Instance:
Sep-12 5:15:55 PM Plug-In Finished initializing plug-in OMNI
__________________
- Pete

Automator

HS3 Pro & Lite
Edition Beta 3.0.0.383 | Ubuntu 16.04 64 bit | Oracle Windows Virtual Box

  #5  
Old September 13th, 2017, 09:14 AM
rmasonjr's Avatar
rmasonjr rmasonjr is offline
OverSeer
 
Join Date: May 2001
Location: Brookhaven, MS USA
Posts: 6,160
Quote:
Originally Posted by Pete View Post
Thank you Rob.

Updated today to Omni Plugin 3.0.2.3.

Installation logs look fine. Same one entry in logs.

Sep-12 5:15:52 PM Info Plugin OMNI has connected. IP:127.0.0.1:37948
Sep-12 5:15:52 PM Warning Attempt by plugin to register a duplicate link of Logs. Plugin: OMNI Instance:
Sep-12 5:15:55 PM Plug-In Finished initializing plug-in OMNI
Thanks Pete - I am still trying to reproduce this on my system. It's still on my list.
  #6  
Old September 13th, 2017, 10:07 AM
Pete's Avatar
Pete Pete is offline
OverSeer
 
Join Date: Jan 2001
Location: House
Posts: 14,123
Thank you Rob.

Curious if you see it on your system.

Here testing the Omni Plugin on the Homeseer Lite box.

Last edited by Pete; September 13th, 2017 at 10:45 AM.
  #7  
Old September 17th, 2017, 04:56 PM
Pete's Avatar
Pete Pete is offline
OverSeer
 
Join Date: Jan 2001
Location: House
Posts: 14,123
Today ran HS3 in console mode via a terminal session (./go).

Noticed the following when I shut down Homeseer.

Beginning is startup.

03:57:12:1437:[Info]->Plugin OMNI has connected. IP:127.0.0.1:35078
Connected to HS.
03:57:12:4675:[Warning]->Attempt by plugin to register a duplicate link of Logs. Plugin: OMNI Instance:

03:54:03:7976:[Shutdown]->-------------------------------------------------------------------
03:54:03:7985:[Shutdown]-> HomeSeer Successfully Shut Down Now
03:54:03:7992:[Shutdown]->-------------------------------------------------------------------
HomeSeer Linux has shut down.
Disconnected from server - client
Connection lost, exiting
Connection lost, exiting
root@ICS-Pine64:/HomeSeer# Exception in LOG of OMNI: Object reference not set to an instance of an object
Exception in LOG of OMNI: Object reference not set to an instance of an object
Exception in LOG of OMNI: Object reference not set to an instance of an object

Unhandled Exception:
System.NullReferenceException: Object reference not set to an instance of an object
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke (System.Runtime.Remoting.Proxies.RealProxy rp, IMessage msg, System.Exception& exc, System.Object[]& out_args) <0x7f795ca7b0 + 0x00a44> in :0

03:58:56:3031:[Shutdown]->-------------------------------------------------------------------
03:58:56:3044:[Shutdown]-> HomeSeer Successfully Shut Down Now
03:58:56:3053:[Shutdown]->-------------------------------------------------------------------
HomeSeer Linux has shut down.
Disconnected from server - client
Connection lost, exiting
root@ICS-Pine64:/HomeSeer# Connection lost, exiting
Exception in LOG of OMNI: Object reference not set to an instance of an object
Exception in LOG of OMNI: Object reference not set to an instance of an object
Exception in LOG of OMNI: Object reference not set to an instance of an object
Exception in LOG of OMNI: Object reference not set to an instance of an object
Exception in LOG of OMNI: Object reference not set to an instance of an object
Exception in LOG of OMNI: Object reference not set to an instance of an object
Exception in LOG of OMNI: Object reference not set to an instance of an object
Exception in LOG of OMNI: Object reference not set to an instance of an object
Exception in LOG of OMNI: Object reference not set to an instance of an object
Exception in LOG of OMNI: Object reference not set to an instance of an object
  #8  
Old September 20th, 2017, 07:55 PM
Pete's Avatar
Pete Pete is offline
OverSeer
 
Join Date: Jan 2001
Location: House
Posts: 14,123
Updated today from V357 to V365.

Still seeing a shutdown error after main HS3 shutdown.

06:53:15:5734:[Shutdown]->-------------------------------------------------------------------
06:53:15:5738:[Shutdown]-> HomeSeer Successfully Shut Down Now
06:53:15:5740:[Shutdown]->-------------------------------------------------------------------
HomeSeer Linux has shut down.
Disconnected from server - client
Connection lost, exiting
Connection lost, exiting
root@ICS-HS3ZeeLite:/HomeSeer# Exception in LOG of OMNI: Object reference not set to an instance of an object
Exception in LOG of OMNI: Object reference not set to an instance of an object

Unhandled Exception:
System.NullReferenceException: Object reference not set to an instance of an object
at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_remoting_wrapper (intptr,intptr)
at (wrapper remoting-invoke) HomeSeerAPI.IHSApplication:GetINISetting (string,string,string,string)
at HSPI_OMNI.HAI.HandleRequestTemperatureAndHumidity (HAI_Shared.clsOmniLinkMessageQueueItem M, System.Byte[] B, Boolean Timeout) <0x40308480 + 0x0028f> in :0
at HAI_Shared.clsOmniLinkConnection.x1b3f2cf3fb2ff439 () <0x402d9000 + 0x00dab> in :0
at System.Threading.ThreadHelper.ThreadStart_Context (System.Object state) <0x7f708bcb1010 + 0x00099> in :0
at System.Threading.ExecutionContext.RunInternal (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state, Boolean preserveSyncCtx) <0x7f708bcaf850 + 0x0016e> in :0
at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state, Boolean preserveSyncCtx) <0x7f708bcaf820 + 0x00020> in :0
at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state) <0x7f708bcaf770 + 0x00059> in :0
at System.Threading.ThreadHelper.ThreadStart () <0x7f708bcb11d0 + 0x0002e> in :0
  #9  
Old September 22nd, 2017, 10:17 AM
rmasonjr's Avatar
rmasonjr rmasonjr is offline
OverSeer
 
Join Date: May 2001
Location: Brookhaven, MS USA
Posts: 6,160
When HS3 is shutdown, the plugin is not gracefully shutting down. Most notably, it's trying to log messages related to the shutdown. I will see if there is a way to quietly shutdown.
  #10  
Old September 23rd, 2017, 11:07 PM
Pete's Avatar
Pete Pete is offline
OverSeer
 
Join Date: Jan 2001
Location: House
Posts: 14,123
Thank you Rob.
  #11  
Old September 26th, 2017, 11:26 AM
rmasonjr's Avatar
rmasonjr rmasonjr is offline
OverSeer
 
Join Date: May 2001
Location: Brookhaven, MS USA
Posts: 6,160
New version posted:
https://forums.homeseer.com/showthread.php?t=191092
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OMNI Plugin v3.0.2.2 rmasonjr HAI/OMNI Panel for HS3 Plug-in (rmasonjr) 22 September 11th, 2017 12:10 PM
Events using HAI plugin not working with OMNI plugin lakemirror HAI/OMNI Panel for HS3 Plug-in (rmasonjr) 7 August 15th, 2017 04:59 PM
Omni plugin won't work for us. kpeters59 HAI/OnQ Panel (HS2) 13 June 17th, 2010 12:15 AM
HAI Omni Pro II or Elk M1 Gold Plugin basshook HomeSeer General Discussion Area 1 February 8th, 2006 11:29 PM
Using the Omni plugin rod_tucker HAI/OnQ Panel (HS2) 4 September 2nd, 2003 01:04 PM


All times are GMT -4. The time now is 09:14 PM.


Copyright HomeSeer Technologies, LLC