www.homeseer.com    
 

Go Back   HomeSeer Message Board > Media Plug-ins > Media Discussion > PI-SonosController (3P)

PI-SonosController (3P) Discussion of Sonos Controller Plug-in

Reply
 
Thread Tools Display Modes
  #1  
Old October 15th, 2016, 11:37 AM
Charles_cz Charles_cz is offline
Seer Plus
 
Join Date: Dec 2014
Location: Colorado
Posts: 80
Question TTS to Sonos stuck on one phrase

Hi, I have a quick question about something that has happened to me for second time in three weeks.

I am trying to take it slowly with setting up everything just so it is easier to troubleshoot things. That said I had setup 4 events with "Speak Something" at the end to have confirmation that things are happening.

First two are just announcements when door is locked or unlocked.
Another 2 are announcements that thermostats were set to certain temperature at certain time.

When I was setting these events up I noticed that at some point TTS to my SONOS was stuck on phrase "Front door unlocked" which was phrase from second event. It would not matter if I tried to change text or create new event. No matter what text I have entered in text to be spoken field it would repeat same phrase when testing the event.

I tried to restart Homeseer with no luck.
After all frustration I went to HomeSeer HS3\html\Sonos\Announcements folder and deleted Ann_Test_0.wav file as I thought it was just temp file. Later I restored the file as I would not hear anything. After messing with it for s while (restarts, playing with new events etc.) it started to work again. Not sure what did the trick.

Now, three weeks later without doing any changes the same problem is back and all four actions say same phrase "Front door unlocked" and so does file in Announcments directory.

Is that a bug? How do I fix it? I am using 3.1.0.16 Sonos plugin.
Not sure if that is SONOS plugin issue or something else.

Restart doesn't help.. Any suggestions?

Thank you. Charles
Reply With Quote
  #2  
Old October 15th, 2016, 01:53 PM
dcorsus dcorsus is online now
OverSeer
 
Join Date: Mar 2010
Location: California
Posts: 3,738
Quote:
Originally Posted by Charles_cz View Post
Hi, I have a quick question about something that has happened to me for second time in three weeks.

I am trying to take it slowly with setting up everything just so it is easier to troubleshoot things. That said I had setup 4 events with "Speak Something" at the end to have confirmation that things are happening.

First two are just announcements when door is locked or unlocked.
Another 2 are announcements that thermostats were set to certain temperature at certain time.

When I was setting these events up I noticed that at some point TTS to my SONOS was stuck on phrase "Front door unlocked" which was phrase from second event. It would not matter if I tried to change text or create new event. No matter what text I have entered in text to be spoken field it would repeat same phrase when testing the event.

I tried to restart Homeseer with no luck.
After all frustration I went to HomeSeer HS3\html\Sonos\Announcements folder and deleted Ann_Test_0.wav file as I thought it was just temp file. Later I restored the file as I would not hear anything. After messing with it for s while (restarts, playing with new events etc.) it started to work again. Not sure what did the trick.

Now, three weeks later without doing any changes the same problem is back and all four actions say same phrase "Front door unlocked" and so does file in Announcments directory.

Is that a bug? How do I fix it? I am using 3.1.0.16 Sonos plugin.
Not sure if that is SONOS plugin issue or something else.

Restart doesn't help.. Any suggestions?

Thank you. Charles
All seems to point to the "Text-to-Speech" function not working. The fact you always heard the same is because it is not being overwritten and when you delete it, you hear nothing so no file is being created.

Up to very recently, I was under the impression that the speaker client on the HS PC was responsible for this (HS!!) function. Somebody pointed out that wasn't correct and that it might be the Windows text-to-speech function that is being called directly by HS. So check the windows text-to-speech settings, see if there is anything out of the ordinary there. Are you using a special voice for example?

Could you also post a screen shot of your event to make sure the event was created properly.

Dirk
Reply With Quote
  #3  
Old October 15th, 2016, 03:27 PM
Charles_cz Charles_cz is offline
Seer Plus
 
Join Date: Dec 2014
Location: Colorado
Posts: 80
Hi Dirk, it has been working just fine for 2-3 weeks with correct TTS announcements for each event. Suddenly it started to say same thing on each event without any change to events or any other configuration.

I have attached screenshot from event.

To answer your question, no, I am not using anything special about TTS. I did not make any changes to TTS.
Attached Images
 
Reply With Quote
  #4  
Old October 15th, 2016, 03:56 PM
Charles_cz Charles_cz is offline
Seer Plus
 
Join Date: Dec 2014
Location: Colorado
Posts: 80
OK.. I think I figured out where the problem. I am using built-in task scheduler to start HS and it looks like it bypasses UAC or it doesn't give proper access control to overwrite the file. If I start HS manually it prompts me to UAC dialog and after HS starts everything works just fine.

I guess I will have to find some software that will allow me to start HS automatically in windows 10 with proper write/read privileges.

What is everyone using?
Reply With Quote
  #5  
Old October 25th, 2016, 04:19 PM
field888 field888 is offline
Seer Deluxe
 
Join Date: Oct 2007
Location: New Jersey
Posts: 171
I recently ran across this same issue - TTS not over writing previous announcements sent to the same speaker client. Driving me crazy until I read your posts. I am using Jon00 Restart and when HS3 has been started using that PI, the announcements don't work properly at all. I can't even create a new speaker client. I'll have to see how I can work around that issue. I have tested SONOS extensively using manual start and all announcements function properly. Incidentally, when I say manual start, I'm referring to a shortcut that starts HS3 in the HS3 directory. No worries about UAC. I also start HS3automatically without delay with a small bat file in the startup directory. If you don't need any delay, that works fine and will allow SONOS to work fine also.

UPDATE: I was able to modify the HS3 startup bat file with a time delay, so the 'restart PI bat file isn't need. I fully tested SONOS TTS and all is working properly.

Last edited by field888; October 26th, 2016 at 12:45 PM.
Reply With Quote
  #6  
Old October 26th, 2016, 09:45 AM
jon00's Avatar
jon00 jon00 is offline
OverSeer
 
Join Date: Jan 2002
Location: London UK
Posts: 11,562
Quote:
Originally Posted by field888 View Post
I am using Jon00 Restart and when HS3 has been started using that PI, the announcements don't work properly at all. I can't even create a new speaker client.
FYI, That may be because you were not running the exe or shortcut as an administrator.
__________________
Jon

Reply With Quote
  #7  
Old October 26th, 2016, 12:35 PM
field888 field888 is offline
Seer Deluxe
 
Join Date: Oct 2007
Location: New Jersey
Posts: 171
Kudos to Jon00 for the quick reply to this thread! I have to apologize to you, I changed the PI to CFguy's 'Restart' so this issue has nothing to do with your PI - sorry bout that.
Reply With Quote
  #8  
Old April 26th, 2018, 04:46 PM
knutarn knutarn is offline
Viewer
 
Join Date: Feb 2018
Location: Norge
Posts: 3
Quote:
Originally Posted by field888 View Post
I recently ran across this same issue - TTS not over writing previous announcements sent to the same speaker client. Driving me crazy until I read your posts. I am using Jon00 Restart and when HS3 has been started using that PI, the announcements don't work properly at all. I can't even create a new speaker client. I'll have to see how I can work around that issue. I have tested SONOS extensively using manual start and all announcements function properly. Incidentally, when I say manual start, I'm referring to a shortcut that starts HS3 in the HS3 directory. No worries about UAC. I also start HS3automatically without delay with a small bat file in the startup directory. If you don't need any delay, that works fine and will allow SONOS to work fine also.

UPDATE: I was able to modify the HS3 startup bat file with a time delay, so the 'restart PI bat file isn't need. I fully tested SONOS TTS and all is working properly.
How you make the file?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Extract phrase before phrase travisdh Script & Plug-In Development 4 October 22nd, 2013 07:13 AM
Sonos PlugIn has lost connection to Sonos system NicolaiL PI-SonosController (3P) 4 February 11th, 2013 07:56 AM
Sonos Not Talking (Sonos update issue?) gerlin PI-SonosController (3P) 4 March 25th, 2012 05:41 PM
How to search for a phrase sponnath Message Board Issues, Suggestion, Problems 1 July 16th, 2010 10:32 PM
Getting last spoken phrase rmasonjr Script & Plug-In Development 0 December 16th, 2007 06:14 PM


All times are GMT -4. The time now is 11:18 AM.


Copyright HomeSeer Technologies, LLC