www.homeseer.com    
 

Go Back   HomeSeer Message Board > Media Plug-ins > Media Discussion > PI-SonosController (3P)

PI-SonosController (3P) Discussion of Sonos Controller Plug-in

Reply
 
Thread Tools Display Modes
  #181  
Old April 7th, 2014, 11:42 PM
dcorsus dcorsus is offline
OverSeer
 
Join Date: Mar 2010
Location: California
Posts: 3,737
Quote:
Originally Posted by mpovolo View Post
Any idea what this error is about, Started happening after the latest update.

Apr-07 11:24:23 PM Sonos Error ERROR in GetCurrentTrackInfo/GetMediaInfo for zoneplayer = Amp with UPNP Error = -2147012194: Unknown error type. OrgError=-2147012894. Error = Exception from HRESULT: 0x80072EE2
Apr-07 11:24:23 PM Sonos Error ERROR in PlayURI for zoneplayer = Amp with UPNP Error = -2147012194: Unknown error type. OrgError=-2147012894. URI=x-sonosapi-stream:s12366?sid=254&flags=32, MetaData={0x3C}DIDL-Lite xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:upnp="urn:schemas-upnp-org:metadata-1-0/upnp/" xmlns:r="urn:schemas-rinconnetworks-com:metadata-1-0/" xmlns="urn:schemas-upnp-org:metadata-1-0/DIDL-Lite/"{0x3E3C}item id="-1" parentID="-1" restricted="true"{0x3E3C}dc:title{0x3E}Z103.5{0x3C}/dc:title{0x3E3C}upnp:class{0x3E}object.item.audioItem.audioB roadcast{0x3C}/upnp:class{0x3E3C}desc id="cdudn" nameSpace="urn:schemas-rinconnetworks-com:metadata-1-0/"{0x3E}SA_RINCON65031_{0x3C}/desc{0x3E3C}/item{0x3E3C}/DIDL-Lite{0x3E}, Error =Exception from HRESULT: 0x80072EE2
network error?
0x80072EE2 -2147012894 ERROR_INTERNET_TIMEOUT
Reply With Quote
  #182  
Old April 8th, 2014, 08:47 AM
mpovolo mpovolo is offline
Seer Deluxe
 
Join Date: Feb 2012
Location: Toronto
Posts: 281
Thanks,

What is odd is that from HS3 I can control and play music via the web interface. However using an event does causes the error.
Reply With Quote
  #183  
Old April 8th, 2014, 10:26 AM
dcorsus dcorsus is offline
OverSeer
 
Join Date: Mar 2010
Location: California
Posts: 3,737
Quote:
Originally Posted by mpovolo View Post
Thanks,

What is odd is that from HS3 I can control and play music via the web interface. However using an event does causes the error.
I suspect that the "learned" info, that is used in the event is outdated for that radio-channel. As far as I can tell, you are trying to play an internet radio station, correct? Is the "learn radio station" option still turned on? If so, select the station from a regular controller and see if you can play that station. If you can, does the event now work? If not, recreate the event and try again.

Dirk
Reply With Quote
  #184  
Old April 11th, 2014, 03:59 AM
NicolaiL's Avatar
NicolaiL NicolaiL is offline
Super Seer
 
Join Date: Mar 2002
Location: Herts, UK
Posts: 1,648
Hi

On HS3 startup I get an error for each of my zone players like this one:


Apr-11 09:09:17 Sonos Error Error in myDeviceFinderCallback_DeviceFound for pDevice.Services for zoneplayer = Kitchen/Lounge. Error=Exception from HRESULT: 0x80040500

Everything else is working fine and all network issues have been sorted out a while back. It only appears to be on startup and does not appear to affect functionality otherwise.

I'm on 3.0.0.10 of the plug-in
Reply With Quote
  #185  
Old April 14th, 2014, 01:59 AM
desolatax desolatax is offline
Seer
 
Join Date: Jul 2013
Location: BC
Posts: 47
I updated to the Sonos beta and my players are now all showing offline in the plugin, even though they are pingable from the server and were working fine before the beta. Just a heads up that something may be changing, and also wondering if you have any ideas.
Edit: Seems like I just had to power cycle all of my Sonos devices after the update to get the plugin working again. App was working fine when the plugin wasn't working.

Last edited by desolatax; April 14th, 2014 at 02:18 AM.
Reply With Quote
  #186  
Old April 23rd, 2014, 03:44 PM
vanisher vanisher is offline
Seer
 
Join Date: Apr 2012
Location: Nederland
Posts: 50
The last beta will expire on 30th april. Any updates on that one?
Reply With Quote
  #187  
Old April 23rd, 2014, 04:13 PM
dcorsus dcorsus is offline
OverSeer
 
Join Date: Mar 2010
Location: California
Posts: 3,737
Quote:
Originally Posted by vanisher View Post
The last beta will expire on 30th april. Any updates on that one?
New beta fixing some cosmetics and extending period will be posted soon.

Dirk
Reply With Quote
  #188  
Old April 26th, 2014, 03:23 AM
vanisher vanisher is offline
Seer
 
Join Date: Apr 2012
Location: Nederland
Posts: 50
Great! The plugin is working like a charm!
Reply With Quote
  #189  
Old April 27th, 2014, 01:23 PM
dcorsus dcorsus is offline
OverSeer
 
Join Date: Mar 2010
Location: California
Posts: 3,737
New Sonos HS3 beta v3.0.0.11 posted

Changes to Beta v3.0.0.11
  • The startup Error should be gone now
  • If you are on the latest HS3 beta, the issue with menu items not being updated when a zone name changes, should be fixed
  • Extended the date until end of July
  • Beware: most likely, the next beta (> v 11) will have major changes as I'm attempting to design out window components that prevent it from being used in a Linux environment. As of then, I'll maintain 2 beta versions, until the new beta is as stable as the old. Events most likely will have to be redone. This beta only has minor cosmetic changes and is first and foremost posted to extend the due date
Reply With Quote
  #190  
Old May 3rd, 2014, 02:23 AM
beerygaz's Avatar
beerygaz beerygaz is offline
Super Seer
 
Join Date: Mar 2006
Location: Johannesburg, South Africa
Posts: 1,664
Dirk, I'm getting a lot of the following in my log after an update to .11


May-03 08:14:01 Sonos Error Error in myDeviceFinderCallback_DeviceFound for zoneplayer = Office Dock. Some crucial services are not on-line. The plug-in cannot work for this zone

Is that expected?
Reply With Quote
  #191  
Old May 3rd, 2014, 10:25 AM
dcorsus dcorsus is offline
OverSeer
 
Join Date: Mar 2010
Location: California
Posts: 3,737
Quote:
Originally Posted by beerygaz View Post
Dirk, I'm getting a lot of the following in my log after an update to .11


May-03 08:14:01 Sonos Error Error in myDeviceFinderCallback_DeviceFound for zoneplayer = Office Dock. Some crucial services are not on-line. The plug-in cannot work for this zone

Is that expected?
Actually it isn't.

After I released v.11 and I dug up my WD100 Dock for something else, I noticed the error, which means your Dock isn't working.

I can post a new version if you need this urgently, else I was waiting to see if anything else was off and I need to spend some time getting the whole installer thing working.

Dirk
Reply With Quote
  #192  
Old May 3rd, 2014, 11:28 AM
beerygaz's Avatar
beerygaz beerygaz is offline
Super Seer
 
Join Date: Mar 2006
Location: Johannesburg, South Africa
Posts: 1,664
Nope - not urgent right now - slide it into the next release, my dock isn't used that much at present.
Reply With Quote
  #193  
Old May 3rd, 2014, 09:04 PM
dcorsus dcorsus is offline
OverSeer
 
Join Date: Mar 2010
Location: California
Posts: 3,737
New Sonos HS3 beta v3.0.0.12 posted

Changes to Beta v3.0.0.12
  • Broke implementation of WD100 Dock
Reply With Quote
  #194  
Old May 4th, 2014, 03:23 AM
beerygaz's Avatar
beerygaz beerygaz is offline
Super Seer
 
Join Date: Mar 2006
Location: Johannesburg, South Africa
Posts: 1,664
Awesome Dirk, thanks.
Reply With Quote
  #195  
Old May 6th, 2014, 04:10 PM
Agwan Agwan is offline
Seer Deluxe
 
Join Date: Dec 2013
Location: Stockholm, Sweden
Posts: 218
Is there any reason why the playlists arent showing any more?

When in [PLUG-INS] -> [Sonos] -> [Sonos unit name] I can see "Line Input" when I press it. But "Radiostaionts" or Playlists" are gone. I tried "Auto Update Flag" and "Immediate Update Flag" in the "Config"-page.
Reply With Quote
  #196  
Old May 6th, 2014, 07:38 PM
dcorsus dcorsus is offline
OverSeer
 
Join Date: Mar 2010
Location: California
Posts: 3,737
Quote:
Originally Posted by Agwan View Post
Is there any reason why the playlists arent showing any more?

When in [PLUG-INS] -> [Sonos] -> [Sonos unit name] I can see "Line Input" when I press it. But "Radiostaionts" or Playlists" are gone. I tried "Auto Update Flag" and "Immediate Update Flag" in the "Config"-page.
Can you post a screenshot. Which OS are you running this on; which browser are you using; did you create a musicDB? Do you see errors in the log file with debug flag turned on and pulling up the web page?

Dirk
Reply With Quote
  #197  
Old May 7th, 2014, 02:58 AM
Agwan Agwan is offline
Seer Deluxe
 
Join Date: Dec 2013
Location: Stockholm, Sweden
Posts: 218
Hmm, today it works. I did not change anything regarding the Sonos since it was working before. Perhaps I restarted the Sonos unit a day before and did not use it until I saw that something was wrong. I tried to start playing music from my HSTouch interface (yesturday), and even thou the event I use to start one of the playlists could not see the playlists, it did start playing.

Lets see this as my falut and I will get back if it happens again.

Great work by the way. One of the best plugins Im using.
Reply With Quote
  #198  
Old May 18th, 2014, 05:24 PM
PosterBoy PosterBoy is offline
Seer
 
Join Date: May 2008
Location: Arizona
Posts: 45
Getting Errors

Hi Dirk

I am running HS 3 version 3.0.0.68 and Sonos Beta version v3.0.0.12
I am running on a windows XP VM running under ESXi on a reasonably fast machine

I am getting the
May-18 2:33:55 PM Sonos Error Error in DirectConnect for zoneplayer = Kitchen when getting the ChannelMapSet/ZoneName with Error = Exception from HRESULT: 0x80040212
May-18 2:33:55 PM Sonos Error Error in DirectConnect for zoneplayer = Kitchen when getting the AudioInputName with Error = Exception from HRESULT: 0x80040212

Errors

Here is my Log
Attached Files
File Type: txt SonosDebug.txt (81.6 KB, 5 views)
Reply With Quote
  #199  
Old May 18th, 2014, 06:02 PM
dcorsus dcorsus is offline
OverSeer
 
Join Date: Mar 2010
Location: California
Posts: 3,737
Quote:
Originally Posted by PosterBoy View Post
Hi Dirk

I am running HS 3 version 3.0.0.68 and Sonos Beta version v3.0.0.12
I am running on a windows XP VM running under ESXi on a reasonably fast machine

I am getting the
May-18 2:33:55 PM Sonos Error Error in DirectConnect for zoneplayer = Kitchen when getting the ChannelMapSet/ZoneName with Error = Exception from HRESULT: 0x80040212
May-18 2:33:55 PM Sonos Error Error in DirectConnect for zoneplayer = Kitchen when getting the AudioInputName with Error = Exception from HRESULT: 0x80040212

Errors

Here is my Log
Do you see this each time you start HS or sometimes?

This is really not a big deal, I suspect I try to read a variable that has not been updated in the UPNP subsystem. I had added a 1 second wait in the past but that might not be enough but what is enough?

Dirk
Reply With Quote
  #200  
Old May 18th, 2014, 07:46 PM
PosterBoy PosterBoy is offline
Seer
 
Join Date: May 2008
Location: Arizona
Posts: 45
Hi Dirk

Unfortunately I always see both errors for every zone on startup and then again both errors for all zones repeating every 20 minutes after
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SonosController Plugin General Forum dcorsus PI-SonosController (3P) 167 February 19th, 2018 08:30 AM
SonosController Plug-In Beta testing Forum dcorsus PI-SonosController (3P) 169 February 7th, 2016 05:19 PM
DLNA Manager Plug-In Beta testing Forum dcorsus Media Controller Plug-in (3P) 280 November 19th, 2015 12:26 PM
Beta Builds are now in the Beta forum rjh HS2 / HSPRO 0 January 7th, 2013 04:48 PM
Testing the new beta jowens14 UltraPioneerAVR HSPI 4 December 28th, 2011 11:04 PM


All times are GMT -4. The time now is 08:56 PM.


Copyright HomeSeer Technologies, LLC