www.homeseer.com    
 

Go Back   HomeSeer Message Board > HomeSeer Products & Services > HomeSeer Hardware > HomeTroller Zee

HomeTroller Zee Discussions related to the HomeTroller Zee automation controller based on Linux.

Reply
 
Thread Tools Display Modes
  #1  
Old January 5th, 2017, 02:53 PM
retiredtech retiredtech is offline
Seer
 
Join Date: Dec 2014
Location: Utah
Posts: 35
Unable to receive email - error in log

Current Date/Time: 1/5/2017 11:42:27 AM
HomeSeer Version: HS3 ZEE Edition 3.0.0.208
Linux version: Linux HomeTrollerZEE 4.1.19-v7+ #858 SMP Tue Mar 15 15:56:00 GMT 2016 armv7l GNU/Linux System Uptime: 0 Days 1 Hour 55 Minutes 31 Seconds
IP Address: 192.168.0.145
Number of Devices: 17
Number of Events: 92

Enabled Plug-Ins
3.0.0.72: HSTouch Server
3.0.0.36: X10
3.0.1.29: Z-Wave

Fully functional system for past 1 1/2 years then 2 weeks ago I stopped receiving emails. Sending emails work fine. The error log is shown below. What I have done for isolation of problem:
1. replace backup config. 2. replace entire backup system code. 3. Moved email from Gmail to POP under Yahoo. 4. Swapped Raspberry Pi 2 to another RPI2. 5. Swapped out ethernet connection.
No change in failure. Help me isolate the problem from the error log:

Unable to log into Gmail server: Authenticate as SSL client failed. You might be connecting to non SSL port.:Inner Exception: System.IO.IOException: The authentication or decryption has failed. ---> Mono.Security.Protocol.Tls.TlsException: Invalid certificate received from server. at Mono.Security.Protocol.Tls.Handshake.Client.TlsServerCertifi cate.LocalValidation (Mono.Security.Protocol.Tls.ClientContext context, AlertDescription description) [0x00000] in :0 at Mono.Security.Protocol.Tls.Handshake.Client.TlsServerCertifi cate.validateCertificates (Mono.Security.X509.X509CertificateCollection certificates) [0x00000] in :0 at Mono.Security.Protocol.Tls.Handshake.Client.TlsServerCertifi cate.ProcessAsTls1 () [0x00000] in :0 at Mono.Security.Protocol.Tls.Handshake.HandshakeMessage.Proces s () [0x00000] in :0 at (wrapper remoting-invoke-with-check) Mono.Security.Protocol.Tls.Handshake.HandshakeMessage:Proces s () at Mono.Security.Protocol.Tls.ClientRecordProtocol.ProcessHands hakeMessage (Mono.Security.Protocol.Tls.TlsStream handMsg) [0x00000] in :0 at Mono.Security.Protocol.Tls.RecordProtocol.InternalReceiveRec ordCallback (IAsyncResult asyncResult) [0x00000] in :0 --- End of inner exception stack trace --- at Mono.Security.Protocol.Tls.SslStreamBase.AsyncHandshakeCallb ack (IAsyncResult asyncResult) [0x00000] in :0

Update: Did sudo apt-get update to Linux but no effect on error. May have to re-do application so as not to depend on receiving emails. Others have indicated the same problem and no resolution was ever shown.

Update: No resolution. Moved to new hardware (RPI V3 and upgrade to Homeseer). It works fine on email receive. Close out request for assistance.

Last edited by retiredtech; January 7th, 2017 at 05:11 PM.
Reply With Quote
  #2  
Old January 31st, 2017, 05:36 PM
gd1210's Avatar
gd1210 gd1210 is offline
Seer Deluxe
 
Join Date: Mar 2016
Location: Edinburgh
Posts: 427
I have exactly the same problem. Ive never managed to get it to work.
Reply With Quote
  #3  
Old March 2nd, 2017, 10:01 PM
MikeSM MikeSM is offline
Seer
 
Join Date: Jan 2016
Location: California
Posts: 9
Same here
Reply With Quote
  #4  
Old March 3rd, 2017, 02:10 PM
MikeSM MikeSM is offline
Seer
 
Join Date: Jan 2016
Location: California
Posts: 9
Some more information. I'm using Gmail to send emails and this works without any problems for a year now. I enabled POP on the gmail account and just checked the "Check E-Mail" option. I tried both with and without SSL. Both fail all the time with the error message shown in the firtst post.

HomeSeer Version: HS3 ZEE S2 Edition 3.0.0.297
Linux version: Linux HomeTrollerZeeS2 3.18.7-v7+ #755 SMP PREEMPT Thu Feb 12 17:20:48 GMT 2015 armv7l GNU/Linux System Uptime: 0 Days 20 Hours 14 Minutes 18 Seconds
IP Address: 192.168.1.11
Number of Devices: 100
Number of Events: 63
Available Threads: 399

Enabled Plug-Ins
3.0.0.74: HSTouch Server
0.0.0.29: Pushover 3P
3.0.6119.21453: UltraNetCam3
3.0.1.87: Z-Wave
Reply With Quote
  #5  
Old March 3rd, 2017, 03:05 PM
MikeSM MikeSM is offline
Seer
 
Join Date: Jan 2016
Location: California
Posts: 9
Updated to the latest release 3.0.0.312, but still the same error.

Also, the gmail account is set to "less secure". Otherwise Homeseer cannot even send emails through it.
Reply With Quote
  #6  
Old March 18th, 2017, 12:17 PM
pgmp pgmp is offline
Seer Plus
 
Join Date: Oct 2005
Location: México
Posts: 83
FYI, The option to read emails from my Gmail Account was running for me, with the same version of HS3 in my ZEE, and no changes in the Operating System. Suddenly in 2016, in the first semester, HS3 started to log the error well documented here.

It seems to be that Gmail made changes in the way accepts access from Linux apps like HomeSeer. I don't have HS3 in Windows but is documented in other posts that they can get Gmail emails from HS3 running under Windows. In my case, even though I changed my Gmail account settings, HS3 can't get emails. There is no problem to send emails with the same account, but in this case HS connects with an SMTP Server.

@Rich, I ran the three commands suggested by you in other posts:
sudo mozroots --import --ask-remove
sudo mozroots --import --ask-remove --machine
sudo certmgr -ssl -m smtps://smtp.gmail.com:465
But still the issue is not fixed

I think it must be fixed getting support from Google. Please do it because this feature is very useful to take actions based on emails send with specific parameters.

Many Thanks!

Last edited by pgmp; March 19th, 2017 at 04:58 PM.
Reply With Quote
  #7  
Old November 3rd, 2017, 01:05 PM
MikeSM MikeSM is offline
Seer
 
Join Date: Jan 2016
Location: California
Posts: 9
Any news on this? I just updated to 3.0.0.368 and still see the same problem. This is a regular feature of Homeseer and I would really appreciate if Homeseer can fix this.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HS3 Hometroller SEL sends email thru Gmail account, but won't receive Jurgen HS3 / HS3PRO Discussion 5 February 1st, 2016 06:10 PM
Error in loading email receive routine retiredtech HS3-Pi Discussion 1 April 9th, 2015 06:45 PM
want to receive email about alarm system status change Ricky Vista Alarm Plug-in (3P) 4 November 13th, 2011 10:45 AM
Email Receive with MAPI mrhappy HS2 / HSPRO 0 August 16th, 2009 06:20 PM
Unable to receive security clkmn RFXCOM Plug-In (3P) 3 June 8th, 2008 10:58 AM


All times are GMT -4. The time now is 01:11 AM.


Copyright HomeSeer Technologies, LLC