www.homeseer.com    
 

Go Back   HomeSeer Message Board > User Interface Plug-ins > User Interface Discussion

User Interface Discussion User Interface Plug-ins

Reply
 
Thread Tools Display Modes
  #221  
Old December 31st, 2017, 08:29 PM
Jobee Jobee is offline
Seer Deluxe
 
Join Date: Apr 2016
Location: Texas
Posts: 356
I am loving this app.

Couple things I have question on now.

HS just implemented new SSL (beta .399 version) that uses the current .Net SSL so it is current security. No more need for the ouside SSL or to VPN to the system. It is working great and I have both local and external SSL setup on the web server so I can use buddy outside and it works with SSL. Ultimate goal is to turn off port 80 and I do not use MyHS.

So, now that it is working, my question is around the new Local Connection that was just introduced. It is working great when the port is 80, but if I try to set it to 443, it cannot connect to hs3 and the following debug is in the log:


Dec-31 18:17:36 HSBuddy Inserting device change: 962, , 1385
Dec-31 18:17:35 Error Authenticating SSL stream: The handshake failed due to an unexpected packet format.
Dec-31 18:17:35 Error Authenticating SSL stream: The handshake failed due to an unexpected packet format.
Dec-31 18:17:28 HSBuddy Inserting device change: 317, , 14.99
Dec-31 18:17:28 HSBuddy Observed client "Pixel XL" with UUID: 25aab713065c0b18


What needs to happen to get the local fixed so it is SSL?

Thanks,

Michael
__________________
HS3Pro on Win2012R2
Aeotec, Cooper, Cree, GE/Jasco, Intermatic, LIFX, Fortrezz, OSRAM, RCS, Trane, Zooz
BLBackup, BLGData, BLRussound, BLSpeech, HSTouch, InvisaLink, HSBuddy, IFTTT, NetCAM, PHLocation, Pushover 3P, Random, UltraLighting3, weatherXML, ZigBee, Z-Wave
Reply With Quote
  #222  
Old January 10th, 2018, 03:04 PM
mhbsoft mhbsoft is offline
Viewer
 
Join Date: Sep 2017
Posts: 3
Unhappy Plugin missing

Hi Antonio,
I've been looking for your plugin in:
Plugin: Available under the BETA section of the Plugin Manager in your HS3 server.

But, couldn't find it
Where else can I look for??
Thanks
Reply With Quote
  #223  
Old January 10th, 2018, 07:27 PM
avargaskun's Avatar
avargaskun avargaskun is offline
Seer Plus
 
Join Date: Sep 2015
Location: Redmond, WA
Posts: 77
Quote:
Originally Posted by mhbsoft View Post
Hi Antonio,
I've been looking for your plugin in:
Plugin: Available under the BETA section of the Plugin Manager in your HS3 server.

But, couldn't find it
Where else can I look for??
Thanks
Hello,

The plug-in should now appear under the User Interfaces section instead of BETA.

Thanks!
Antonio.
Reply With Quote
  #224  
Old January 11th, 2018, 02:52 AM
avargaskun's Avatar
avargaskun avargaskun is offline
Seer Plus
 
Join Date: Sep 2015
Location: Redmond, WA
Posts: 77
Quote:
Originally Posted by Jobee View Post
I am loving this app.

Couple things I have question on now.

HS just implemented new SSL (beta .399 version) that uses the current .Net SSL so it is current security. No more need for the ouside SSL or to VPN to the system. It is working great and I have both local and external SSL setup on the web server so I can use buddy outside and it works with SSL. Ultimate goal is to turn off port 80 and I do not use MyHS.

So, now that it is working, my question is around the new Local Connection that was just introduced. It is working great when the port is 80, but if I try to set it to 443, it cannot connect to hs3 and the following debug is in the log:


Dec-31 18:17:36 HSBuddy Inserting device change: 962, , 1385
Dec-31 18:17:35 Error Authenticating SSL stream: The handshake failed due to an unexpected packet format.
Dec-31 18:17:35 Error Authenticating SSL stream: The handshake failed due to an unexpected packet format.
Dec-31 18:17:28 HSBuddy Inserting device change: 317, , 14.99
Dec-31 18:17:28 HSBuddy Observed client "Pixel XL" with UUID: 25aab713065c0b18


What needs to happen to get the local fixed so it is SSL?

Thanks,

Michael
Hi,

I have not tried the beta that has this new SSL support - I will check it out in the next few days and see if I get the same issue.

Could you let me know which version of HSBuddy are you using? Is it iPhone or Android, and did you get it from HockeyApp or from the app store? Also, does the identity in the SSL certificate match the address of the server?

Since you mentioned that you are using this to connect locally, I'm suspecting it fails because the identity in the certificate does not match the server address. You would have to enable the option to "Allow invalid certificates" in the app, which is only available in HockeyApp.

Thanks,
Antonio
Reply With Quote
  #225  
Old January 25th, 2018, 08:01 PM
sbrandon sbrandon is offline
Viewer
 
Join Date: Jan 2018
Location: Georgia
Posts: 1
HSBuddy Notifications

I am having this same issue. Notifications say sent to 0 devices even though i have two devices listed in clients list with green check marks for notifications. Is this functionality broken?



Quote:
Originally Posted by wb-avl View Post
I'm really liking this app!

I have setup a few push messages but I'm not having any luck.

I have notifications enabled for the app on my iphone.

I also checked the hsbuddy plugin and the client info appears correct.

My server log shows "push notification successfully sent to 0 devices"

Thanks
Reply With Quote
  #226  
Old February 3rd, 2018, 04:37 PM
Jobee Jobee is offline
Seer Deluxe
 
Join Date: Apr 2016
Location: Texas
Posts: 356
Quote:
Originally Posted by avargaskun View Post

Could you let me know which version of HSBuddy are you using? Is it iPhone or Android, and did you get it from HockeyApp or from the app store? Also, does the identity in the SSL certificate match the address of the server?

Since you mentioned that you are using this to connect locally, I'm suspecting it fails because the identity in the certificate does not match the server address. You would have to enable the option to "Allow invalid certificates" in the app, which is only available in HockeyApp.

Thanks,
Antonio
Hi Antonio,

I have the android version and from the HockeyApp download. I have a full server cert and do not use the MyHomeSeer nor allow any non-https connection from the outside world. I even connect internally via https.

The way HS3 ssl works you have to have a pfx file then in HS3 put the info to get into and use the certs in the pfx.

I did finally get this to work. In HS3 I have is set to direct and using port 443 and use secure connections. I also turned off ASCII connection.

On the main screen of buddy, next to the hamburger menu button, the blue house comes and goes but is stays on for the most part. I've not see what this means, but assume it is the connection is made.

I have mine grouped by Room. The only thing I would love to see, is if then it could group by device. An example is I have a whole home audio system that has multiple devices (power, volume, bass etc.) and they are listed in alpha order and not grouped.

If this is not possible, then maybe have a device alias either in buddy or the plug in so we can edit the name just for showing in buddy.

Thanks,

Michael
Reply With Quote
  #227  
Old February 13th, 2018, 12:33 AM
anstosa anstosa is offline
Seer
 
Join Date: Jan 2018
Location: Washington
Posts: 9
Hi Antonio,

I just found your app. WOW! Seriously good work. I haven't been satisfied with any of the options out there including the paid ones and yours is great! Can't wait to see it on the Play Store at some point, especially with an option to donate or with paid features. You should be compensated for your work!
Reply With Quote
  #228  
Old February 14th, 2018, 04:07 PM
BobS0327 BobS0327 is offline
Viewer
 
Join Date: Jan 2018
Location: NorthEast Pennsylvania
Posts: 3
I got the following warning when I installed the HSBuddy plugin..

WARNING: Failed getting InterfaceStatus from HSBuddy - the interface was not found in the list of active interfaces,the list may need to be refreshed.

I'm not sure what it means since I'm new to HomeSeer and HSBuddy.
Reply With Quote
  #229  
Old February 15th, 2018, 05:28 AM
Gogs's Avatar
Gogs Gogs is offline
OverSeer
 
Join Date: Apr 2003
Location: Kirkliston, Scotland, GB
Posts: 4,637
Just downloaded your app from the updater, but will not install, get this error.
Quote:
Feb-15 09:23:36
Error Warning, Cannot load EXE file (possibly missing dependencies) HSPI_HSBuddy.exe: Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.Warning, Error details with EXE HSPI_HSBuddy.exe: Could not load type 'System.Runtime.CompilerServices.IAsyncStateMachine' from assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'.Warning, Error details with EXE HSPI_HSBuddy.exe: Could not load type 'System.Runtime.CompilerServices.IAsyncStateMachine' from assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'.Warning, Error details with EXE HSPI_HSBuddy.exe: Could not load type 'System.Runtime.CompilerServices.IAsyncStateMachine' from assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'.Warning, Error details with EXE HSPI_HSBuddy.exe: Could not load type 'System.Runtime.CompilerServices.IAsyncStateMachine' from assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'.
Any ideas?
__________________

A founder member of "The HA Pioneer Group" otherwise known as the "Old farts club!"
HomeSeer 3 V 3.0.0.318 with ALEXA (AKA Amazon Echo)
BL Radar V2.0.217; BLRF V2.0.85.0; HS Touch V3.0.0.1034 X10 V3.0.0.42; PHLocation V3.0.0.38; Zwave V3.0.1.110; X10 V3.0.0.42
BLBackup V2.0.39;ImperiHome3.0.0.20 All on Windows XP Pro
Reply With Quote
Reply

Bookmarks

Tags
app, client, mobile, phone, remote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
All-In-One Mobile UI ... iPhone, Windows Mobile, etc alevey Web Server and Interface 11 February 7th, 2013 12:11 PM
Mobile brenton.prettejohn pjc Network 0 September 19th, 2011 04:27 AM
Mobile Backup darren-mc SMS Connector 0 August 23rd, 2010 04:46 AM
Windows Mobile Help 68sting Clients - Windows CE / Mobile 0 October 23rd, 2009 05:53 PM
Help with Windows Mobile Please phillb Clients - Windows CE / Mobile 4 February 25th, 2009 06:49 PM


All times are GMT -4. The time now is 01:02 AM.


Copyright HomeSeer Technologies, LLC