www.homeseer.com    
 

Go Back   HomeSeer Message Board > Media Plug-ins > Media Discussion > SqueezeBox Plug-In (3P)

SqueezeBox Plug-In (3P) Discussion area for the SqueezeBox plug-in by PCP.

Reply
 
Thread Tools Display Modes
  #181  
Old March 12th, 2018, 07:47 PM
ServiceXp's Avatar
ServiceXp ServiceXp is offline
Seer Master
 
Join Date: May 2015
Location: USA
Posts: 826
So many problems 1 of 2

At this point I'm not sure if my entire installation is messed up or if there are just some serious problems in the setup.

LMS > CB >> LMS HS3 PI >> HS3 PI

Chromecast Audio's and Grace Digital CastDock X2 Speakers


Problems I've Encounter: (Here are just a few)
TTS Problems:

1) Typically I can only get it to speak one time. For the first 2 or 3 attempts the speakers indicator light will illuminate as if it's going to speak (but fails). At some point, generally after the 3rd attempt the speak indicator wont even light up, and the PI typically crashes

The TTS .mp3 file is created and will play without issue on any player.

2): The settings 'TTS Voice' setting is being ignored (see picture in second post)
3): Looks like it sends duplicate TTS's
4): This isn't a bug, but I was hoping that 'Delay Before Speaking' would wake the speaker before speaking.

Music Problems:

1) Mute button drives volume to 100%, Un-mute allows it to return to prev. settings
2) None of the Player Devices have accurate or updated or feed back/function to HS

etc...etc...
Attached Images
    
Attached Files
File Type: zip hspi_squeezebox_debug.zip (29.1 KB, 0 views)
File Type: zip hspi_squeezebox_debug_Large.zip (906.0 KB, 0 views)
__________________
RJ_Make On YouTube

Last edited by ServiceXp; March 13th, 2018 at 06:10 AM.
Reply With Quote
  #182  
Old March 12th, 2018, 07:48 PM
ServiceXp's Avatar
ServiceXp ServiceXp is offline
Seer Master
 
Join Date: May 2015
Location: USA
Posts: 826
So many problems 2 of 2

More Pics..
Attached Images
     
Reply With Quote
  #183  
Old March 13th, 2018, 07:52 AM
ServiceXp's Avatar
ServiceXp ServiceXp is offline
Seer Master
 
Join Date: May 2015
Location: USA
Posts: 826
.. and then the music just stopped. Tried restarting all services involved, rebooting the machine (several times) still would not play through the speakers.

The LMS web player status bar would count up to ~5 sec, then quickly move to the end as if it was finished. If I hit pause it would just repeat the above.

Un-installed the LMS HS3 PI, Rebooted server and end up with the picture below. Had to manual hit the "Generate .xml" file button again to get the IP entries to show up in HS3.

Now I can play via the LMS web player to the CCA's.

Logs may not be useful as I didn't have them turned on until the middle of this madness, but attached regardless.

I wan't to test if the LMS HS3 PI plug-in is causing these problems so I would like to un-install the HS3 plug-in and only use Sqeezebox players to access the LMS server. How do I un-install this plug in?
Attached Images
 
Attached Files
File Type: zip Logs.zip (1.03 MB, 0 views)
Reply With Quote
  #184  
Old March 13th, 2018, 06:17 PM
ServiceXp's Avatar
ServiceXp ServiceXp is offline
Seer Master
 
Join Date: May 2015
Location: USA
Posts: 826
Came home today to discover I could not play music again. I cleaned the system from all related software and reinstalled LMS and CB only.

I grabbed a brief log set before I started.
Attached Files
File Type: zip Logs.zip (8.8 KB, 0 views)
Reply With Quote
  #185  
Old March 13th, 2018, 08:54 PM
pcp pcp is offline
Super Seer
 
Join Date: Jan 2006
Location: MA
Posts: 1,686
Have you tried a LMS / Squeezebox player (physical or software player such as squeezeplay, softsqueeze, etc) without the additional Chromcast bridge? I am not familiar with that plugin / bridge and how well it does work. But I would dissocate them. Any playing does not involve the HS3 squeezebox plugin, only LMS aserver and the players you areusing.

Also ensure you do not have multiple HS3 speak proxies (typically via media plugins) configured and enabled as that could be a reason for duplicate TTS (as both speech proxy servers ould acknnowledge to play the TTS).

You can disable the squeezebox plugin and (from the HS3 page) and when disabled will not start the process and interact with LMS.
Reply With Quote
  #186  
Old March 14th, 2018, 06:36 AM
ServiceXp's Avatar
ServiceXp ServiceXp is offline
Seer Master
 
Join Date: May 2015
Location: USA
Posts: 826
Quote:
Originally Posted by pcp View Post
Have you tried a LMS / Squeezebox player (physical or software player such as squeezeplay, softsqueeze, etc) without the additional Chromcast bridge? I am not familiar with that plugin / bridge and how well it does work. But I would dissocate them. Any playing does not involve the HS3 squeezebox plugin, only LMS aserver and the players you areusing.

Also ensure you do not have multiple HS3 speak proxies (typically via media plugins) configured and enabled as that could be a reason for duplicate TTS (as both speech proxy servers ould acknnowledge to play the TTS).

You can disable the squeezebox plugin and (from the HS3 page) and when disabled will not start the process and interact with LMS.
Oh I thought you were the one who created the Chromecast Bridge LMS PI? What are the odds you would have the same name..

I didn't get a chance to thoroughly check a PC player before ripping everything off the system.

I don't have any detectable proxy installed. I did have Spuds Chromecast PI installed, but removed it.

The LMS and CB is still working this morning. I think I'm going to let this ride for a few days to see how it goes before re-introducing your HS3 SqueezeBox PI.

I will assume, considering the instructions say's too, I need to install the LMS SB PI after I install the HS3 SB PI?

I have a feeling that when I introduce this PI to the mix, everything goes sideways. Perhaps this plug-in is not compatible with LMS + CB..???

Any way thanks for help. I'll report back on my progress.
Reply With Quote
  #187  
Old March 15th, 2018, 12:08 AM
pcp pcp is offline
Super Seer
 
Join Date: Jan 2006
Location: MA
Posts: 1,686
Quote:
Originally Posted by ServiceXp View Post
Oh I thought you were the one who created the Chromecast Bridge LMS PI?
I am not the one who created the Chromecast Bridge LMS plugin and never used it (nor any need for it).
Reply With Quote
  #188  
Old March 15th, 2018, 06:11 AM
ServiceXp's Avatar
ServiceXp ServiceXp is offline
Seer Master
 
Join Date: May 2015
Location: USA
Posts: 826
Quote:
Originally Posted by pcp View Post
I am not the one who created the Chromecast Bridge LMS plugin and never used it (nor any need for it).
My apologizes; that's what I get for assuming..
Reply With Quote
  #189  
Old March 15th, 2018, 08:37 AM
Pete's Avatar
Pete Pete is offline
OverSeer
 
Join Date: Jan 2001
Location: House
Posts: 15,296
Yeah when you asked about Chromecast / LMS a couple of weeks back I just googled it and found the link you utilized for your Chromecast stuff.

See a lively GitHub called LMS-to-Cast here ===> philippe44/LMS-to-Cast

Personally keep my LMS / Squeezeplayers configuration very simple.

Mentioned also that I use custom Openpeak tablets for my Squeezeplayer as they are availble on Ebay for little as $10 these days (mentioned $35 in my previous post). It is very easy to convert these tabletop tablets to Squeezeplayers these days...you write the OS to a USB stick and boot up with the USB stick and a script writes the OS to the built in eMMC on the tablets. Takes about 5 minutes to write the OS.
__________________
- Pete

Automator

HS3 Pro & Lite Edition Beta 3.0.0.435

HS3 Wintel Touch | Ubuntu 16.04 64 bit | Oracle Windows Virtual Box ==> for Wintel only SAPI and HS3 plugins | Speech - Microsoft SAPI - Neospeech - Amazon Echo | Hardware | Haswell Intel iSeries 3 - 16Gb | Pine64 - 2Gb computers | Openpeak Intel Atom SoC tabletop touchscreens (15 HS tabletop tablets) | Touchscreens - Windows embedded POE connected |Light switches - X10,UPB, ZWave and Zigbee | Firewall - PFSense - 2 WAN plus 4 LAN interfaces | Network - Gb managed switches / POE WAP(s) | CCTV - Zoneminder IPHD cams - variety | Audio - Russound - AB8SS | Security - Leviton HAI Omni Pro 2 | Weather - Davis Vantage Vue - MeteoStick - WeeWx | 1-Wire - AAG, Midon and HB | OWFS - Mosquitto - Node Red - Python - RPi Stretch - OpenWRT
Reply With Quote
  #190  
Old March 17th, 2018, 07:11 PM
ServiceXp's Avatar
ServiceXp ServiceXp is offline
Seer Master
 
Join Date: May 2015
Location: USA
Posts: 826
So I took the plunge and re-installed the PI today.. It seams to be working much better this time around.

These are my findings:

1) Mute / Unmute does not work with Chromecast Audio Players.
2) Speech does not work reliably (double speak) and often times crashes plug-in.
3) The 'TTS Voice' entry is ignored, and system voice is used.
4) Often the HS3 devices become 'disconnected' from LMS and will not update. The interesting thing is Start/Stop/Pause seem to work (not updated but will function)

I'm guessing these issues are incompatibilities with the Chromecast Bridge PI.

Logs Attached.
Attached Files
File Type: zip hspi_squeezebox_debug.zip (181.3 KB, 0 views)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 09:31 PM.


Copyright HomeSeer Technologies, LLC