www.homeseer.com    
 

Go Back   HomeSeer Message Board > 3rd Party Plug-Ins/Scripts > Plug-ins by Author > Click Here for List of Author Forums > Spud Plug-Ins > Ecobee (3P)

Ecobee (3P) Discussions related to the Ecobee plugin by Spud

Reply
 
Thread Tools Display Modes
  #1  
Old November 10th, 2017, 03:53 PM
beerguy beerguy is offline
Seer Deluxe
 
Join Date: Dec 2005
Posts: 182
Error installing on Linux (Homeseer SEL)

Hi Spud -
Thanks for writing this plugin for Ecobee. I'm excited to get it set up. I tried installing from the HS Installer and get the following error:

Nov-10 11:07:23 AM Error Error, Creating plugin instance: HSPI_Ecobee.exe->Exception has been thrown by the target of an invocation.->HSPI_Ecobee.EcobeeApp
Nov-10 11:07:22 AM Updater Install/Update of package Ecobee was successful.
Nov-10 11:07:22 AM Updater Warning File exists, not overwriting: \usr\local\HomeSeer\Config\\Ecobee.ini

I've read through the forums and found your note about needing to move a couple of files, but that likely that was fixed in newer systems. Mine is a brand new HS SEL and I can confirm that the files are already located in the directory that you specified.

Any other ideas on what I might do to get this working?

Thanks,

Pat
Reply With Quote
  #2  
Old November 10th, 2017, 04:00 PM
spud's Avatar
spud spud is offline
Moderator
 
Join Date: Jan 2012
Location: Canada
Posts: 5,074
what version of mono your SEL is running?

from the command line try the following to get more information on the problem:

Code:
sudo mono HSPI_Ecobee.exe
Reply With Quote
  #3  
Old November 10th, 2017, 04:15 PM
beerguy beerguy is offline
Seer Deluxe
 
Join Date: Dec 2005
Posts: 182
It also throws an error when I try to run that command:
Attached Images
 
Reply With Quote
  #4  
Old November 10th, 2017, 05:15 PM
spud's Avatar
spud spud is offline
Moderator
 
Join Date: Jan 2012
Location: Canada
Posts: 5,074
what's the mono version:

Code:
mono --version
Reply With Quote
  #5  
Old November 10th, 2017, 06:02 PM
beerguy beerguy is offline
Seer Deluxe
 
Join Date: Dec 2005
Posts: 182
homeseer@hometrollerSEL:/usr/local/HomeSeer$ mono --version
Mono JIT compiler version 5.0.1.1 (2017-02/5077205 Thu May 25 09:18:45 UTC 2017)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
TLS: __thread
SIGSEGV: altstack
Notifications: epoll
Architecture: x86
Disabled: none
Misc: softdebug
LLVM: supported, not enabled.
GC: sgen (concurrent by default)
homeseer@hometrollerSEL:/usr/local/HomeSeer$ Mono JIT compiler version 5.0.1.1 (2017-02/5077205 Thu May 25 09:18:45 UTC 2017)
Reply With Quote
  #6  
Old November 12th, 2017, 05:49 PM
spud's Avatar
spud spud is offline
Moderator
 
Join Date: Jan 2012
Location: Canada
Posts: 5,074
I installed mono 5. on a Ubuntu machine, but I'm still unable to reproduce this problem.

Could you run the following command and post the output here

Code:
sudo MONO_LOG_LEVEL=debug mono HSPI_Ecobee.exe
Reply With Quote
  #7  
Old November 12th, 2017, 06:13 PM
beerguy beerguy is offline
Seer Deluxe
 
Join Date: Dec 2005
Posts: 182
Thanks again for all of your help with this. Sorry for the hassle. Here is the output from the operation:


Welcome to Ubuntu 14.04.1 LTS (GNU/Linux 3.16.0-031600-generic i686)

* Documentation: https://help.ubuntu.com/

homeseer@hometrollerSEL:/$ cd usr/local/HomeSeer
homeseer@hometrollerSEL:/usr/local/HomeSeer$ sudo Mono_Log_Level=debug mono HSPI_Ecobee.exe
[sudo] password for homeseer:

Unhandled Exception:
System.TypeLoadException: Could not load type of field 'HSPI_Ecobee.EcobeeApp:m_ ecobeeApi' (20) due to: Could not load file or assembly 'System.Runtime, Version =4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its depend encies. assembly:System.Runtime, Version=4.0.0.0, Culture=neutral, PublicKeyToke n=b03f5f7f11d50a3a type:<unknown type> member:<none>
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeLoadException: Could not load type of field 'HSPI_Ecobee.EcobeeApp:m_ecobeeApi' (20) due to: Could not load file o r assembly 'System.Runtime, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03 f5f7f11d50a3a' or one of its dependencies. assembly:System.Runtime, Version=4.0. 0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a type:<unknown type> member :<none>
homeseer@hometrollerSEL:/usr/local/HomeSeer$
Reply With Quote
  #8  
Old November 12th, 2017, 06:29 PM
spud's Avatar
spud spud is offline
Moderator
 
Join Date: Jan 2012
Location: Canada
Posts: 5,074
thanks, but Mono_Log_Level needs to be upper case MONO_LOG_LEVEL, please run it again
Reply With Quote
  #9  
Old November 12th, 2017, 06:37 PM
beerguy beerguy is offline
Seer Deluxe
 
Join Date: Dec 2005
Posts: 182
Sorry about that. Here it is. Some of the spacing got screwy on the copy/paste from putty but on the screen it looks correct without some of the big gaps that are shown below:

login as: homeseer
homeseer@10.0.1.147's password:
Welcome to Ubuntu 14.04.1 LTS (GNU/Linux 3.16.0-031600-generic i686)

* Documentation: https://help.ubuntu.com/

Last login: Sun Nov 12 14:10:15 2017 from 192.168.3.30

homeseer@hometrollerSEL:/usr/local/HomeSeer$ sudo MONO_LOG_LEVEL=debug mono HSPI_Ecobee.exe
[sudo] password for homeseer:
Mono: Config attempting to parse: '/etc/mono/config'.
Mono: Config attempting to parse: '/home/homeseer/.mono/config'.
Mono: process_set_name: using [HSPI_Ecobee.exe] as prog name
Mono: mono_w32handle_new: create Process handle 0x400
Mono: Assembly Loader probing location: '/usr/lib/mono/4.5/mscorlib.dll'.
Mono: Image addref mscorlib[0x976a9d8] -> /usr/lib/mono/4.5/mscorlib.dll[0x976a0 30]: 2
Mono: Prepared to set up assembly 'mscorlib' (/usr/lib/mono/4.5/mscorlib.dll)
Mono: AOT: image '/usr/lib/mono/4.5/mscorlib.dll.so' not found: /usr/lib/mono/4. 5/mscorlib.dll.so: cannot open shared object file: No such file or directory
Mono: Assembly Loader probing location: '/usr/lib/mono/4.5/mscorlib.dll'.
Mono: AOT: image '(null)' found.
Mono: Assembly Loader loaded assembly from location: '/usr/lib/mono/4.5/mscorlib .dll'.
Mono: Config attempting to parse: '/usr/lib/mono/4.5/mscorlib.dll.config'.
Mono: Config attempting to parse: '/etc/mono/assemblies/mscorlib/mscorlib.config '.
Mono: AOT: FOUND method System.OutOfMemoryException:.ctor (string) [0xb538f740 - 0xb538f778 0xb574c42f]
Mono: AOT NOT FOUND: (wrapper runtime-invoke) <Module>:runtime_invoke_void__this ___object (object,intptr,intptr,intptr).
Mono: AOT: FOUND method System.Exception:.cctor () [0xb5383ba0 - 0xb5383be0 0xb5 74be7d]
Mono: AOT NOT FOUND: (wrapper runtime-invoke) object:runtime_invoke_void (object ,intptr,intptr,intptr).
Mono: AOT NOT FOUND: (wrapper alloc) object:AllocSmall (intptr,intptr).
Mono: AOT: FOUND method System.Exception:Init () [0xb5382200 - 0xb5382267 0xb574 bcf8]
Mono: AOT NOT FOUND: (wrapper write-barrier) object:wbarrier_conc (intptr).
Mono: AOT: FOUND method System.NullReferenceException:.ctor (string) [0xb538b690 - 0xb538b6c8 0xb574c365]
Mono: AOT: FOUND method System.StackOverflowException:.ctor (string) [0xb5391ca0 - 0xb5391cd8 0xb574c572]
Mono: Assembly mscorlib[0x976a9d8] added to domain HSPI_Ecobee.exe, ref_count=1
Mono: Assembly Loader probing location: 'HSPI_Ecobee.exe'.
Mono: Image addref HSPI_Ecobee[0x97d8a30] -> /usr/local/HomeSeer/HSPI_Ecobee.exe [0x97d7c98]: 2
Mono: Prepared to set up assembly 'HSPI_Ecobee' (/usr/local/HomeSeer/HSPI_Ecobee .exe)
Mono: Assembly HSPI_Ecobee[0x97d8a30] added to domain HSPI_Ecobee.exe, ref_count =1
Mono: AOT: image '/usr/local/HomeSeer/HSPI_Ecobee.exe.so' not found: /usr/local/ HomeSeer/HSPI_Ecobee.exe.so: cannot open shared object file: No such file or dir ectory
Mono: AOT: image '/usr/lib/mono/aot-cache/x86/HSPI_Ecobee.exe.so' not found: /us r/lib/mono/aot-cache/x86/HSPI_Ecobee.exe.so: cannot open shared object file: No such file or directory
Mono: Assembly Loader loaded assembly from location: 'HSPI_Ecobee.exe'.
Mono: Config attempting to parse: '/usr/local/HomeSeer/HSPI_Ecobee.exe.config'.
Mono: Config attempting to parse: '/etc/mono/assemblies/HSPI_Ecobee/HSPI_Ecobee. config'.
Mono: Assembly Loader probing location: 'HSPI_Ecobee.exe'.
Mono: AOT: image '/usr/local/HomeSeer/HSPI_Ecobee.exe.so' not found: /usr/local/ HomeSeer/HSPI_Ecobee.exe.so: cannot open shared object file: No such file or dir ectory
Mono: AOT: image '/usr/lib/mono/aot-cache/x86/HSPI_Ecobee.exe.so' not found: /us r/lib/mono/aot-cache/x86/HSPI_Ecobee.exe.so: cannot open shared object file: No such file or directory
Mono: Assembly Ref addref HSPI_Ecobee[0x97d8a30] -> mscorlib[0x976a9d8]: 2
Mono: Assembly Loader probing location: '/usr/local/HomeSeer/HSCF.dll'.
Mono: Image addref HSCF[0x97e09f0] -> /usr/local/HomeSeer/HSCF.dll[0x97dfe98]: 2
Mono: Prepared to set up assembly 'HSCF' (/usr/local/HomeSeer/HSCF.dll)
Mono: Assembly HSCF[0x97e09f0] added to domain HSPI_Ecobee.exe, ref_count=1
Mono: AOT: image '/usr/local/HomeSeer/HSCF.dll.so' not found: /usr/local/HomeSee r/HSCF.dll.so: cannot open shared object file: No such file or directory
Mono: AOT: image '/usr/lib/mono/aot-cache/x86/HSCF.dll.so' not found: /usr/lib/m ono/aot-cache/x86/HSCF.dll.so: cannot open shared object file: No such file or d irectory
Mono: Assembly Loader loaded assembly from location: '/usr/local/HomeSeer/HSCF.d ll'.
Mono: Config attempting to parse: '/usr/local/HomeSeer/HSCF.dll.config'.
Mono: Config attempting to parse: '/etc/mono/assemblies/HSCF/HSCF.config'.
Mono: Assembly Ref addref HSPI_Ecobee[0x97d8a30] -> HSCF[0x97e09f0]: 2
Mono: Assembly Ref addref HSCF[0x97e09f0] -> mscorlib[0x976a9d8]: 3
Mono: Assembly Loader probing location: '/usr/local/HomeSeer/HomeSeerAPI.dll'.
Mono: Image addref HomeSeerAPI[0x97e29c8] -> /usr/local/HomeSeer/HomeSeerAPI.dll [0x97e1e18]: 2
Mono: Prepared to set up assembly 'HomeSeerAPI' (/usr/local/HomeSeer/HomeSeerAPI .dll)
Mono: Assembly HomeSeerAPI[0x97e29c8] added to domain HSPI_Ecobee.exe, ref_count =1
Mono: AOT: image '/usr/local/HomeSeer/HomeSeerAPI.dll.so' not found: /usr/local/ HomeSeer/HomeSeerAPI.dll.so: cannot open shared object file: No such file or dir ectory
Mono: AOT: image '/usr/lib/mono/aot-cache/x86/HomeSeerAPI.dll.so' not found: /us r/lib/mono/aot-cache/x86/HomeSeerAPI.dll.so: cannot open shared object file: No such file or directory
Mono: Assembly Loader loaded assembly from location: '/usr/local/HomeSeer/HomeSe erAPI.dll'.
Mono: Config attempting to parse: '/usr/local/HomeSeer/HomeSeerAPI.dll.config'.
Mono: Config attempting to parse: '/etc/mono/assemblies/HomeSeerAPI/HomeSeerAPI. config'.
Mono: Assembly Ref addref HSPI_Ecobee[0x97d8a30] -> HomeSeerAPI[0x97e29c8]: 2
Mono: Assembly Ref addref HomeSeerAPI[0x97e29c8] -> mscorlib[0x976a9d8]: 4
Mono: Found assembly remapping for System and was for the same version 4.0.0.0
Mono: Config attempting to parse: '/usr/local/HomeSeer/HSPI_Ecobee.exe.config'.
Mono: Found assembly remapping for System and was for the same version 4.0.0.0
Mono: Assembly Loader probing location: '/usr/lib/mono/gac/System/4.0.0.0__b77a5 c561934e089/System.dll'.
Mono: Image addref System[0x97ecb78] -> /usr/lib/mono/gac/System/4.0.0.0__b77a5c 561934e089/System.dll[0x97ec130]: 2
Mono: Prepared to set up assembly 'System' (/usr/lib/mono/gac/System/4.0.0.0__b7 7a5c561934e089/System.dll)
Mono: Assembly System[0x97ecb78] added to domain HSPI_Ecobee.exe, ref_count=1
Mono: AOT: image '/usr/lib/mono/gac/System/4.0.0.0__b77a5c561934e089/System.dll. so' not found: /usr/lib/mono/gac/System/4.0.0.0__b77a5c561934e089/System.dll.so: cannot open shared object file: No such file or directory
Mono: AOT: image '/usr/lib/mono/aot-cache/x86/System.dll.so' not found: /usr/lib /mono/aot-cache/x86/System.dll.so: cannot open shared object file: No such file or directory
Mono: Assembly Loader loaded assembly from location: '/usr/lib/mono/gac/System/4 .0.0.0__b77a5c561934e089/System.dll'.
Mono: Config attempting to parse: '/usr/lib/mono/gac/System/4.0.0.0__b77a5c56193 4e089/System.dll.config'.
Mono: Config attempting to parse: '/etc/mono/assemblies/System/System.config'.
Mono: Assembly Ref addref HSPI_Ecobee[0x97d8a30] -> System[0x97ecb78]: 2
Mono: Assembly Ref addref System[0x97ecb78] -> mscorlib[0x976a9d8]: 5
Mono: Found assembly remapping for System and was for the same version 4.0.0.0
Mono: Found assembly remapping for System and was for the same version 4.0.0.0
Mono: Assembly Ref addref HomeSeerAPI[0x97e29c8] -> System[0x97ecb78]: 3
Mono: Assembly Loader probing location: '/usr/local/HomeSeer/Scheduler.dll'.
Mono: Image addref Scheduler[0x97f6dc8] -> /usr/local/HomeSeer/Scheduler.dll[0x9 7f6268]: 2
Mono: Prepared to set up assembly 'Scheduler' (/usr/local/HomeSeer/Scheduler.dll )
Mono: Assembly Scheduler[0x97f6dc8] added to domain HSPI_Ecobee.exe, ref_count=1
Mono: AOT: image '/usr/local/HomeSeer/Scheduler.dll.so' not found: /usr/local/Ho meSeer/Scheduler.dll.so: cannot open shared object file: No such file or directo ry
Mono: AOT: image '/usr/lib/mono/aot-cache/x86/Scheduler.dll.so' not found: /usr/ lib/mono/aot-cache/x86/Scheduler.dll.so: cannot open shared object file: No such file or directory
Mono: Assembly Loader loaded assembly from location: '/usr/local/HomeSeer/Schedu ler.dll'.
Mono: Config attempting to parse: '/usr/local/HomeSeer/Scheduler.dll.config'.
Mono: Config attempting to parse: '/etc/mono/assemblies/Scheduler/Scheduler.conf ig'.
Mono: Assembly Ref addref HSPI_Ecobee[0x97d8a30] -> Scheduler[0x97f6dc8]: 2
Mono: Assembly Ref addref Scheduler[0x97f6dc8] -> mscorlib[0x976a9d8]: 6
Mono: Assembly Loader probing location: '/usr/local/HomeSeer/bin/Ecobee/Ecobee.N et.dll'.
Mono: Image addref Ecobee.Net[0x97f96b0] -> /usr/local/HomeSeer/bin/Ecobee/Ecobe e.Net.dll[0x97f8ad8]: 2
Mono: Prepared to set up assembly 'Ecobee.Net' (/usr/local/HomeSeer/bin/Ecobee/E cobee.Net.dll)
Mono: Assembly Ecobee.Net[0x97f96b0] added to domain HSPI_Ecobee.exe, ref_count= 1
Mono: AOT: image '/usr/local/HomeSeer/bin/Ecobee/Ecobee.Net.dll.so' not found: / usr/local/HomeSeer/bin/Ecobee/Ecobee.Net.dll.so: cannot open shared object file: No such file or directory
Mono: AOT: image '/usr/lib/mono/aot-cache/x86/Ecobee.Net.dll.so' not found: /usr /lib/mono/aot-cache/x86/Ecobee.Net.dll.so: cannot open shared object file: No su ch file or directory
Mono: Assembly Loader loaded assembly from location: '/usr/local/HomeSeer/bin/Ec obee/Ecobee.Net.dll'.
Mono: Config attempting to parse: '/usr/local/HomeSeer/bin/Ecobee/Ecobee.Net.dll .config'.
Mono: Config attempting to parse: '/etc/mono/assemblies/Ecobee.Net/Ecobee.Net.co nfig'.
Mono: Assembly Ref addref HSPI_Ecobee[0x97d8a30] -> Ecobee.Net[0x97f96b0]: 2
Mono: Assembly Loader probing location: '/usr/lib/mono/gac/System.Runtime/4.0.0. 0__b03f5f7f11d50a3a/System.Runtime.dll'.
Mono: Assembly Loader probing location: '/usr/lib/System.Runtime.dll'.
Mono: Assembly Loader probing location: '/usr/lib/mono/4.5//Facades/System.Runti me.dll'.
Mono: Assembly Loader probing location: '/usr/lib/mono/gac/System.Runtime/4.0.0. 0__b03f5f7f11d50a3a/System.Runtime.exe'.
Mono: Assembly Loader probing location: '/usr/lib/System.Runtime.exe'.
Mono: Assembly Loader probing location: '/usr/lib/mono/4.5//Facades/System.Runti me.exe'.
Mono: AOT: FOUND method System.AppDomainoAssemblyResolve (string,System.Reflec tion.Assembly,bool) [0xb52df240 - 0xb52df529 0xb57478cc]
Mono: AOT NOT FOUND: (wrapper runtime-invoke) <Module>:runtime_invoke_object__th is___object_object_byte (object,intptr,intptr,intptr).
Mono: Assembly Loader probing location: '/usr/lib/mono/gac/System.Runtime/4.0.0. 0__b03f5f7f11d50a3a/System.Runtime.dll'.
Mono: Assembly Loader probing location: '/usr/local/HomeSeer/bin/Ecobee/System.R untime.dll'.
Mono: Assembly Loader probing location: '/usr/lib/System.Runtime.dll'.
Mono: Assembly Loader probing location: '/usr/lib/mono/4.5//Facades/System.Runti me.dll'.
Mono: Assembly Loader probing location: '/usr/lib/mono/gac/System.Runtime/4.0.0. 0__b03f5f7f11d50a3a/System.Runtime.exe'.
Mono: Assembly Loader probing location: '/usr/local/HomeSeer/bin/Ecobee/System.R untime.exe'.
Mono: Assembly Loader probing location: '/usr/lib/System.Runtime.exe'.
Mono: Assembly Loader probing location: '/usr/lib/mono/4.5//Facades/System.Runti me.exe'.
Mono: The following assembly referenced from /usr/local/HomeSeer/bin/Ecobee/Ecob ee.Net.dll could not be loaded:
Assembly: System.Runtime (assemblyref_index=0)
Version: 4.0.0.0
Public Key: b03f5f7f11d50a3a
The assembly was not found in the Global Assembly Cache, a path listed in the MO NO_PATH environment variable, or in the location of the executing assembly (/usr /local/HomeSeer/bin/Ecobee/).

Mono: Failed to load assembly Ecobee.Net[0x97f96b0].
Mono: AOT: FOUND method System.TypeLoadException:.ctor (string) [0xb5397620 - 0x b5397658 0xb574c8dc]
Mono: AOT: FOUND method System.Exception:ToString () [0xb5382e40 - 0xb5382e77 0x b574bdbd]
Mono: AOT NOT FOUND: (wrapper runtime-invoke) <Module>:runtime_invoke_object__th is__ (object,intptr,intptr,intptr).
Mono: AOT: FOUND method System.Exception:ToString (bool,bool) [0xb5382e80 - 0xb5 38306b 0xb574bdc2]
Mono: AOT: FOUND method System.TypeLoadException:get_Message () [0xb53976a0 - 0x b53976cd 0xb574c8e0]
Mono: AOT: FOUND method System.TypeLoadException:SetMessageField () [0xb53976d0 - 0xb53977bd 0xb574c8e2]
Mono: AOT: FOUND method System.RuntimeType:.cctor () [0xb5341150 - 0xb53412c0 0x b5749b1d]
Mono: AOT: FOUND method System.RuntimeType:ToString () [0xb5339b00 - 0xb5339b37 0xb574978b]
Mono: AOT: NOT FOUND: System.RuntimeType:getFullName (bool,bool).
Mono: AOT NOT FOUND: (wrapper managed-to-native) System.RuntimeType:getFullName (System.RuntimeType,bool,bool).
Mono: AOT: FOUND method string:memset (byte*,int,int) [0xb5343e00 - 0xb5343f40 0 xb5749ba1]
Mono: AOT: FOUND method string:Concat (string,string,string) [0xb534ba40 - 0xb53 4bb2a 0xb5749d7b]
Mono: AOT: NOT FOUND: string:FastAllocateString (int).
Mono: AOT NOT FOUND: (wrapper managed-to-native) string:FastAllocateString (int) .

Unhandled Exception:
System.TypeLoadException: Could not load type of field 'HSPI_Ecobee.EcobeeApp:m_ ecobeeApi' (20) due to: Could not load file or assembly 'System.Runtime, Version =4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its depend encies. assembly:System.Runtime, Version=4.0.0.0, Culture=neutral, PublicKeyToke n=b03f5f7f11d50a3a type:<unknown type> member:<none>
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeLoadException: Could not load type of field 'HSPI_Ecobee.EcobeeApp:m_ecobeeApi' (20) due to: Could not load file o r assembly 'System.Runtime, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03 f5f7f11d50a3a' or one of its dependencies. assembly:System.Runtime, Version=4.0. 0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a type:<unknown type> member :<none>
homeseer@hometrollerSEL:/usr/local/HomeSeer$
Reply With Quote
  #10  
Old November 13th, 2017, 08:31 AM
spud's Avatar
spud spud is offline
Moderator
 
Join Date: Jan 2012
Location: Canada
Posts: 5,074
please try to install the mono-devel package

Code:
sudo apt-get install mono-devel
Reply With Quote
  #11  
Old November 17th, 2017, 03:40 AM
beerguy beerguy is offline
Seer Deluxe
 
Join Date: Dec 2005
Posts: 182
Hi spud -
I tried to install per your instructions and got the following:

homeseer@hometrollerSEL:~$ sudo apt-get install mono-devel
[sudo] password for homeseer:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
mono-devel : Depends: libglib2.0-0 (>= 2.40.2) but 2.40.0-2 is to be installed
Recommends: referenceassemblies-pcl but it is not going to be installed
Recommends: msbuild but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
homeseer@hometrollerSEL:~$


I should mention that this is a completely "stock" Homeseer SEL so it seems odd that we'd have to go to this much work to make this plug-in work. Are other people with an SEL having these kinds of problems?

Thanks again for your help.

Pat
Reply With Quote
  #12  
Old November 18th, 2017, 03:09 PM
spud's Avatar
spud spud is offline
Moderator
 
Join Date: Jan 2012
Location: Canada
Posts: 5,074
It used to work out of the box on older SEL, but the newest ones don't have the package mono-devel preinstalled by default which is needed for the Ecobee plugin (as well as several other of my plugins)

Unfortunately the manual installation of the package seem to fail as per the error you got. So I asked HST how to fix that and they should get back to me soon. I will let you know as soon as I have a solution.

FYI you are the second user to report this problem with the SEL.

Thanks for your patience.
Reply With Quote
  #13  
Old December 8th, 2017, 03:10 PM
beerguy beerguy is offline
Seer Deluxe
 
Join Date: Dec 2005
Posts: 182
Hi Spud -
Just checking in to see if there's been any resolution to this issue.

Thanks again for the help.

Pat
Reply With Quote
  #14  
Old December 8th, 2017, 03:22 PM
spud's Avatar
spud spud is offline
Moderator
 
Join Date: Jan 2012
Location: Canada
Posts: 5,074
Quote:
Originally Posted by beerguy View Post
Hi Spud -
Just checking in to see if there's been any resolution to this issue.

Thanks again for the help.

Pat
I've just asked again the HS dev responsible for this, he said he's hoping to get to it next week...

sorry that it takes so long.
Reply With Quote
  #15  
Old January 9th, 2018, 11:20 AM
thejtdude thejtdude is offline
Viewer
 
Join Date: Jan 2018
Location: Northeast
Posts: 3
+1

I am experiencing this issue on my new HomeTroller-SEL as well.
Reply With Quote
  #16  
Old January 25th, 2018, 07:15 PM
thejtdude thejtdude is offline
Viewer
 
Join Date: Jan 2018
Location: Northeast
Posts: 3
Any update on this? I have been searching for alternative solutions to this but cannot find any. My trial for this plugin expires in 7 days and I would love to get this plugin to work.

Thanks in advance.
Reply With Quote
  #17  
Old January 29th, 2018, 12:39 PM
spud's Avatar
spud spud is offline
Moderator
 
Join Date: Jan 2012
Location: Canada
Posts: 5,074
Quote:
Originally Posted by thejtdude View Post
Any update on this? I have been searching for alternative solutions to this but cannot find any. My trial for this plugin expires in 7 days and I would love to get this plugin to work.

Thanks in advance.
I asked the HST team, they said they are building a new SEL image with the mono-complete package installed, but they have not figure out a way to update existing units yet.

For my part, I'm going to investigate to see if I can build a version of the Ecobee plugin that would not need the mono-complete package to be installed but I think this is going to be difficult.
Reply With Quote
  #18  
Old January 30th, 2018, 05:31 PM
spud's Avatar
spud spud is offline
Moderator
 
Join Date: Jan 2012
Location: Canada
Posts: 5,074
I changed a few things in version 3.0.0.22 attached, and I'm now able to run this version on Linux without the mono-devel package.

Could you try it and let me know? Thanks
Attached Files
File Type: zip Ecobee_3-0-0-22.zip (422.5 KB, 5 views)
File Type: txt updater_override.txt (3.1 KB, 8 views)
Reply With Quote
  #19  
Old January 30th, 2018, 06:45 PM
beerguy beerguy is offline
Seer Deluxe
 
Join Date: Dec 2005
Posts: 182
Hi Spud -
Thanks for making the changes. I can move the files into place but not sure where they go. Update3 directory? Or do they each go into the specific directory called out in the install.txt file? And do I need to delete the other Ecobee files from the old version that wasn't installed properly?

Thanks,

Pat
Reply With Quote
  #20  
Old January 30th, 2018, 06:53 PM
spud's Avatar
spud spud is offline
Moderator
 
Join Date: Jan 2012
Location: Canada
Posts: 5,074
Quote:
Originally Posted by beerguy View Post
Hi Spud -
Thanks for making the changes. I can move the files into place but not sure where they go. Update3 directory? Or do they each go into the specific directory called out in the install.txt file? And do I need to delete the other Ecobee files from the old version that wasn't installed properly?

Thanks,

Pat
sorry, the installation steps are here: https://forums.homeseer.com/showthread.php?t=177451

you don't need to delete anything
the zip goes in Updates3/Zips
and the updater_override.txt file goes in the HS3 root folder
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help installing xAP on Linux philipi xAP Discussions 2 September 14th, 2016 03:29 AM
Installing HS3Pro Linux on official HS3Pi2 System JasonCreager HS3-Pi Discussion 8 August 17th, 2015 07:53 AM
Re installing Homeseer afmiller HS2 / HSPRO 2 March 10th, 2013 05:28 PM
Installing error: Knocks out the sageTV error Moskus InControl Windows Store / Windows Phone 3 March 18th, 2012 04:00 AM
Re-installing Homeseer. Phill HomeSeer General Discussion Area 1 October 19th, 2006 04:08 AM


All times are GMT -4. The time now is 09:43 AM.


Copyright HomeSeer Technologies, LLC