www.homeseer.com    
 

Go Back   HomeSeer Message Board > 3rd Party Plug-Ins/Scripts > Plug-ins by Author > Click Here for List of Author Forums > Spud Plug-Ins > Ecobee (3P)

Ecobee (3P) Discussions related to the Ecobee plugin by Spud

Reply
 
Thread Tools Display Modes
  #1  
Old July 6th, 2017, 07:04 PM
chuckk9032 chuckk9032 is offline
Seer Deluxe
 
Join Date: Jan 2008
Location: Northern California
Posts: 143
Ecobee Disconnecting After Installation - Functionality Lost

Ecobee PI has been working fine until I ran an update today to 3.0.0.18. It installed, but disconnects and throws off errors. Here is the log from installation. Running HS3 3.0.0.318 on Windows server. FYI, another PI, Blue Iris, also had problems at the same time after updating, but I've tried others and they are fine. Could really use some help.

Jul-06 3:58:14 PM
*
*
Error
Initializing plug-in(2): Ecobee Instance::Object reference not set to an instance of an object.STACK: at System.Runtime.Remoting.Messaging.LogicalCallContext.Propaga teIncomingHeadersToCallContext(IMessage msg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type) at HomeSeerAPI.IPlugInAPI.SupportsMultipleInstances() at Scheduler.clsHSPI.CheckInterfaces()
Jul-06 3:55:33 PM
*
Info
Plugin Ecobee with instance: has disconnected
Jul-06 3:55:33 PM
*
Ecobee
INFO Ecobee version 3.0.0.18
Jul-06 3:55:33 PM
*
Info
Plugin Ecobee has connected. IP:127.0.0.1:54238
Jul-06 3:55:33 PM
*
Warning
I/O interface Ecobee is down, executable is not running, restarting ...
Jul-06 3:55:03 PM
*
Info
Plugin Ecobee with instance: has disconnected
Jul-06 3:55:03 PM
*
Ecobee
INFO Ecobee version 3.0.0.18
Jul-06 3:55:03 PM
*
Info
Plugin Ecobee has connected. IP:127.0.0.1:54048
Jul-06 3:55:03 PM
*
Warning
I/O interface Ecobee is down, executable is not running, restarting ...
Jul-06 3:54:54 PM
*
Warning
In InitSingleIOPlugin: Object reference not set to an instance of an object.
Jul-06 3:54:54 PM
*
Updater
Re-initializing plugin after update.
Jul-06 3:54:54 PM
*
Updater
Install/Update of package Ecobee was successful.
Jul-06 3:54:54 PM
*
Updater
Copying file: C:\Program Files (x86)\HomeSeer HS3\Config\\Ecobee.ini
Jul-06 3:54:54 PM
*
Updater
Extraction Complete.
Jul-06 3:54:54 PM
*
Updater
Extracting files from zip file: images.zip
Jul-06 3:54:54 PM
*
Updater
Copying file: C:\Program Files (x86)\HomeSeer HS3\bin\Ecobee\System.Time.dll
Jul-06 3:54:54 PM
*
Updater
Copying file: C:\Program Files (x86)\HomeSeer HS3\bin\Ecobee\Ecobee.Net.dll
Jul-06 3:54:54 PM
*
Updater
Copying file: C:\Program Files (x86)\HomeSeer HS3\bin\Ecobee\Newtonsoft.Json.dll
Jul-06 3:54:54 PM
*
Updater
Making dir: C:\Program Files (x86)\HomeSeer HS3\bin\Ecobee\
Jul-06 3:54:54 PM
*
Updater
Copying file: C:\Program Files (x86)\HomeSeer HS3\HSPI_Ecobee.exe.config
Jul-06 3:54:54 PM
*
Updater
Copying file: C:\Program Files (x86)\HomeSeer HS3\HSPI_Ecobee.exe
Jul-06 3:54:53 PM
*
Updater
Installing package Ecobee
Jul-06 3:54:53 PM
*
Updater
Update HSPI_Ecobee.exe downloaded successfully
Jul-06 3:54:53 PM
*
Updater
Downloading update: Ecobee
__________________
HS3 Pro Edition 3.0.0.423 (Windows)

Plug-Ins Enabled:
Device History:,BLShutdown:,PHLocation:,LutronCaseta:,EnvisaLink:,U ltraWeatherWU3:,BLOnkyo:,Restart:,UltraGCIR3:,MyQ:,SqueezeBo x:,BLBackup:,UltraMon3:,Sonos:,EasyTrigger:,BLLock:,DoorBird :,Blue-Iris:,BLLAN:,Z-Wave:,Ecobee:,ImperiHome:,UltraRachio3:
Reply With Quote
  #2  
Old July 6th, 2017, 09:31 PM
chuckk9032 chuckk9032 is offline
Seer Deluxe
 
Join Date: Jan 2008
Location: Northern California
Posts: 143
Update - I found this post from last December from Spud. This solved the problem. Thanks, Spud!

"You had a version of Newtonsoft.Json.dll in your HS3 dir that conflicts with the one used by the Ecobee plugin in bin/Ecobee

I renamed the one in your HS3 dir to Newtonsoft.Json.old, and it works now."
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ecobee Fan Status Bug jryanishere Ecobee (3P) 7 June 4th, 2016 06:15 PM
Disconnecting bigbrorpi Envisalink DSC Plugin (3P) 1 February 16th, 2014 12:11 PM
View Recents Lost Filtered Cam Display Functionality cbryan HomeSeer NetCam Plug-in 0 December 4th, 2010 07:26 PM
Not disconnecting from the web Tymon HSTouch™ 0 April 5th, 2009 02:14 PM
Totally bizarre installation - lost mkronmal SeerAMP (3P) 2 January 11th, 2007 02:10 PM


All times are GMT -4. The time now is 10:37 PM.


Copyright HomeSeer Technologies, LLC