www.homeseer.com    
 

Go Back   HomeSeer Message Board > 3rd Party Plug-Ins/Scripts > Plug-ins by Author > Click Here for List of Author Forums > Ultra Scripts and Plug-Ins > UltraRachio3 HSPI

UltraRachio3 HSPI Discussion area for the UltraRachio3 Irrigation Controller Plug-in

Reply
 
Thread Tools Display Modes
  #61  
Old April 24th, 2018, 07:56 PM
mminehan mminehan is offline
Seer Deluxe
 
Join Date: Jun 2011
Location: New Zealand
Posts: 366
For those of you having problems with controlling zones via the plugin (i.e. not being able to stop a zone etc) you might like to try the following. It's not perfect but an improvement on these issues.
  1. Disable the plugin from the 'manage plugins' list.
  2. Delete ALL the UltraRachio devices (zones, weather, root etc.)
  3. Go to the 'Config' folder in your HS3 directory and delete/rename the hspi_ultrarachio3.ini and hspi_ultrarachio3.ini.bak files.
  4. Enable the plugin and reconfigure (API token, units etc).
  5. Then restart HS3.

All going to plan you should now have rebuilt your UltraRachio devices. You will need to modify any events or scripts that use the UltraRachio devices.

I did this and it seems to working much better. I can now turn the zones off using the 'watering state' device. But using the 'zone control' to turn the zone off has no effect. Also if you use the app or web UI to control the zone the plugin does not change, even after waiting for the update interval set.

It's a real shame that this plugin is not working properly since Rachio update the API. It used to work perfectly. I'm very keen to help Ultra sort this out. Is it something to do with options maybe?

Mine are: units metric, update frequency 2 minutes, forecast today and tomorrow, device image yes.

I'd be interested to see what other people find after recreating the devices.

Marty.
__________________
iCore5 Win 10 Pro x64 SSD

HS3 Pro Edition 3.0.0.435 Windows

BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:
Reply With Quote
  #62  
Old April 27th, 2018, 10:04 AM
sgottscho sgottscho is offline
Seer
 
Join Date: Dec 2015
Location: Florida
Posts: 11
Quote:
Originally Posted by mminehan View Post
For those of you having problems with controlling zones via the plugin (i.e. not being able to stop a zone etc) you might like to try the following. It's not perfect but an improvement on these issues.
  1. Disable the plugin from the 'manage plugins' list.
  2. Delete ALL the UltraRachio devices (zones, weather, root etc.)
  3. Go to the 'Config' folder in your HS3 directory and delete/rename the hspi_ultrarachio3.ini and hspi_ultrarachio3.ini.bak files.
  4. Enable the plugin and reconfigure (API token, units etc).
  5. Then restart HS3.

All going to plan you should now have rebuilt your UltraRachio devices. You will need to modify any events or scripts that use the UltraRachio devices.

I did this and it seems to working much better. I can now turn the zones off using the 'watering state' device. But using the 'zone control' to turn the zone off has no effect. Also if you use the app or web UI to control the zone the plugin does not change, even after waiting for the update interval set.

It's a real shame that this plugin is not working properly since Rachio update the API. It used to work perfectly. I'm very keen to help Ultra sort this out. Is it something to do with options maybe?

Mine are: units metric, update frequency 2 minutes, forecast today and tomorrow, device image yes.

I'd be interested to see what other people find after recreating the devices.

Marty.
Tried all the suggestions zones still not able to be turned off from the zone control devices. Only from the watering state device.

Current Date/Time: 4/27/2018 10:01:52 AM
HomeSeer Version: HS3 Standard Edition 3.0.0.435
Operating System: Microsoft Windows 10 Pro - Work Station
System Uptime: 0 Days 7 Hours 16 Minutes 39 Seconds
IP Address: 10.1.0.123
Number of Devices: 338
Number of Events: 149
Available Threads: 800
HSTouch Enabled: True
Event Threads: 0
Event Trigger Eval Queue: 0
Event Trigger Priority Eval Queue: 0
Device Exec Queue: 0
HSTouch Event Queue: 0
Email Send Queue: 0
Anti Virus Installed: Windows Defender

Enabled Plug-Ins
1.0.3.0: BLShutdown
3.1.1.24385: Blue-Iris
2.0.22.0: BLUPS
3.0.0.46: EasyTrigger
3.0.0.33: iTunesDAAP
3.0.2.0: MeiHarmonyHub
0.0.0.38: Pushover 3P
1.0.0.7: Restart
30.0.0.36: RFXCOM
3.0.6554.33094: UltraMon3
3.0.6685.27970: UltraRachio3
3.0.0.83: weatherXML
3.0.1.190: Z-Wave
Reply With Quote
  #63  
Old April 28th, 2018, 08:54 AM
Ultrajones's Avatar
Ultrajones Ultrajones is offline
OverSeer
 
Join Date: Jan 2001
Location: Michigan, US
Posts: 5,746
Quote:
Originally Posted by sgottscho View Post
Tried all the suggestions zones still not able to be turned off from the zone control devices. Only from the watering state device.

Current Date/Time: 4/27/2018 10:01:52 AM
HomeSeer Version: HS3 Standard Edition 3.0.0.435
Operating System: Microsoft Windows 10 Pro - Work Station
System Uptime: 0 Days 7 Hours 16 Minutes 39 Seconds
IP Address: 10.1.0.123
Number of Devices: 338
Number of Events: 149
Available Threads: 800
HSTouch Enabled: True
Event Threads: 0
Event Trigger Eval Queue: 0
Event Trigger Priority Eval Queue: 0
Device Exec Queue: 0
HSTouch Event Queue: 0
Email Send Queue: 0
Anti Virus Installed: Windows Defender

Enabled Plug-Ins
1.0.3.0: BLShutdown
3.1.1.24385: Blue-Iris
2.0.22.0: BLUPS
3.0.0.46: EasyTrigger
3.0.0.33: iTunesDAAP
3.0.2.0: MeiHarmonyHub
0.0.0.38: Pushover 3P
1.0.0.7: Restart
30.0.0.36: RFXCOM
3.0.6554.33094: UltraMon3
3.0.6685.27970: UltraRachio3
3.0.0.83: weatherXML
3.0.1.190: Z-Wave
I noticed a similar issue, but wasn't sure the zone didn't turn off because my sprinklers are still winterized. I can turn the zones off and the API response from Rachio indicates it's off, but their app still indicates it is watering. Are you able to confirm your zone is on because it is still watering or are you using the Rachio App to tell you it's still watering?
__________________
Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR
Reply With Quote
  #64  
Old April 28th, 2018, 05:49 PM
mminehan mminehan is offline
Seer Deluxe
 
Join Date: Jun 2011
Location: New Zealand
Posts: 366
Quote:
Are you able to confirm your zone is on because it is still watering or are you using the Rachio App to tell you it's still watering?
I can confirm the physical zones correspond to the app/WebUI. If the WebUI indicates watering the zone is actually watering. Using the app/WebUI works as expected.

Using the plugin not so much:
change plugin 'zone control' to on -> zone starts watering and app/WebUI indicates zone is running
change plugin 'zone control' to off -> zone continues watering and app/WebUI continues to indicate zone is running
change plugin 'watering state' to stop watering -> zone stops watering and app/WebUI indicates zone off
use app/WebUI to turn a zone on -> zone starts watering but plugin remains in off/idle state -> change plugin 'watering state' to stop watering -> zone stops watering even though the plugin thinks the zone is already off

Hope this makes sense.

It seems to me there are two issues: 1) The 'zone control' device is not sending the stop watering command to Rachio, and 2) the plugin is not updating from Rachio when a zone changes, even after waiting for the API "Update Frequency" set time.

Could part of the problem be that changing the 'zone control' device to "Zone Off" changes the 'watering state' device to "Idle" but does not actually send the stop watering command to Rachio?

Also, the 'Last Watered' devices are not updating at all. Only the weather and API remaining/reset devices are updating regularly. No API Status failures by the way. It's almost like other than weather no information is coming back from Rachio.

I appreciate the effort you are putting into this. I can imagine it is a little frustrating. But anything I can do to help (debug logs, testing etc) let me know.

Marty.
Reply With Quote
  #65  
Old May 16th, 2018, 09:38 AM
cd-card-biz cd-card-biz is offline
Seer Deluxe
 
Join Date: Aug 2005
Posts: 152
New API - Resolved Yet?

I just installed a Rachio Gen 2 controller which I want to use with my ZEE v2.

Are the issues with the new Rachio API worked out yet?

Would this be a good time to purchase and install UltraRachio3?

Thanks for any information.
Reply With Quote
  #66  
Old May 18th, 2018, 10:41 AM
sgottscho sgottscho is offline
Seer
 
Join Date: Dec 2015
Location: Florida
Posts: 11
I am still experiencing the same issues with zone control.
Reply With Quote
  #67  
Old May 20th, 2018, 10:52 PM
mminehan mminehan is offline
Seer Deluxe
 
Join Date: Jun 2011
Location: New Zealand
Posts: 366
Seeing as there has been no fix for the zones not turning off with the individual 'zone controls' I have made a work around. Basically an event that changes 'watering state' to 'stop watering'. See attached screen shot.

This might work for others having the same problem.

Marty.
Attached Images
 
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
RainMachine/Rachio/OpenSprinkler mulu Irrigation Discussion 1 December 30th, 2016 03:47 PM
Multiple Rachio Controllers ScottM UltraRachio3 HSPI 1 May 29th, 2016 08:26 PM
Rachio sprinkler controller chewie HomeSeer General Discussion Area 30 May 21st, 2016 10:22 AM
ISY Plug-in not communicating straydog99 ISY Plug-in Beta (3P) 15 May 4th, 2010 10:55 AM
M1 Plug In Stops Communicating mmnissan Elk M1 Plug-In 4 October 30th, 2006 07:33 AM


All times are GMT -4. The time now is 10:35 PM.


Copyright HomeSeer Technologies, LLC