www.homeseer.com    
 

Go Back   HomeSeer Message Board > HomeSeer Products & Services > HomeSeer Software > HomeSeer Amazon Echo Connected Home API

HomeSeer Amazon Echo Connected Home API Discussions related to the Amazon Echo native support for connected home products

Reply
 
Thread Tools Display Modes
  #1  
Old February 5th, 2018, 07:56 AM
pyspilf's Avatar
pyspilf pyspilf is offline
Seer Deluxe
 
Join Date: Nov 2007
Location: Spain
Posts: 385
Checkbox Discovery failed...

Summary, before you read all detail below: Alexa reports "Discovery failed" and no devices are shown.

I am at a loss, don't know what else to try... would love any tips from people who have had the same issue and maybe tried something I haven't...


At the moment I am only trying to use Alexa from my iPhone until I see it works, and then start purchasing echo, dots, etc.


Steps / things I have done:
  1. As a non-US user, I have had to create a myUS postal address, a US Amazon account and a US iTunes account just in order to get the Alexa app on my iPhone (surreal, of course nothing to do with HS, just an anecdote...)
  2. Installed Alexa on my iPhone
  3. Created a myHS account and verified it works correctly (tried remote access a few times and all is fine)
  4. Upgraded HS to v. 3.0.0.409
  5. Added the "HomeSeer Smarthome" skill to Alexa and linked correctly to myHS account
  6. Tried to discover devices --> "discovery failed"
  7. Did all of the following, with no change in result, always "discovery failed":
  • Made sure at least a few devices (simple on/off lights) had voice commands activated
  • Created a user in HS to match the credentials used for myHS and made this an "admin" - not sure if this is required, or if I need a user to match the Amazon Alexa credentials?
  • Made sure control via JSON is active
  • Restarted HS
  • Restarted the computer hosting HS
  • Logged in and out of Alexa
  • Closed and reopened Alexa on iPhone
Would appreciate any tips you may have...

Cheers!
__________________
HS3 Pro Edition 3.0.0.409| Plug-Ins Enabled: Sonos 3.1.0.22, RFXCOM 30.0.0.36, X10 3.0.0.36, IPThermostat 3.4.5.0, Pushover 3P 0.0.0.37, Blue-Iris 3.1.1.24385, Z-Wave 3.0.1.162, BLML2HS 2.0.28.0 | Win 7 32-bit | Intel Atom D2550 @ 1.86GHz 4GB RAM

Last edited by pyspilf; February 5th, 2018 at 06:23 PM.
Reply With Quote
  #2  
Old February 5th, 2018, 06:22 PM
pyspilf's Avatar
pyspilf pyspilf is offline
Seer Deluxe
 
Join Date: Nov 2007
Location: Spain
Posts: 385
I eventually found a way to get the devices discovered, in case anyone else runs across the same issue.

I used the iPhone Amazon app, where you can use Alexa voice control and said "Alexa, discover my devices" - and the devices were found... very odd, but it worked.

Trying on alexa.amazon.com via a web browser also failed...

Have no clue how/why it works now, but happy it does...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
discovery failed Ricky HomeSeer Amazon Echo Connected Home API 2 December 2nd, 2017 05:43 PM
INFO Connection to AirPort (x.x.x.x:5000) failed: Request failed, read error twitchnln AirplaySpeak 4 November 28th, 2014 10:10 AM
Connection failed: Request failed, error 500 Jaco AirplaySpeak 7 July 16th, 2013 03:56 AM
Incomplete discovery Mr_Resistor TWA-Onkyo / Integra Plug-in (3P) 4 February 4th, 2011 05:35 PM
Failed upgrade / Failed building screen CJVann HSTouch™ 0 April 28th, 2010 06:46 PM


All times are GMT -4. The time now is 11:13 PM.


Copyright HomeSeer Technologies, LLC