www.homeseer.com    
 

Go Back   HomeSeer Message Board > Telephone,Text and Email Plug-ins > Telephone,Text and Email Integration Discussion > SMS Gateway (3P)

SMS Gateway (3P) Discussions related to the SMS Gateway third party plugin.

Reply
 
Thread Tools Display Modes
  #1  
Old November 4th, 2015, 04:27 PM
herbus herbus is offline
Seer Plus
 
Join Date: Sep 2005
Location: The Netherlands
Posts: 89
Problems with Siemens M20 modem

Hi,

I'm moving from HS2 to HS3. In my HS2 configuration I used a Siemens M20 modem with the Stipus plugin.
Now moving to the SMS Gateway.

Some strange issues occur:
1. The SMSC number is stored in the HSPI_SMSGW config file but the config screen of the plugin shows nothing. The logging shows when opening the config page: "SMS-Gateway Error Error trying to read the SMSC of your modem."

Name:  Plugin screen.jpg
Views: 73
Size:  113.4 KB

[CONFIG]
DEBUG=true
LOGLEVEL=Debug
LOGTOFILE=False
BAUD=9600
KEEPALIVE=9600
FLOW=RTS
SMSC=+31653131313

2. Sending SMS messages works fine. Although it seems that the plugin is restarting sometimes.
But messages aren't received at all. No reaction, not even in the debug logging. Does the plugin need some AT commands for receiving?

Hope anyone can help me out with these two issues.

Thanks!

Jos

Last edited by herbus; November 4th, 2015 at 04:51 PM.
Reply With Quote
  #2  
Old November 5th, 2015, 04:15 AM
beerygaz's Avatar
beerygaz beerygaz is offline
Super Seer
 
Join Date: Mar 2006
Location: Johannesburg, South Africa
Posts: 1,581
I'm stumped about the SMC issue, let me look into it for you. Does it remain blank even after a restart?

For some Siemens devices I've found you need a Custom Message Receive String. Try adding this in the config page: CNMI=2,1,0,0,1

Please also turn on "Log to file" and if you still have plugin reset/crash issues or the SMSC is not showing up then mail me the two log files created by the plugin in the HS3\Logs folder.

Gavin
Reply With Quote
  #3  
Old November 7th, 2015, 05:03 PM
herbus herbus is offline
Seer Plus
 
Join Date: Sep 2005
Location: The Netherlands
Posts: 89
Gavin,

I've tried the init string without result. Still only sending text messages and not receiving. I keep the error message when opening the config page.
Please find attached the log file, config file and the original file from the Stipus plugin which worked ok with the Siemens M20.
Hope you can help me.
Thanks!

Jos
Attached Files
File Type: zip Gateway.zip (2.2 KB, 2 views)
Reply With Quote
  #4  
Old November 8th, 2015, 09:27 AM
beerygaz's Avatar
beerygaz beerygaz is offline
Super Seer
 
Join Date: Mar 2006
Location: Johannesburg, South Africa
Posts: 1,581
Hi Jos. Can you edit the HSPI_SMSGW.INI file and change Loglevel=Debug please

Then start the plugin. It should create a more detailed log as well as a HSPI_SMS_Modem.log file too, can you send me those please.

You have revealed a bug in the config page that I need to fix, which I'll address as soon as we get over the current 12-hour blackout.

Gavin


Sent from my iPad using Tapatalk HD
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SMS'es with M20 (Siemens) not 100% compatible! Edge SMS Connector 21 May 28th, 2009 10:19 AM
Way2Call and PCI Modem problems TrOjAn HS2 / HSPRO 4 October 9th, 2007 07:24 PM
HomeSeer PCI Modem Problems johnwpb HomeSeer General Discussion Area 21 March 26th, 2005 11:38 AM


All times are GMT -4. The time now is 06:19 PM.


Copyright HomeSeer Technologies, LLC