www.homeseer.com    
 

Go Back   HomeSeer Message Board > Telephone,Text and Email Plug-ins > Telephone,Text and Email Integration Discussion > SMS Gateway (3P)

SMS Gateway (3P) Discussions related to the SMS Gateway third party plugin.

Reply
 
Thread Tools Display Modes
  #1  
Old January 25th, 2017, 04:51 PM
mikee123 mikee123 is offline
Seer Master
 
Join Date: May 2016
Location: London
Posts: 982
SMS received not triggering event

I have a few SMS received events, and they work fine. I have created more, and although I can see in teh log that the message has been received, the event doesnt trigger. When I copy an existing event, disable the event I copied from, and send the SMS, it does not trigger. Extremely weird !

An example of my log:

Jan-25 20:34:29 SMS-Gateway Received SMS message from +44*** : Mike home

Jan-25 20:37:49 SMS-Gateway Received SMS message from +44*** : Mike home

sent from the same number, identical events, the older one triggered, the new one didnt. The new event is a copy, and I have disabled the original to test. And the 20:34:29 did not trigger.

This is the event:
Attached Images
 
Reply With Quote
  #2  
Old January 25th, 2017, 05:05 PM
mikee123 mikee123 is offline
Seer Master
 
Join Date: May 2016
Location: London
Posts: 982
I think I have an idea why. I deleted all events, and recreated them. They work. But if you copy an event and change it, it will not trigger. Create the same event manually and it does.
Very strange. Must be a bug somewhere, my guess would be HS3...
Reply With Quote
  #3  
Old January 25th, 2017, 08:04 PM
petez69's Avatar
petez69 petez69 is offline
Seer Master
 
Join Date: Oct 2005
Location: Alice Springs, Australia
Posts: 781
Mikee

I was going to say delete the event and type it in again. I've done this with a few plugins and found that copying an event works **most** of the time...
Reply With Quote
  #4  
Old January 26th, 2017, 04:44 AM
beerygaz's Avatar
beerygaz beerygaz is offline
Super Seer
 
Join Date: Mar 2006
Location: Johannesburg, South Africa
Posts: 1,581
Mike can you try copy the event, restart the plugin, and then see if your copied event works? It's possible the PI isn't being notified that there are new events it needs to handle.
__________________
Author of Highpeak Plugins
SMS-Gateway Plugin
Blue Iris Plugin
Paradox (Beta) Plugin
Modbus Plugin
Yamaha Plugin
Reply With Quote
  #5  
Old January 26th, 2017, 07:00 AM
mikee123 mikee123 is offline
Seer Master
 
Join Date: May 2016
Location: London
Posts: 982
Quote:
Originally Posted by beerygaz View Post
Mike can you try copy the event, restart the plugin, and then see if your copied event works? It's possible the PI isn't being notified that there are new events it needs to handle.
Ok will give that a try later and report back.
Reply With Quote
  #6  
Old January 26th, 2017, 07:08 AM
mikee123 mikee123 is offline
Seer Master
 
Join Date: May 2016
Location: London
Posts: 982
I just tried, and even after shutting down the plugin and restarting it still doesn't trigger. So I guess its just create new events for the time being.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Event "X10 Received - L4 ON" triggers when L14 ON received [resolved in v3.0.0.40] Mike Johnson HomeSeer X10 Plug-in 12 December 21st, 2016 12:30 AM
How to run event when the same value is received twice (fixed) The-Source HS3 Event Clinic 0 October 31st, 2015 08:24 AM
x10 received not triggering Raptor HomeSeer General Discussion Area 4 September 4th, 2013 10:23 AM
X10 Received event trigger failing Uncle Michael HS2 / HSPRO 0 October 29th, 2009 09:03 PM


All times are GMT -4. The time now is 06:25 PM.


Copyright HomeSeer Technologies, LLC